Touch scrolling unreliable



  • Anyone else having odd problems with touch-based actions? It seems like some websites (Facebook, Tweetdeck) are now ignoring all interactions from the touchscreen. I can't scroll or follow links by tapping the screen on sites where it's broken. Oddly enough, if it works on a site, it works 100%. But on sites where it doesn't, it works very sometimes, and then not for long. I've filed a bug, but was curious if anyone else is seeing this. Surface Pro3, Windows 8.1, also I have Ghostery installed, but disabling it makes no difference. Touch is fine in other apps an in Vivaldi's own UI (e.g. tab switching). Wade.



  • I am experiencing the same issue on a Surface 3 using Vivaldi 1.0.425.3, touch works on some web sites and on some it doesn't.

    What's odd is if you do a Find in Page (Ctrl+F) all the web sites that are effected by the Touch not working will now work.

    But if you close the Find in Page they stop working again.



  • Two or three updates later and touch is still not working reliably. Usually, if it works on a site, it always works on a site (e.g. Vivaldi forums). If it doesn't, then it usually doesn't (Facebook, Tweetdeck). Touching the tabs to move between tabs always works.

    The trick another member suggested is not quite so useful, either. Now, on a site that doesn't do touch properly, open a Find In Page (Ctrl+F) and touch all works again! But only in that window. And some pages (Tweetdeck) don't work if there is a Find In Page open in another window, whilst that doesn't bother Facebook.

    Wade.



  • Thanks for letting us know about this and sorry for the troubles. The dev team is looking into it. Thanks for your patience. :)
    Please watch out for VB-14424 in future snapshots.



  • I am having the same issue. Surface Book, Windows 10 Pro. Just started on Vivaldi and so far can't use touch screen for cnn, google, getpocket.



  • Same thing here, with an ASUS T100HA using Win10 in tablet mode. Some sites work, some don't. On some sites the touch control gets lost after some time while data is still being downloaded. All since I updated to Rev 1. I thought it was the adblocker, but no, as I uninstalled it and nothing changed. Can't use the touch input in the active window. I can still select in the UI menus though. So it's as if the active window does not let the touchscreen input. if the keyboard is attached on, its touchpad works fine.

    So I'll keep looking for new updates. Unless I can revert to a previous version.



  • I'm experiencing the same problem on my Surface Pro 4. Some pages work perfectly fine. Others don't recognize a single touch input. As soon as I use the keyboard cover it works fine with it (not with touch input though).

    Back to Opera for the time being I guess.



  • Just wanted to add a "me too". I'm on a surface pro 3 and I find that scrolling with touch works for a while and then suddenly seems to stop working for no reason on the same page.



  • Same very odd and inconsistent behavior on Acer S7 Win10. Sidebars, tabs - touch works, but no touch/scrolling/screen gestures in most main browser windows. Example: msn.com



  • It's still not working right in 1.0.435.42 () (32-bit)

    additionally, some website elements - this very text box for one, and DuckDuckGo's hamburger menu bar - don't accept touch input until the 'Ctrl+F' trick - or 'Icon > Edit > Find in Page', for complete freedom from keyboards - is used (actually, the DDG menu still doesn't…)



  • Same here (Windows 10 Pro 64 bit, 16 GB RAM), in “Tablet Mode” als well as in keyboard-attached (non-tablet) mode:
    Finger touch actions on a lot of pages often unreliable, while Wacom digitizer pen works perfectly.



  • I got the same problem on my surface pro 3.
    Touch not working on most websites.
    I could barely live with the fact that pinch to zoom still isn't implemented, but touch not working altogether is a bridge too far for me.
    I switched back to Chrome…



  • Just updated to stable version 1.1, problem not solved up to now.



  • Also having issues. Touch support is pretty bad.





  • It's fixed! It's fixed! They fixed it in Developer Build 1.2.490.3! They even listed my bug number! :-D

    Thanks Vivaldi Team!

    Wade.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.