[solved] Make Thunderbird open links in Vivaldi



  • I set my default browser to Vivaldi. When I click on an HTML file in Dolphin, it opens in Vivaldi, but when I click on a link in Thunderbird, it opens in Firefox. How do I fix this? I didn't see anything obvious in Thunderbird Advanced Preferences. Thanks. Joe Vivaldi-beta 3 / Kubuntu 12.04 with backports / KDE 4.14.2 / Thunderbird 38.6.0 / Firefox 45.0



  • Hello,

    It's not on Thunderbird's side but more a KDE setting.
    I don't use KDE, but on MATE (based from GNOME 2) there is a setting screen "Default applications" where you can set the default browser for web pages, default mail client, … And this works with Vivaldi. Thunderbird opens links in new tab.

    Here is KDE's doc about this : https://userbase.kde.org/System_Settings/Default_Applications



  • That's what I meant by "I set my default browser to Vivaldi." I did that first before posting. That's why Dolphin did the "right" thing. For some reason, Thunderbird appears to be ignoring that setting.

    I have my beefs with Mozilla, but I don't think they're evil and doing it on purpose.

    Joe


  • Moderator



  • I'm not a thunderbird user, so I haven't tried it for a long time.
    In thuderbird go:
    Edit –> Preferences --> Advanced
    Search for those entries:
    network.protocol-handler.warn-external.http
    network.protocol-handler.warn-external.https
    network.protocol-handler.warn-external.ftp

    Make them true. And add a string. Point it to the place of your executable(browser) e.g. /usr/bin/vivaldi-snapshot



  • Thanks. That fixed it. After making those config setting changes, I clicked on a link and it asked me what app to use. I told it /usr/bin/vivaldi and all was good.



  • It didn't give me anywhere to add a string, but when I clicked on a link it asked me what app to use and I told it there.

    I did this many years ago when I was getting Firefox and Thunderbird to work together on Win 98. Seeing those settings reminded me of it.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.