Zoom too often



  • I have been having a problem with the Mac version of Vivaldi for many snapshots. The problem does not happen in Opera, nor in Chrome. If I navigate to an url with Apple's wireless mouse while pressing the Command key, the page zooms. Sometimes it zooms with the Command key held down and the mouse not touched. I have the settings for the mouse gestures turned off. What else can I do to make this distracting behaviour stop? I tried switching to a Logitech USB mouse. The problem was lessened, but there was a fresh problem. Clicking on a url often opened two tabs instead of one! I could go back to using Opera, but would prefer to use Vivaldi.



  • I also have this problem, using a rMBP with El Capitan (and its trackpad). It gets annoying, since I'm closing my tabs Cmd+W almost always…



  • Even with a trackpad, zooming is a bit nervous. I figured I would get used to it, but it seems old habits don't go away that easily.



  • This is still a problem and may prevent me from keeping Vivaldi as my main browser on the Mac.

    Maybe it is time to go back to Opera with built in adblocking (but not yet very effective) and a built in VPN.



  • This is still a problem.

    I find myself now using Opera on the Mac but Vivaldi on Windows.


  • Moderator

    With "Apple's wireless mouse" you probably mean an Apple Magic Mouse (1 or 2; the ones with a touch-sensitive surface) and not a Mighty Mouse (the one with the little scroll ball) or an Apple Wireless Mouse (the simple two button mouse that was discontinued in 2006), is that correct, scamidge?

    Web page zoom is triggered by a scroll event when the Command key is held down at the same time. I open tons of tabs in Vivaldi with Command-Click (or to be more precise: with Command-Tap) on my MacBook Pro's trackpad and I've never ever experienced the issue you have described.

    So it is very possible that the issue is related to the mouse you are using (although tragram seems to suggest that he experiences the issue with his trackpad). Assuming you do have a Magic Mouse, you only use a single finger and not two fingers for scrolling up and down with it, right? If that's the case, it's conceivable that doing a regular click with a Magic Mouse can easily also trigger a tiny scroll event.

    It is then conceivable that Vivaldi has a (much) lower threshold for triggering a page zoom than Opera does, which could explain why you don't experience this issue in Opera.

    That was a lot of conjecture, but to me, this seems to be the most plausible explanation.



  • Thank you very much for your reply.

    I have an Apple Magic Mouse (not sure if 1 or 2).

    I am using a single finger on the mouse for scrolling.

    Your analysis sounds reasonable to me - to test this, I would like the development team to raise the threshold (or allow us to with a preference) to I do not have to see this behaviour.

    I have also noted elsewhere that I also have a Logictech USB driven mouse. If I follow the same behaviour with it, Vivaldi sometimes responds by launching two tabs instead of one.


  • Moderator

    Thanks for providing that information and confirming my suspicion. The sensitivity of the web zoom by touch gesture should definitely be considerably reduced (and a minimum threshold be implemented).

    As cyrano has stated earlier, web zoom is also far too sensitive when you invoke it intentionally via trackpad. When I replied earlier, it seemed a bit sensitive but not very much so on my Mac, which is why I didn't comment on it. I've now realized, though, that that was because my Vivaldi was a bit slowed down by 160+ tabs, some of which were quite resource-heavy. Now that I have freshly restarted Vivaldi, Command-ScrollByTouch is super sensitive and pretty hard to use.

    Recently, there was an issue with two finger swiping on a trackpad being too sensitive. I hope the devs can make the same kind of fix for the web zoom touch gesture.

    I'm not sure about your issue with the Logitech mouse. Maybe you can create a new thread about it to see if other people are experiencing it, too. If you do, please include how you actually open the new tabs with the mouse (e.g., via middle-click, via Command-LeftClick, etc.).



  • Thank you for your comments. I hope the devs will act on your suggestions.

    The Logictech issue doesn't happen as often as it used to in prior builds, and have noted it previously. I just control left click on an url. Usually the link launches in a new tab, but sometimes it launches two new tabs. But not consistently.



  • Not sure if its related, however the pinch zoom, no longer works, since two versions ago within Vivaldi.
    I actually went back to Opera because I love that feature when comes to my track[pad.



  • The latest snapshot 1.3.534.3 seems to have fixed the problem!

    Thank you very much to the developers.

    Sorry, I spoke too soon. It is still an issue.



  • Still an issue with today's build.



  • Still an issue with today's build.



  • This issue is the same as
    Disable Zoom when CMD-scroll

    That thread is considered by the admin to be completed and closed the topic.

    Please see above notes - it is still an issue.


  • Moderator

    Yes, the fixed bug that was mentioned in this posting is about web page zoom being triggered erroneously when you hit Cmd during/after scrolling and not about Cmd-Scroll being overall too sensitive.

    That posting also mentions that there is an internal feature request about adding an option to disable Cmd-Scroll altogether (VB-20069).

    Since Cmd-Scroll is too sensitive to be really usable (even for trackpad users), I've filed a separate issue for this (VB-20117), in which I suggested to both implement a minimum scroll threshold that needs to be reached until any zoom is triggered and to increase the amount of scrolling needed per increase/decrease in zoom level.

    If any of those two were addressed, your problem would be solved.



  • Excellent. Thank you very much.



  • The fix included in the latest build has indeed solved the problem. Thank you very much! (This time I waited longer to post as I jumped the gun once before).


  • Moderator

    In the current developer snapshot, there is now also an option "Vivaldi Preferences->Webpages->Use ⌘+Scroll to Zoom Page" that you can disable, should you ever experience this issue again.



  • That is what I used.

    Thank you.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.