Keyboard Issues with Vivaldi !??!



  • Using Vivaldi on sites with forms I am used to "Tabbing" between fields. This no longer works with Vivaldi. Tab key does not advance me to the next field. Oddly enough if I switch to SeaMonkey, FF or Opera I can navigate without issue. Anyone else notice this? Also there is the issue of Vivaldi Hotkeys interfering with GMail Hotkeys... For example to BCC in GMail one hits Ctrl+Shift+B, which in Vivaldi brings up the Bookmarks Bar. This does not happen in other Chromium based brosers with Hotkeys enabled. Vivaldi 1.0.420.4 (Developer Build) dev (32-bit) Revision 086206ef10bc3cef44adb9be6ed9c84d2783f3e8 OS LinuxMint 17.3



  • Works for me, although it curiously does skip the Message field that I'm typing this in. Tried it on several other sites, tab-switching covers fields to type in, radio buttons, drop down menus (although these are not highlighted when selected), etc..

    Vivaldi 1.0.420.4 (Developer Build) dev (64-bit)
    Revision 086206ef10bc3cef44adb9be6ed9c84d2783f3e8
    Running on Mageia 5 64 bit.



  • Still not working here… with newer build.

    Vivaldi 1.0.422.8 (Developer Build) dev (32-bit)
    Revision 086206ef10bc3cef44adb9be6ed9c84d2783f3e8
    OS LinuxMint 17.3

    Works fine on Windows 32bit (Vista).



  • I have the same same issue with keys on Mint 17.3

    It looks like bigger problem with handling keys on web pages, for example:
    [ul]

    • Using Ctrl+Tab successfully cycles thru browser tabs but doesn't move cursor to next field on form.
    • Pressing Backspace in text field on form causes browser to go back to previous page instead of deleting previous character.
    • Pressing Ctrl+B in web-based text editors with support for key shortcuts doesn't bold the font but instead opens Bookmarks (works in other tested browsers and I'm pretty sure it also worked in older versions of Vivaldi).
      [/ul]
      Looks like for some reason browser captures all key presses and executes "global browser actions" instead of the ones expected inside the form fields.

    Vivaldi 1.0.430.3 (Developer Build) dev (32-bit)
    Revision a69719e121cc0c8e5fecfaa65a8366cb65216f3c
    OS Linux (it's Mint 17.3 Rosa 64bit)



  • Yup, +1.

    I've noticed when using Google Mail in Vivaldi on Fedora 23, if you use Ctrl+B to embolden some text you immediately get a Bookmarks tab in your face. I get why this happens, but other browsers seem able to ignore the Ctrl+B in the context of a textarea form field so you don't get the unwanted bookmarks tab appearing when you're actually just editing text.

    I wonder if it's a Linux issue or affects all platforms? Sounds like it might just be Linux (Gnome?) …


  • Moderator

    A implemented Workaround:
    Open Vivaldi Settings -> Keyboard
    [x] Disable keyboard shortcuts

    Now the shortcuts from Vivaldi are gone and you can use your Webapp.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.