Dead zone surrounding 'New Tab' button



  • This UI bug is driving me absolutely crazy. [img]https://zippy.gfycat.com/MammothBlushingBadger.gif[/img] https://zippy.gfycat.com/MammothBlushingBadger.gif There's a space of a few pixels to the left of the 'new tab' button that does nothing when clicked, although the UI responds. This only seems to be the case [b]sometimes[/b], which complicates things further. I find I'm only able to replicate it when I really don't want to. Windows 10 Enterprise x64 En-GB. Vivaldi 1.0.403.24 (Beta 3) (64-bit). Have experienced it since Beta 1.



  • There's a space of a few pixels

    Exactly

    .newtab { background-color:darkgrey; }
    

    [attachment=2816]tabs-2.png[/attachment]
    Attachments:



  • So why does clicking that dead zone make the button respond?
    Can I omit that space, or at the least make it so that the button doesn't respond so I don't expect it to do anything?



  • @5eagull:

    So why does clicking that dead zone make the button respond?
    Can I omit that space, or at the least make it so that the button doesn't respond so I don't expect it to do anything?

    The button changes its size.
    [attachment=2818]pressed.png[/attachment]

    Fix:

    #tabs-container .newtab:active { transform: scale(1.0); }
    #tabs-container .newtab:active svg { transform: scale(.9); }
    ```Details: [Vivaldi UI Customisations](https://vivaldi.net/en-US/forum/all/3073-vivaldi-ui-customisations)
    Attachments:
    ![](https://forum.vivaldi.net/uploads/attachments/72065/pressed.png)

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.