Microphone usage problem



  • I have been unable to use the microphone on a certain site I allowed to use my microphone. Recently Duolingo (Duolingo.com) introduced a new type of question where you are supposed to speak the answer into your microphone. I press the button, but instantly, before I have the chance to even say anything, it says that it couldn't hear me and to try again. The same thing happens the second time I try, and it tells me to just move on. This has happened a variety of times to the point where for now I have disabled the feature. This worked on Google Chrome itself. I figured that since Vivaldi was chromium based it should work as well (I have been using it as my primary browser) but I suppose there is something that they modified that is interfering with the microphone usage. When you go into vivaldi://settings/content it LOOKS the same as Chrome and duolingo.com listed under the exceptions as "allow" I can use chrome as my dedicated Duolingo browser for now, but ideally I would like to use it in Vivaldi which is my primary browser. (I have made a post on the duolingo forums as well) I have not tried using my microphone on another site, as I don't know what other websites use a microphone. This is on Windows 10 Using my headset microphone on my Sennheiser PC 350 SE On board sound card on my motherboard EVGA P67 SLi, using Realtek High Definition Audio drivers.



  • Welcome to the forum FrozenEcho!

    Using the microphone on Duplingo.com is - let's say - not always fun. On Linux Debian based, Redhat based or Arch based I didn't find any browser - plugin configuration bringing the microphone on Duolingo.com to function. On Windows 7, 8.1 and 10 with Vivaldi I can confirm your problem. It was working with the new Opera, Microsoft Internet Explorer and Edge but sometimes even with these browsers it's becoming a painful struggle to finish a lesson. For sure it's not a coincidence Duolingo's forum to be very active on microphone questions ;) and to provide an option to turn it off overall.



  • I don't think it is a Duoligo's issue. I've had the same problem and I tested with the microphone of Google Translate, but the same thing happened again. :(



  • I second this issue - microphone cannot be used on Duolingo.com

    I am using: Vivaldi 1.5.644.7 revision dbe2370e28131630f49822fa82bb7122a5833ca9 (32-bit) on Windows 10 x64.





  • Yes, but the problem seemingly is with Vivaldi, not Duolingo - as @Retroker supposed also...

    Vivaldi doesn't come bundled with Chrome's Flash Player because it (Vivaldi) is based on Chromium, which doesn't include it, right(?) Duolingo uses Flash Player for audio because some browsers do not support audio through HTML5. I have Flash Player installed, and it is listed as a plugin on my plugins page...



  • I had to temprarily disable 'Disable HTML5 Autoplay' extension.
    However, it helped only at playing sound.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.