"Filter Quick Commands" with a lot of bookmarks very slow



  • I just imported all my bookmarks from firefox now "Filter Quick Commands" entry is very slow. It takes about one second to recognize the second keystroke... not really usable anymore. Before I imported the bookmarks it was very fast. Is this something you work on?



  • I too have a lot of bookmarks. Not sure how to find the count, I'm guessing a couple hundred. There is a delay after the first keystroke where the whole application freezes for about 5 seconds. So the "Quick Commands" feature is for practical purposes unusable.

    Not sure what is going on here? Better data structures or string search algorithm needed perhaps?

    Re: "Filter Quick Commands" with a lot of bookmarks very slow



  • @rog1039 Oh, is that why? (I never knew and just decided to ignore the feature.)

    I guess that makes sense given that I have several hundred bookmarks (not sure how to find out how many either).



  • Honestly, I'm not sure if that is the reason but there seem to be several reports on the forum of this issue and the people reporting the issue seem to have a lot of bookmarks (more than 100).

    It's certainly a strange problem to have on a modern computer. I would be less surprised if this were to happen if I had 30,000 bookmarks. I think I only have several hundred so it seems even a poor algorithm should still be so fast as to not even freeze the application so perhaps something else is causing this issue.

    I think the only people who could answer this would be the people who wrote the code for this feature.



  • Already Reportbug it; VB-24920

    Meanwhile, till this got handled, as a workaround;
    Quick Command trick



  • Re: Very slow/unusable "Quick Commands" feature

    I've noticed -don't remember in which version it started- that the Quick Commands box freezes exactly as described on this post from two years ago. I've realized that it happens when I access the History.
    So, F2 works fine until I press Ctrl+H. Then it sucks and I have to restart the browser.
    I am using Windows 7 64bit.


  • Moderator

    @chicodeoli this happens if you have a very large history file. Once you press ctrl+h your full history is loaded. One solution is just to disable history in quick commands.



  • @LonM
    Thank you. It works. Simple, yet not ideal.
    I only noticed a few versions ago. It used to work fine before.
    Maybe it's a buggy thing. I don't know.
    But thanks again. You actually helped a lot. 👍


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.