Import: cannot choose non-default location



  • If the default profile location for a browser one want to import something (e.g. bookmarks) from does not exist, it is not possible to specify a non-default location. The behavior differs from one browser to another. I checked for Opera 12 and Firefox. [b]Opera 12[/b] If the default profile [tt]~/.opera/operaprefs.ini[/tt] does not exist, it is possible to select "Opera 12" in the drop-down list and the checkbox to use the default profile is not ticked (and disabled), but the available button is "Start import" instead of "Choose location", and clicking it shows the import dialog with an ever-spinning wheel, importing nothing, forever. I ran into this problem because on Archlinux, Opera 12 is called [i]opera-legacy[/i] and and uses [tt]~/.opera-legacy[/tt] instead of [tt]~/.opera[/tt] as config directory, whereas Opera-Blink is called [i]opera[/i] and uses the expected [tt]~/.opera[/tt] directory. Symlinking [tt]~/.opera-legacy[/tt] to [tt]~/.opera[/tt] solved the problem (and the importation worked fine, at least for bookmarks and notes; I did not check the passwords). [b]Mozilla Firefox[/b] If the default profile [tt]~/.mozilla/firefox/*.default[/tt] does not exist, the drop-down list does not even propose Firefox for selection. [b]Edit[/b] I just found the mythical bug report page, so I submitted this, and it is now tracked under VB-12931. I'll still leave this post here, as it might be helpful at least for people coming from Opera 12 on Archlinux :) I am not sure whether it is relevant for other distributions as well, but I have seen a few "import does not work" posts, which might caused by this bug. [hr] [table] [tr] [td]OS[/td] [td]Archlinux[/td] [/tr] [tr] [td]Package source[/td] [td][url=http://repo.herecura.be/herecura/x86_64][herecura][/url][/td] [/tr] [tr] [td]Vivaldi[/td] [td]1.0.390.3[/td] [/tr] [/table]


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.