Password manager annoyances



  • Compared to classic Opera, all other browsers have pretty broken password managers - eg. we have some internal sites that are all hosted on the same subdomain, but each in a different directory (https://internal.lan/site1/, https://internal.lan/site2/ etc.). With Opera, if I saved a password on site1, it didn't offer it on site2 and vice-versa, unlike Vivaldi (and other Chromium-based browsers, and Firefox). An additional problem I have with Vivaldi (and other Chromium-based browsers) is my OpenWRT router - if I save the login password there, it will be filled in other forms inside settings, most annoyingly in the WPA key field, overwriting what's already there (which has once locked me out of my wireless network when I didn't notice). I'd really like that instead of filling the forms automatically, I'd have to click a button (or press Ctrl+Enter) before anything is filled, but having a bit smarter algorithm for choosing what to fill where wouldn't hurt either.


  • Moderator

    Yes, that would be a nice-to-have. But…. there are other priorities for Developer Team at this time. Sorry to say.

    Currently you can disable Autofill with settings in chrome://settings/search#autofill

    Does this help you?



  • I tried disabling autofill, but it doesn't seem to have any effect (I tried restarting Vivaldi afterwards, and confirmed that autofill remained unchecked).

    Correction: it apparently has no effect on the two sites example I gave, but at least it seems it's not replacing my WiFi password any more in OpenWRT.


  • Moderator

    @ender`:

    I tried disabling autofill, but it doesn't seem to have any effect (I tried restarting Vivaldi afterwards, and confirmed that autofill remained unchecked).

    Correction: it apparently has no effect on the two sites example I gave, but at least it seems it's not replacing my WiFi password any more in OpenWRT.

    The correct setting is not autofill. It's passwords. Go to chrome://settings/search#pass and you will find the setting to turn off the offer to save passwords.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.