Annoying white flash



  • HI. Whenever I open a new tab, or load a new page, there is a white flash. I prefer use dark versions of sites and that flashes (especially at night) make my eyes hurt. As i know old versions of chromium have that issue, but it was fixed. https://code.google.com/p/chromium/issues/detail?id=1373 I record video for you: https://youtu.be/yH-s97sr30g I would be very happy if you gave me a temporary solution or fix it. Or allow to change the color of this background.



  • may be it is a GPU issue. Yes, sometimes this occur for me, too.
    Try this:
    Edit properties of Vivaldi desktop shortcut with Alt Enter
    Add parameter```
    --disable-gpu --disable-software-rasterizer

    Start Vivaldi with this shortcut
    
    Gone?


  • Sorry for wait.
    No, it not fix it.
    May i change the white color to black or gray?

    P.S. Sorry for my english. Not my primary language



  • I found a solution. but i need ability to change .css parameter which is responsible for the color of this flash. I tried to find it, but seems to be it does not exist.



  • I have this same issue with a white flash, the same thing occurs in Chrome, but not in Firefox.

    Very simple to reproduce and most obvious using dark web pages to test.
    Either:

    • Close a tab, and use Ctrl+Shift+T to undo the close.
    • Using the bookmark bar, open a new tab in the background with Middle mouse or right click -> 'open in background tab'. Switch to that tab at any point in its loading process.
    • With one Vivaldi window open and multiple tabs, close the window and re-open vivaldi. Now switch to any of the background tabs which are yet to be re-loaded.


  • This is still an issue and really needs to be addressed.
    It's causing me headaches with the constant flashing.
    Doesn't happen in Chrome or Firefox.

    Easy way to reproduce the problem is to open dark pages in new tabs and then switching to them with ctrl+tab or by closing the current tab with ctrl+w.



  • --disable-gpu did the trick for me both in the current stable (1.5) and snapshot.



  • @gwen-dragon I've just found your fix and it did work... But hasn't there been any progress on this problem? disabling GPU makes the Speed Dial animations laggy and slow... but enabling it makes the screen flicker white every once in a while...



  • @neltherion No progress yet. They have to fix the new window system for next Snapshot.

    But, be sure, i have a eye on the bug and will ask from time to time as accessability is important.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.