Vivaldi, Web-Panels, Audio, Netflix.

  • Web-Panels & Streaming Audio:

    I was a bit slow to understand web-panels, but for the last few SS's I've been using them LOTS ... they greatly extend V's utility, versatility, & "feel-good factor" for me. One of the sites now living in my panel is
    Mainly I use it only to read the playlist itself, but occasionally I also try to stream the audio from it... but that aspect never works. Til today it never occurred to me that the problem might be specifically the web-panel, & not some sad incompatibility between the site & V per se. I was wrong, it IS just the web-panel. If i view that site in a normal tab, it streams the audio like a champion. I am well aware that at the moment no Extensions seem to work in the web-panels, but surely this is unrelated to Extensions? Is it possible that my pepperflashplugin-nonfree also does not work in web-panels?

    Vivaldi & Netflix: I've completely lost the plot here, regarding if the current official status is that V does or does not fully support NF. Certainly all the early TP & SS's did not play NF, but magically there was a SS quite some time back that did work, then with later SS's it broke again, then more recently another SS fixed it again. However my current [latest] SS version, & as best i recall a few before, also did not work. Is this the accepted wisdom, or do others actually have NF playing in V on Linux? If yes, are there any special tricks I need to do pls? Here's the typical error, whenever i attempt to play anything on NF, in V:

    Whoops, something went wrong... Unexpected Error There was an unexpected error. Please reload the page and try again. Error Code: M7355-1203

    1.0.365.3 (Beta) dev (64-bit) Mint x64 17.3 KDE Name: Shockwave Flash Description: Shockwave Flash 20.0 r0 Version: Location: /usr/lib/pepperflashplugin-nonfree/ Type: PPAPI (out-of-process)

  • Well, about Netflix is not working. They tell me "Netflix is having trouble playing videos on this browser . Make sure you are using the official version of Chrome.". The error code is M7355-1203

  • Hi. Having elicited nought but a Roaring Silence [Manfred Mann ???] on my post here [til you], i instead dived into another thread, from which i did get my answer re NF, & which [after rather a lot of hassle] i do now have working very nicely in my x64 Deb Vivaldi [of course, since then, there's been a whole other non-V hassle wrt NF opting to start actively blocking DNS & VPN services to stop geo-hopping, with said services then making their own workarounds in this apparent incessant whack-a-mole contest].

    Here's that other thread… [clue: most of my hassles were related to my near-pathological desire to [i]avoid having to have Chrome installed onto my SSD, but in the end, given nothing else i tried worked, i surrendered & installed Chrome, then did the other actions advised in the thread, thence NF is good again in V]. As an alternative to the other thread, to save u time, fyi here's my personal solution summary, as saved in my V Notes panel for future self-reference [btw, since i did it there's been one or two more updates of both Chrome & V, but NF has kept working fine in V without me needing to do anything else]:

    **To play Netflix in Vivaldi-Snapshot in Linux x64:
    1. Sadly, Google Chrome-Stable must be on the SSD.

    2. Browse to

    3. Find the latest vivaldi-snapshot-ffmpeg-codecs-xx.0.xxxx.xx-x-x86_64.pkg.tar.xz [eg, vivaldi-snapshot-ffmpeg-codecs-48.0.2564.71-1-x86_64.pkg.tar.xz] & download it.

    4. Go to the Downloads folder, initiate Konsole therein, & run tar xf vivaldi-snapshot-ffmpeg-codecs-48.0.2564.71-1-x86_64.pkg.tar.xz –strip 2 [ie, obviously match the specific file from #3. This step pops out into the folder]

    5. Run sudo install /opt/vivaldi-snapshot/ [This step installs said file into my Vivaldi-Snapshot folder]

    6. Close V if it was open, [re]start it, & now NF should play.

    Nobody has replied to my other questions in my OP, re the web panel… sad.

  • Steffie, thank you for posting this information. Some of us have been waiting for this! puppylinux forum

  • Hi wognath

    I'm very pleased to hear that it now works for you. I cannot take any credit, though it certainly was kind of you to thank me here & there – i merely found the good work of others & "borrowed" it 😉

    You might or might not already be aware that NF recently, temporarily, broke in V again, but it's now all good again... see here if you're interested:

    PS - I really love that "our community" is so willing to help each other. It's nice.

  • Hello Steffie,
    It may give you some vicarious satisfaction to know that Netflix works on my system without Chrome! It's Vivaldi snapshot 422.8, Fatdog 702 on a 2009 Lenovo netbook.

    In PuppyLinux, large apps are often in the form of sfs files which can be loaded and unloaded to the layered file system. With both GC and V sfs's loaded and libffmpeg updated per your instructions, Netflix runs. Then I tried "install /opt/google/chrome/ /opt/vivaldi-snapshot/" and unloaded GC sfs (/opt/google/ disappears from the file system). Netflix still plays :woohoo:, even when the GC.sfs file is deleted and the system rebooted.

    Credit or no, thanks again for posting clear, complete directions for this.

  • Hi again wognath

    Well, ta again for your kindness, but also for your very interesting info. I'm very keen to try it out myself, if i can deduce a Linux Mint [ie, Ubuntu/Debian] equivalent to your PuppyLinux technique. I'm hoping to preface "apt-get" in front of your "install" commands below. Though i love Linux, i'm still not very good with terminal commands yet, so am not willing to do this directly in my main Mint OS. Instead i'll experiment with it in a duplicate Mint installation i run in one of my VMs. I still need to patch V for NF in that VM, b4 i can then try your method. If it works, & lets me remove Chrome, then i'll replicate it in my "real" Mint OS. Thanks.

  • Ha ha, carrying your excellent instructions one tiny step further makes me a champion! I'm glad it worked.

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.