Import certificates?



  • [color=#8800bb]Hi. I need to import a Certificate i've already separately trusted, into V. I can do this in Firefox & Opera12. I can also do it in two chromium-based browsers; Slimjet & Chromium. Re the latter two, i go into [i]Settings[/i], scroll down to the "[i]HTTPS/SSL[/i]" section, click the "[i]Manage certificates[/i]..." button, & therein i can do the importing. The internal page that opens from that button is "chrome://settings/certificates". As far as i can see, V's Settings has no "[i]HTTPS/SSL[/i]" section. When i try the alternative of trying to directly browse to "chrome://settings/certificates", the address automagically changes to "vivaldi://settings/certificates" [unsurprisingly], but the page is blank. If instead i directly try to browse to "vivaldi://settings/certificates", the resultant tab's address indeed bears that name, but the page itself is merely the ordinary V Settings [in a tab, vs my (deliberate) usual habit of accessing Settings in a window]. I note that "vivaldi://vivaldi-urls/" does not include "vivaldi://settings/certificates", but that hadn't initially troubled me once i noticed that the equivalent URLs page in Chromium & Slimjet also oddly omits that URL. Can any clever person here pls tell me what i'm doing wrong / how i can actually import the certificate? [/color] [color=#0000ff]Vivaldi 1.0.365.3 (Beta) dev (64-bit) Revision a001ed347756190e898b9b608f0a8d8a7ca4b959 OS Linux [/color]


  • Moderator

    You can import a cert in Linux Shell. As written in http://blog.avirtualhome.com/adding-ssl-certificates-to-google-chrome-linux-ubuntu is usable for other Linuxes, too.

    certutil -d sql:$HOME/.pki/nssdb -A -t TC -n "Certs Name" -i acert.pem

    But the URL chrome://settings/certificates should work in Vivaldi, there in tab Authorities you can import your certificates
    Works for me with 365.5 on Debian 8 KDE.



  • @Gwen-Dragon:

    … the URL chrome://settings/certificates should work in Vivaldi, … Works for me with 365.5 on Debian 8 KDE.

    Vielen Dank liebe GD. Your info as quoted above really surprised me, because as i wrote before, all my attempts to navigate to that internal link merely gave me a blank tab. The fact you knew it DID work, told me it's MY problem, not a V bug. I knew that i have many Flags set customised away from Default, so i suspected maybe one of my Flags was causing this problem. Sure enough, stupid me had set "Show settings in a window Mac, Windows, Linux, Chrome OS … If enabled, Settings will be shown in a dedicated window instead of as a browser tab. #enable-settings-window" to Enabled. Sigh, what a goose!! After resetting this to Default, all my Vivaldi-URLs now work correctly again, including the Certs page. Yay. Danke schön.

    The link you gave me [thanks] is i'm afraid a bit too tricky for me; i could understand some of it, but a lot went over my head. Can i ask you though… https://www.autistici.org/en/stuff/man_ca/linux.html shows you what i did yesterday, when i had not yet fixed the Flag.
    $ apt-get install ca-certificates
    $ install -m 644 ca.crt /usr/local/share/ca-certificates/autistici-ca.crt
    $ update-ca-certificates
    Can you tell me what is the specific effect of the "-m 644"? I believe it has changed something about permissions in my system, for that Cert, but i don't have a good enough understanding. All i know is that following those Konsole steps last night [still before i'd realised my Flag mistake], V stopped warning me that the A/I pages were insecure, & instead gave me the proper green padlocks.

    Finally, & this is probably unrelated to my OP & instead should be opened in a new topic, but i'm initially putting it here in case editing the Flag somehow caused this… today almost all [but not all] of my many SD thumbnails had disappeared [bummer]. I know for sure they were still good last night, but i can't say for sure if they were wiped today before or after i edited the Flag & restarted V. I thought this bug was fixed a few SS's ago; certainly this is the first time for a few weeks this damn problem recurred for me. I'm now refreshing them all again manually… & hoping they stay put.


  • Moderator

    Oh, i did not know, that the popup did not appear without flag change. On my Debian 8 KDE It worked.
    But fin you found out what it was.

    The flag tells the install program to change the permissions of file /usr/local/share/ca-certificates/autistici-ca.crt to 0644 (-rw-r–r--, Read/Write for Owner, Read for Group and World).
    Thats ok.
    The Shell lines updated your Root CA Certificates and installed one Root CA certificat for Autistici.org
    After this all chromium-like browsers as Opera34 or Vivaldi now know that certificates signed by Autistici.org are safe and have to be displayed with a green lock.

    Please dont fear and ask me more if i dit not explain good enough.



  • Ah, ok good - thank you. Do you happen to know a good link i could have pls, that would list for me all the available Linux permissions, & maybe even typically used values of them? Every now & then i come across examples [like the current one] that my lack of knowledge of this subject disadvantages me.

    You know, it's funny, & i expect the following will seem implausible to you. The other night, when i was still unable to open the V Certs internal page, I tested it out in Slimjet & Chromium, both of which worked fine. As a workaround to not being able to import the Cert directly in V, i ran those Konsole lines you've seen. but V still would not initially give me the green padlock on the necessary pages… despite me restarting V, & even then rebooting Linux. However, over the next couple of hours, i began to notice that V had begun to "accept" some of the Autistici pages, & eventually it happily gave me the green padlock for all of them. But the crazy thing [which makes no sense to me] is that this "acceptance" by V of those pages occurred gradually, incrementally, over many hours, ie, some of the pages at the site were green early on, whilst some others were still "bad", but as time went by, more & more "bad" pages at that site became "green" [compared to Slimjet & Chromium, which were happy from the moment i directly imported the Cert into each of them]. By the following night, after you helped me realise my error with the Flag, V was accepting all the pages at the Autistici site, meaning technically i no longer needed to manually import the Cert into it. Does it make sense that V was so "gradual / slow"? i'm very confused about the behaviour i observed over that period.


  • Moderator

    Tuts about Linux permission:
    https://www.linux.com/learn/tutorials/309527-understanding-linux-file-permissions
    http://www.linux.com/learn/tutorials/760276-how-to-manage-file-and-folder-permissions-in-linux
    http://blog.pluralsight.com/linux-file-permissions
    https://help.ubuntu.com/community/FilePermissions
    http://www.techlila.com/linux-file-permissions/
    http://www.hostingmanual.net/linux-file-permissions/

    –-

    i dont know why Vivaldi showed the acceptance of Autistici certs so late.
    For certificates exists servers telling a browser if a certificate is valid or revoked, may be such servers for Autustici certs were under attack or temprarily not available.



  • Thank you very much for your nice help.



  • Sorry, but this still is not working for me (I mentioned this last year). Makes no difference whether vivaldi://settings are in a tab or a window…


  • Moderator

    Pleas test this:
    Open chrome://settings/certificates in adressbar
    Select tab Authorities
    Hit button import
    Select certificate file
    In popup Certificate Authority do activate [x] Trust this certificates for identifiying websites
    Button OK
    Button Done

    Then restart Vivaldi
    SSL Certificate should work on sites which showed a error before.

    What does not work for you? Client certificates or CA root certificates?
    Which Linux do you have?



  • Sorry I didn't get back before - I didn't have the certificates settings page before, and that now works; and my client certificate is showing. However, when trying to sign in with my WebID, it doesn't produce the pop up to choose my client certificate. This same certificate works in every other browser and has done for years.


  • Moderator

    Sorry to hear about your annoyance. :ohmy:

    How can your problem be tested/reproduced?
    It is not easy to guess without a demo. And it would be better for developers and a bugreport to have more information.



  • I'm always happy to provide a video… note that the certificate is the same, logging into the same site.

    u3lqC5wOg5U


  • Moderator

    Oh your site. What a bad problem, sorry for you.

    Can you please do this for better bug report about this:

    1. Report bug at https://vivaldi.com/bugreport/
    2. Reply to received mail from bugtracker
    3. Add video as attachment, a personal certificate for the devs, the login data for there cert and the URL of your site
    4. The Dev team will get the mail from you into bugtracker

    I hope they investigate and fix it fast.

    Can you please do this for a testcase?

    Thanks a lot that you spent much time to check it.


  • Moderator

    chrome://settings/certicates does only work on Linux!
    On Windows you must use Windows Certificates manager, start it with certmgr.msc



  • This must be a Vivaldi bug. Certificates added to Windows using the Certificate manager (certmgr.msc) are not found by Vivaldi. IE and Firefox work just fine. This is a serious shortcoming that will lead to Vivaldi being kicked out of production workstations.



  • This is bug VB-13456.


  • Moderator

    @muiruri:

    This must be a Vivaldi bug. Certificates added to Windows using the Certificate manager (certmgr.msc) are not found by Vivaldi.

    Please dont hijack this thread.
    This is NOT a Windows thread about Windows certificate problems.
    Here is Linux and certificates!


  • Moderator

    Thanks, you sent us key and URL.

    To stay private for more checking please reply to bug tracker mail and explain how to test the issue with this data?



  • Your response is totally ridiculous. Vivaldi version for Windows should be able to find certificates like all browsers. Merely stating that it works with Linux is pretty much worthless to a Windows user. The development team should either fix it OR provide an interim workaround.



  • Hey Silly Person

    Here's the current thread path for your elucidation: Forum - Vivaldi Browser - Vivaldi browser for Linux - Import certificates? GD was simply, politely, pointing out to you that you are posting in the INCORRECT stream… this is the LINUX one. If you have a problem with the Windows build of V, then you should post it in the WINDOWS Forum stream. How hard is that to comprehend, for dog's sake?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.