Can't set cookies to "session only"



  • Hi, I can't set the cookie preference to "session only". Changing other preferences works, and I can set the cookies to "never", but when setting it to "session only" it resets when I switch tabs or close the preferences. At first I thought it might be a permissions issue (because I use a non-admin windows login), so I made the user profile folder (and subfolders) writable, but it didn't help - and either way it would not explain being able to change other settings. Vivaldi 1.0.357.5 (Beta) (64-bit) Windows 7, running as non-admin user "C:\Program Files\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --disable-translate --flag-switches-begin --flag-switches-end --enable-smooth-scrolling --enable-tab-audio-muting



  • On Windows 8.1 with Vivaldi 1.0.357.5 (Beta) (32-bit) it's the same. The radio button at Settings - Privacy - Cookie Control - Accept Cookies "Session Only" can be switched on but never stays active. After closing the settings window and reopening it the "All" radio button is on again.
    A workaround is going to the page chrome://settings/content and switching on at Cookies the radio button "Keep local data only until you quit your browser". If you take a look at the Settings - Privacy - Cookie Control - Accept Cookies after this change you won't see any radio button to be on. A bit strange, isn't it?



  • Aha, thank you for the workaround :-)



  • @RJules3, I get the same result as you with Win7-64 and Vivaldi 1.0.357.5 (Beta) (32-bit). A curious wrinkle is that when I first read your post, I checked the cookie setting and none of the 3 cookie control buttons were on, though I had selected the session-only one several versions back. After re-selecting sessions-only cookies and closing the settings panel, upon reopening it, the 'sessions-only' setting failed to stick just as you and the OP have described, instead flipping to "all" cookies. Applying your work-around was successful in getting all three buttons to turn off as you pointed out. Indeed this is curious behavior…

    Has anyone yet filed a bug report on this?



  • @Blackbird:


    Has anyone yet filed a bug report on this?

    Sorry, I don't know but I know I didn't. ;)



  • @RJules3:

    @Blackbird:


    Has anyone yet filed a bug report on this?

    Sorry, I don't know but I know I didn't. ;)

    I just submitted one. If it merits an assigned VB bug number, I'll report it here.



  • The bug number for this issue is VB11864.



  • Thanks for bugreport!
    I can confirm the issue and did add a comment in bugtracker


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.