Unable to run Vivaldi beta2 on Puppy Linux [SORTOF SOLVED}



  • I'm unable to run Vivaldi beta2 on Puppy Linux (Precise) I've previously installed pre-beta snapshots on the same system and (having worked around the problem with running as root) they ran OK. I uninstalled and cleaned up before installing the beta. I used https://vivaldi.com/download/stable/vivaldi-beta_1.0.344.37-1_i386.deb. It seems correctly installed in /opt and the link in /usr/bin correctly calls the wrapper script in /opt However all happens when I invoke [i]vivaldi-beta[/i] from a shell window is that the cursor moves down as expected, but nothing appears - no vivaldi window, but more importantly no error messages. This is not a "hang" - I can ctrl-break out and close the window as desired. Other unrelated processes seem unaffected, and the system remains stable. ps/top/htop etc all show vivaldi-beta as running. I've also tried invoking [i]vivaldi-bin[/i] with exactly the same symptoms. I assume there is some library or other incompatibility causing this, but without any error messages to go on I'm struggling to know where to start looking ... any help please?



  • I've recently downloaded the latest full release version and had another go with the same result.

    After a bit of faffing about (and some help from a knowledgeable bod at the Puppy forum) it seems that the problem lies with the sandboxing.

    I can now run Vivaldi under Puppy but only by at least partially disabling the sandbox, thus:

    # vivaldi-stable --user-data-dir /root/.config/vivaldi --disable-setuid-sandbox
    
    

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.