Typing something in address bar will not look up resaults on Startpage.com

  • Whenever i try to look up something by typing it in the address bar, it just directs me to StartPage INSTEAD of looking up the results. It is my default search engine and the ones pre-added work fine. Not sure if this is exclusively a Linux problem.

  • Yes me too. I expect that anything I put in the address bar that isn't a URL should be treated like a search term. When pasting-in an email address Vivaldi translated itinto a URL which is an undesired behavior.

  • hope they fix it soon, or make it an option. Little things like that is nice.

  • This also happens with Windows 7 version. It is one of 2 reasons I do not make Vivaldi my main browser, even in its beta form.

  • Maybe it is not a vivaldi issue, I don't know.

    Here is my how-to search from adress-bar with startpage in Vivaldi properly:

    • open preferences/search (simply hit Alt+p or via the "v"-icon left top). You should see a list of all search engines in your Vivaldi.
    • click "add new search" (or something like that –- as I use the German locale, I don't know how the button is labeled in English)
    • in the field named "URL" insert: >>https://eu1.startpage.com/do/search?q=%s<< (without >> and <<)
    • in the field named "description" you can add for example >>startpage<< (optional)
    • as "shortcut" you can use for example >>s<< (optional)
    • you will probably want startpage to be your standard search - so check the box before "set as standard"
    • hit the button "add"

    This works fine for me in Linux Solydx 64 Bit (Debian based) and Win 7 64 Bit

  • Moderator

    Did youi check papagei2's hint?

    Works for me with Vivaldi 1.0.357.5 (Beta) 64-Bit | Windows 7 | Debian 8 KDE

  • this worked! thank you very much. I put in >>https://startpage.com/do/search?q=%s<< in the URL field instead of yours, considering I am not in the EU.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.