Lost PDF Plugins



  • I used to have plugins for both PDF-XChange Viewer and PDF-XChange Editor. Somehow in recent updates I lost them both, and now have only the Chrome PDF plugin. I tried apply the NP plugins to other browsers from PDF-XChange Editor, but no plugins appeared in Vivaldi. Vivaldi is on the launch button in PDF-XChange Editor, so it clearly knows where the program is.


  • Moderator

    Chromium has stopped support of NPAPI-Plugins, adn as i know PDF-XCahnge has only NPAPI-Plugins (Plugins for Netscape/Firefox).
    Current Vivaldi (with Chromium 47) does not support the type of NPAPI plugins anymore.



  • Thank you for your reply.

    That's unfortunate since the PDF-XChange plugin is customisable, and displays comments, unlike the Chrome PDF plugin.


  • Moderator

    Yes, before ChrOpera and Vivaldi i used PDF-Exchange and liked the plugin. But most useful Netscape compatible plugins are gone on Linux and Windows.

    But the decision of not using NPAPI anymore is more a stability and security decision.



  • Tracker tell me that they would have to completely rewrite the plugins to work with Chrome, so no hope there.



  • The old NPAPI Flash may be deprecated but it looks like Vivaldi is trying to use it.

    From the vivaldi:\about page:

    "<path>Application\vivaldi.exe" –enable-npapi –ppapi-flash-path="<flash path="">"

    If NPAPI is not working it is not because they did not try! :)</flash></path>


  • Moderator

    @Pesala:

    Tracker tell me that they would have to completely rewrite the plugins to work with Chrome, so no hope there.

    I feel ya. PDF-Exchange is the preferred PDF viewer/commenting tool on my system, and I sorely miss it in Vivaldi. But, y'know…"progress." Sometimes I could live without it.



  • The PDF-XChange plugins don't work in Opera 12.17 either, so either way I have to load PDF files in the external viewer. The Chrome plugin is good enough in most cases.


  • Moderator

    @Pesala:

    The PDF-XChange plugins don't work in Opera 12.17 either…

    Really? That's odd. PDF-Exchange Viewer plugin works perfectly in Opera 12.17 here.



  • [attachment=2113]PDF-XChangePlugin.png[/attachment]
    Attachments:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.