Cannot save passwords - OS X El Capitan



  • Dear all, I apologize if this problem is known or already reported but I was unable to find similar topics. My problem is the following: when I start Vivaldi and go to a website, like gmail or facebook, I start typing my login and I am prompted with the popup: "Allow Vivaldi to access Chrome Safe Storage..." at that point I can only press Reject, because clicking 'Allow' or 'Always' does not do anything and the popup stays there...then the popup closes when I click reject, I finish typing my login and password and click "remember password" when prompted... Upon closing Vivaldi and starting it again the story repeats. I tried to deleting the fb password from the keychain, and googled for the same issue, but I cannot find anything... A friend of mine has the same problem, he is also on mac. I am on El capitan and he is on Yosemite. Any idea why this is happening? This browser is awesome, I love it, keep on with the wonderful job devs!



  • Hi,
    I had on El Capitan 10.11.2 a similar issue, downloaded Vivaldi vers. 1.0.344.37 (Beta 2) (64-Bit), additionally I switched off the MagicPrefs application of MagicMouse first, started Vivaldi browser, confirmed "Allow Vivaldi to access Chrome Safe Storage…" and restarted MagicPrefs afterwards again ... solved.

    see also in google "El Capitan SecurityAgent Ignoring user action since the dialog has received events from an untrusted source"

    cheers
    Ron



  • I don't know. For me the allow procedure is no issue, and when I click save password it gets saved. The problem is that it doesn't work anywhere but on vivaldi.com. Most sites only autofill my username, not the password, other sites leave everything blank – although they are all listed in settings.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.