Local images for profile avatar – Vivaldi Browser snapshot 2064.6


  • Vivaldi Team

    Today’s snapshot adds support for using local images for your user profile avatars.

    Click here to see the full blog post



  • First!



  • Third



  • [Screen capture] Not possible to cancel capture with mouse or on touch screen (VB-44466)

    Nice one! I'll have to try that out.


  • Moderator

    Evening version, always welcome.


  • Vivaldi Team

    @legobuilder26: If you click elsewhere on the page (without further movement) it cancels now. If you move further, you just start a new selection as before.


  • Vivaldi Team

    @folgore101: Evening testing from you is also, always welcome! 😉



  • I have some issues with the previous version » Vivaldi v3.4.2059.2 Snapshot

    Hi!
    I want to write and left here some report about some issues,but I encountered another one. xD
    This is the issue when I tried to write here »
    You can not use Incognito mode to comment here. (Maybe it isn't an issue...maybe it's because of the features of the incognito mode. 🙂 )
    But I have 3 more issues or lack of feature (or maybe I missed the settings for them) »

    When you use the search field in the Bookmarks (on the side Bookmarks panel or on the Bookmarks tab) to find a folder or a subfolder you can find that folder and can you select it, but when you want to manually search for a link in that folder, then you can not hold focus the position of the selected folder (example: by expand the folder tree to that subfolder and the links in it) if you delete the searched word/folder name in the search field.

    For example:
    Bookmarks/Game/Steam/CSGO
    I want to find these links in the CSGO folder where I have more than 12 links and other subfolders »
    Steam Community :: Guide :: How to: Scripting, Binds and Configs || https://steamcommunity.com/sharedfiles/filedetails/?id=314801693
    or
    Steam Community :: Guide :: Fixing various game crashes || https://steamcommunity.com/sharedfiles/filedetails/?id=2203518412

    I search for "CSGO" and it find me the subfolder, but I can not hold the focus on it and/or expand the folder tree to search towards manually for the links I mentioned above. These bookmarks have no "csgo" in their name or their url.
    When I delete the search word, then the focus goes back to the root folder of the Bookmarks and not stay on the selected "CSGO" folder. I can not and I do not want to open all the 12+ links, like I can do if I use the Quick Commands feature. With this feature you can open only all the links in the searched folder, luckily it not opens the links in the subfolders of the searched folder. (Though it would be a nice feature to select what to open in the Q.C. as well. 😛 )

    It will be a nice feature to have, if the focus stays on the last searched folder/subfolder after deleting the search word in the search field and/or we would be able to open the folder tree from there and see all its subfolders and bookmarks, and manually search towards for some specific favorites like in my example above.

    I do not use the Notes feature at all, but I can not disable it.
    Can we have the option to completely turn it off (remove its features from the context menu and disable its shortcuts as well, like the Ctrl+Shift+C ,etc.)?

    When you open a Twitch tab, a YouTube tab and some other site without audio and you want to watch the YouTube video, when the Twitch stream is playing in the background if “Prioritize Active Tab” selected in the settings, then the Twitch stream and the Youtube video randomly mute and unmute themselves when you're watching the video. And if you open a new tab via Quick Command/Bookmars/"Open link on a new tab" or duplicate and switch to a website which has no audio then both the Twitch and YouTube tabs unmute themselves. I noticed these issue about several months ago, but after 2-3 snapshot update when it wasn't fixed, I changed the setting to “Play All Audio” and manually mute that tab, which I do not want to hear.
    I tried to reproduce this bug with more then two background tabs and only the firstly opened and the lastly visited have this issue. The third, forth, etc. tabs are muted correctly, as intended.
    If there are more than 2 YouTube and more then 2 Twitch tabs are open then the "random muting" bug is more frequently appears.
    I think these are maybe some prioritizing issues. I do not tested these bugs with other streaming or audio/video sharing or social websites.
    Until you not fix this, I will use the “Play All Audio” setting and mute and unmute the tabs manually when needed.
    Back then, when you added these features to Vivaldi they worked correctly with these kind of circumstances.

    Thanks for the reading. 😉
    Regards,
    cserpete

    ps.: Is it alright to report here these things or I should use the form here »
    Report a Bug | Vivaldi Browser || https://vivaldi.com/bugreport/


  • Moderator

    @Ruarí Of course, it's already in testing. 🚀



  • Thanks now I can use my glorious new avatar in any new testing profile of mine.



  • cool. any word on M3 though?



  • It's just me or uBlock Origin has started acting weirdly after this update? Some annoyances like banners and euro cookie warnings are not removed, restoring settings from the backup txt doesn't work anymore.
    I updated to uBlock Origin development build 1.30.1.5 (beta on github and chrome store) and no change, acts buggy.
    EDIT: I managed to make it work again by manually fiddling with the saved backup settings, by saving a default settings txt and reimporting with a text editor each section from the backup that didn't get reimported; apparently something went wrong and there was some setting that made uBO act weird...


  • Vivaldi Translator

    VB-72508 -> nice



  • I see that the continue running in the background switch is working now (in some way, got a vivaldi icon with menu in the system tray)... or was it always working and it's just the aftermath of an installed extension? I tend to believe the latter. yep false observation


  • Vivaldi Team

    @holly: Getting closer each day now...



  • Please, please, please fix the bug VB-70371, which is preventing me from upgrading to the latest Vivaldi versions! The bug can cause accidental mouse actions and is very troublesome. It seems like an easy bug to fix so please fix it soon!

    https://forum.vivaldi.net/topic/49487/bug-mouse-cursor-position-is-bugged-after-we-middle-click-on-a-webpage



  • @Ruarí Interesting one! Thank you Vivaldi team. 👏🏼



  • What I’d wish to see from Vivaldi is a clear commitment to themes and sync. A good portion of the mods I write addresses fixed colors in the UI and outside sources, like background images. Images are a separate setting and can’t change with the theme, such as patterns or startpage backgrounds. Moreover they are added from the file system and cannot be synced. Please consider making all styling dependent on themes, getting rid of any and all fixed colors and allowing us to save backgrounds, patterns and in this case profile images inside our profile and allow them to sync.



  • I'm not sure where to mention this, but twitter has been a mess on Macos 11 Beta 9. It totally refreshes the screen randomly and enough of these make twitter unusable and I have to go manually refresh it and hope for the best.



  • [Popout video] Allow PiP window to be larger than half the monitor size (VB-72508)

    This is nice; thanks.

    [Popout video] Not available for Dailymotion videos (VB-69364)

    Also nice, & momentarily i thought i might now finally be able to uninstall https://chrome.google.com/webstore/detail/picture-in-picture-for-ch/ekoomohieogfomodjdjjfdammloodeih given it's no longer needed for DM. Sadly however there's still no PiP for https://www.sbs.com.au/ondemand/ thus i do still need this extension [note: you won't be able to test this without a VPN, coz iirc it blocks non-Australian access (also to my HUGE annoyance, i have to disable the V tracker & blocker for this site, & suffer the expletive expletive ads)].



    VB-72731.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.