Tab crashing in latest snapshot



  • Hi guys, since the latest snapshot (1.0.330.3 (32-Bit, Windows)) I'm experiencing some extremely buggy behavior in my favorite browser. It's hard to explain and I guess it's almost impossible to recreate - but since so one else has written about it, I shall give it a try: I launch Vivaldi and everything works fine. I surf a bit, switch through tabs and all and then, all of a sudden, one of my tabs gets broken. Not that fallen-bird-image broken, but completely f*cked up, the tabs content all black with a weird white flicker in the upper right corner (size varies on hovering the tab-close-button) and the window borders apearing like Windows native borders (although that setting is turned off). That tab is now broken, I might enter a new URL, but it won't open anyway. I can close that tab and head on - but usually one tab after the other will be broken (Funny thing is: when I close such a broken tab and restart the browser - it's there again! Not broken, though). I have a suspicion that it happens when I switch a tab, that has active JavaScript running at the moment of switching. But that's not for sure - just a vague suspicion. It only happens to background tabs. It's definetely not a single page issue, since almost every single one of my usually frequented sites has crashed at least once during last week. I reinstalled the entire browser and trashed my personal settings - still the same. On my 64bit system, there are no bugs at all. Sooo.... anyone else? Any idea what might went wrong? Attachments: [img]https://forum.vivaldi.net/uploads/attachments/56127/screen.png[/img]



  • Second this. Same symptoms, except the white squares are on the left (well, next to the toolbar, anyway).

    Truly annoying, I must say, please, please fix this soon.

    Also, them broken tabs – they don't get fully closed. I kept closing them, opening a new tab to re-open the same page, repeated that over and over again, as they kept crashing. At the end of the day I closed entire browser. And re-opened the browser. And guess what, there were about a hundred tabs with the same pages. Every single one that crashed and got closed. They were all there.



  • Whoa, finally! I was getting anxious that this was a special lensaffair-bug :)

    Edit: I can second that weird close and not-close behavior - those broken tabs are never really closed and come up on the next start of Vivialdi.

    I downgraded to Beta yesterday and updated to the new and now latest snapshot (1.0.334.3) today as it came available. So far, so good! That issue seems to be gone with that new version (after about 1 hour of testing).

    Maybe you should try this as well?



  • Nope, I need to correct my last post: It's back (or was never even gone, idk)! The same buggy behavior, black tabs, native windows borders and a weird closed but not actually closed status of broken tabs.
    Now on 1.0.334.3.

    Is there some kind of logfile I can offer?



  • I have the exact same issue. Makes it impossible to use the browser… I have submitted a bug report, but haven't found any useful log or report to attach. Others are also experiencing it: https://vivaldi.net/en-US/forum/vivaldi-browser/7269-bugs-and-feature-wishes-broken-tabs-double-icon-bookmark-folders-customization



  • Windows 7, 32 bit as well?



  • Yep, W7 Enterprise 32 bit (at work, shhh don't tell anyone)



  • I have same bug than topic author but I use 64 bits version (1.0.334.3) on Windows 10 Professional. Note this bug is also present on previous beta version 1.0.330.3. I think correction of this bug should be a priority because it is impossible to use Vivaldi with them…


  • Vivaldi Team

    Hi all,

    thanks for reporting. We trying to find the root of this issue. The problem is - can't reproduce it. If you have some examples with 100% reproducing of this bug - please, let us know.



  • Hi Shpankov,

    thanks for your feedback! As for now, I was not able to reproduce the error in a controlled manner. Is there a way to enable debug logging (or something similar) for Vivaldi?



  • Hi Shpankov,

    Thanks also for your feedback. For me, this bug happens when I use multiple tabs. The active tab is ok. But when I return on a inactive tab, it can be touched or not by the bug randomly.

    Small note, my pc has a Intel Graphic HD 4000, i don't know if it may be linked.


  • Vivaldi Team

    @lensaffair:

    Hi Shpankov,

    thanks for your feedback! As for now, I was not able to reproduce the error in a controlled manner. Is there a way to enable debug logging (or something similar) for Vivaldi?

    You can use standard Chromium debugging commands.

    http://www.chromium.org/developers/how-tos/debugging-on-windows


  • Vivaldi Team

    @kaffeine:

    Hi Shpankov,

    Thanks also for your feedback. For me, this bug happens when I use multiple tabs. The active tab is ok. But when I return on a inactive tab, it can be touched or not by the bug randomly.

    Small note, my pc has a Intel Graphic HD 4000, i don't know if it may be linked.

    Not sure, but thanks for the info!



  • OK, I would gladly help, as this makes me look towards the Chrome icon more than I'd like to. But I have no idea how as well.

    So yes, like mentioned above, this happens to tabs 'below' the current one (the top tab never breaks).They're just black with flickering white squares next to the toolbar (left side in my case, right side in the screenshot above. The address bar is fine, you can easily copy the site url. Most likely if one tab is dead - the ones below it will be dead as well.

    Setup is Vivaldi 32bit, always latest build, Win 7 64 bit, Quad-core proc, 4Gb ram, nvidia 9800 card, vivaldi usually open along with something from adobe suite, outlook, chrome, trillian, skype, usually about 5 tabs open at a time. Also it's a dual-screen setup with Actual Dual Monitor software running. No pattern in the tab crashing, neither in actions, nor pages that are open in them, nor time, it seems completely random.

    If anything else comes into mind where we could help out, please do tell. Any logging options or whatever. I want this gone like a bad dream.

    Upd.: So there it went again, tried to open task manager to see if there's anything of interest there. And entire Vivaldi crashed dead the moment I clicked the mouse button. Not frozen, it was an instant crash and gone.



  • I enabled the logging as mentioned in Shpankov post the other day. It seems some unknown extension crashes:

    [5668:892:1201/085647:VERBOSE1:web_request_time_tracker.cc(186)] WR excessive delays:76
    [5472:7124:1201/085650:VERBOSE1:page_load_histograms.cc(1027)] PLT: 3381ms http://www.golem.de/news/formel-e-roboter-fahren-rennen-1511-117707.html
    [5772:5356:1201/085650:VERBOSE1:ipc_sync_channel.cc(386)] Canceling pending sends
    [5772:7972:1201/085650:VERBOSE1:ipc_sync_channel.cc(386)] Canceling pending sends
    [5772:5356:1201/085650:VERBOSE1:ipc_sync_channel.cc(386)] Canceling pending sends
    [6756:6784:1201/085650:VERBOSE1:dispatcher.cc(468)] Num tracked contexts: 12
    [6756:6784:1201/085650:VERBOSE1:script_context.cc(117)] Destroyed context for extension
      extension id: 
      effective extension id: 
    [6756:6784:1201/085650:VERBOSE1:script_context.cc(117)] Destroyed context for extension
      extension id: 
      effective extension id: 
    [5668:6928:1201/085652:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.getZoom: Unknown error.
        at null. <anonymous>(chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:27:12899)
        at r.createClass._onActiveWebViewStoreChanged (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:27:12981)
        at Object.n.emit (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:6:9272)
        at Object.assign.emitChange (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:25894)
        at n (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:25725)
        at Object.ID_8 (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:26093)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [5668:6928:1201/085652:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.setVisible: Unknown error.
        at r.createClass.componentWillReceiveProps (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:37:19677)
        at v.updateComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18683)
        at v.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18160)
        at Object.r.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:16:8879)
        at Object.s.updateChildren (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:8595)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [5668:6928:1201/085655:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.setVisible: Unknown error.
        at r.createClass.componentWillReceiveProps (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:37:19677)
        at v.updateComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18683)
        at v.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18160)
        at Object.r.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:16:8879)
        at Object.s.updateChildren (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:8595)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)</anonymous> 
    

    My only installed extension is AdBlock - but I'm pretty sure the crashes occured even before I installed that one.

    Is that any help at all?



  • Allow me to update here: I have no extensions installed. None. None whatsoever. Yet the tabs keep dying constantly.



  • I guess almost everything in Vivaldi (or Chrome) is an extension in the backend. Just like the speeddial.

    I just managed to get out another (though similar) logging entry for the buggy behavior:

    [6580:6788:1201/124354:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.getZoom: Unknown error.
        at null. <anonymous>(chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:27:12899)
        at r.createClass._onActiveWebViewStoreChanged (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:27:12981)
        at Object.n.emit (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:6:9272)
        at Object.assign.emitChange (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:25894)
        at n (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:25725)
        at Object.ID_8 (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:26093)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [6580:6788:1201/124354:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.setVisible: Unknown error.
        at r.createClass.componentWillReceiveProps (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:37:19677)
        at v.updateComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18683)
        at v.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18160)
        at Object.r.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:16:8879)
        at Object.s.updateChildren (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:8595)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [6580:6788:1201/124354:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.setVisible: Unknown error.
        at r.createClass.componentWillReceiveProps (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:37:19677)
        at v.updateComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18683)
        at v.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18160)
        at Object.r.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:16:8879)
        at Object.s.updateChildren (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:8595)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [7972:6096:1201/124356:WARNING:keycode_converter.cc(100)] empty code string
    [6580:6788:1201/124356:INFO:CONSOLE(0)] "Error in response to webViewInternal.executeScript: TypeError: Cannot read property '0' of undefined
        at Object.callback (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:40:9688)
        at u (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:40:9443)
        at HTMLDocument.d (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:40:9899)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [6580:6788:1201/124356:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.executeScript: Unknown error.
        at u (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:40:9443)
        at HTMLDocument.d (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:40:9899)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [6580:6788:1201/124356:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.getZoom: Unknown error.
        at null. <anonymous>(chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:27:12899)
        at r.createClass._onActiveWebViewStoreChanged (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:27:12981)
        at Object.n.emit (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:6:9272)
        at Object.assign.emitChange (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:25894)
        at n (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:25725)
        at Object.ID_8 (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:38:26093)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [6580:6788:1201/124356:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running webViewInternal.setVisible: Unknown error.
        at r.createClass.componentWillReceiveProps (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:37:19677)
        at v.updateComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18683)
        at v.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:18160)
        at Object.r.receiveComponent (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:16:8879)
        at Object.s.updateChildren (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:14:8595)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [6580:6788:1201/124356:INFO:CONSOLE(0)] "Unchecked runtime.lastError while running guestViewInternal.destroyGuest: Unknown error.
        at Object.c.processUpdates (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:13:12721)
        at Object.l.dangerouslyProcessChildrenUpdates [as processChildrenUpdates] (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:15:717)
        at s (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js:15:31822)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)</anonymous></anonymous>
    

    I'm pretty sure, that this marks the issue, since it occures right after any tab crash. Well, for me, that is. Seems to me that the tab does not crash in the background, but in the moment it comes back to front.

    Can anyone confirm that?

    (To start Vivaldi in debug mode, just append " –enable-logging --v=1" to your Vivaldi bookmark, so that it looks like this:

    C:\Users\<username>\AppData\Local\Vivaldi\Application\vivaldi.exe --enable-logging --v=1</username>
    ```Then you will get that logfile:
    

    C:\Users<username>\AppData\Local\Vivaldi\User Data\chrome_debug.log</username>



  • Same here. after a while when I have a lot of tabs opened, when I switch between them some squares appear and make my tabs useless, I am experiencing this 2 snapshots ago, but I thought it was only my computer because in a newer machine tis problem do not happen.

    Vivaldi X64 Windows 7 x64


  • Vivaldi Team

    Thanks, guys, we will check it.



  • Yep, can confirm the same error as lensaffair's present in the logfile. And that the error generates the very moment you click on a broken tab (which basically means, that it breaks on focus).

    Actually it ran smoothly for a whole day after restarted into debugging mode. I was getting nervous, that it's not going to crash on me at all, but I guess I didn't have more than 4-5 tabs open until now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.