Issues loading Twitter.com



  • I've recently started having some issues with Vivaldi when trying to load twitter.com for some reason the page will not load at all, I have to close the browser and re-open the browser just to get it to load. I don't know what or why this is even happening, but it must of happened after updating the browser at some point here. I can access the site normally from another browser like Firefox or Brave, or just stock Chromium without issue.

    I opened up the inspector console and all I'm getting is

     HTTP error: status code 401, net::ERR_HTTP_RESPONSE_CODE_FAILURE
    
    DevTools failed to load SourceMap: Could not load content for https://ton.twitter.com/responsive-web-internal/sourcemaps/client-web/vendors~main.e7e20d65.js.map: HTTP error: status code 401, net::ERR_HTTP_RESPONSE_CODE_FAILURE
    
    ondemand.BranchSdk.e3445e85.js:1 GET https://app.link/_r?sdk=web2.52.3&_t=**********&branch_key=key_live_************&callback=branch_callback__0 net::ERR_BLOCKED_BY_CLIENT
    

    f9c0bf3a-2cfc-4d8a-b3e3-d12133459f2f-image.png

    I shouldn't be getting Status code 401, and I'm not blocking content, I did disable adblock on Twitter.com but it made no difference, it still says Blocked by Client error. I don't have anything else that's blocking it. Is there some hidden new setting in Vivaldi that's blocking content? If so how can I remove it or disable it? since it's interfering with sites loading.

    I have tried clearing site data and cookies, but does nothing.


  • Moderator

    I'm running an Ubuntu 20.04 based distro and I'm able to access public accounts fine (I don't have a twitter account). Is it only when you login that you get the issue or does the issue appear on public pages?
    (check https://twitter.com/vivaldibrowser when not logged in)



  • @sirfredrick I tried that out with Private Window and it's the same there when not logged in. Going to any part of Twitter itself seems to be broken and inaccessible within Vivaldi. I just get blank page as if you were viewing about:blank page. It gets the same Blocked by Client error message.


  • Moderator

    @Alkaris said in Issues loading Twitter.com:

    I just get blank page as if you were viewing about:blank page. It gets the same Blocked by Client error message.

    Then one of your extensions or the Vivaldi Blocker blocks something. For the latter please click on shield of address field and check which was blocked.


  • Vivaldi Team

    @Alkaris which Vivaldi version are you on (check on vivaldi://about)? If you're not on the latest 3.3 please update your browser.

    We've received a few reports about similar issues and so far updating the browser has fixed the issue for our users.



  • @Gwen-Dragon

    @Gwen-Dragon said in Issues loading Twitter.com:

    @Alkaris said in Issues loading Twitter.com:

    I just get blank page as if you were viewing about:blank page. It gets the same Blocked by Client error message.

    Then one of your extensions or the Vivaldi Blocker blocks something. For the latter please click on shield of address field and check which was blocked.

    As I previously stated in my original post, I disabled ablockers which made no difference, something else is blocked. I checked the shield icon, and I only see one tracker blocked by Vivaldi for app.link which is associated with Twitter, I added that to the No Blocking policy and yet it still made no difference. Once again I have to reiterate that closing and re-opening the browser makes Twitter load properly the way its suppose to.


  • Moderator

    @Alkaris Which Vivaldi version (see vivaldi://about) do you have?



  • @Gwen-Dragon said in Issues loading Twitter.com:

    vivaldi://about

    I think you mean vivaldi://version

    Vivaldi 3.1.1929.45 (Stable channel) (64-bit)
    Version 83.0.4103.119 (Official Build) (64-bit)


  • Vivaldi Team

    @Alkaris, you're 2 versions behind. The latest is Vivaldi 3.3, so please update the browser and check Twitter then.
    Most, if not all, users, who reported the issue, have confirmed that Twitter loads fine after updating.



  • @jane-n I can't see an update for my distribution, I'm using Manjaro. This is the current version available to me.


  • Moderator

    @Alkaris Tell us how you have installed Vivaldi?
    Do you use a special repo?

    Vivaldi is maintaied for Arch Linux by @BlackIkeEagle.
    Arch repo: https://repo.herecura.eu/herecura/x86_64/

    You need to edit the config for pacman.

    @Steffie said in Vivald ffmpeg-codecs downloading alot of things not sure if it's normal:

    @Priest72 said in Vivald ffmpeg-codecs downloading alot of things not sure if it's normal:

    Have you tried just downloading the vivaldi deb.file from the vivaldi site.?

    With respect, that simply cannot work. OP uses Manjaro, not Ubuntu/Debian. Manjaro is Arch-based, thus uses a fundamentally different package management system & tools. In MJ/Arch we do not install rpm or deb files, the process is very different.

    As a further alternative to AUR, wrt using the herecura repo as an edit to /etc/pacman.conf, one could instead manually download the compiled compressed tar file from the repo's website https://repo.herecura.eu/herecura/x86_64/. Personally i continue to consider adding the repo to the conf file the superior method.

    # Added 21/1/18 by Steffie, for direct [non-AUR] pacman access to Vivaldi [SS & Stable] + their ffmpeg codecs.
    [herecura]
    Server = https://repo.herecura.be/$repo/$arch/
    
    


  • @Gwen-Dragon Apparently I installed some other version of Vivaldi that was there in the repo, it was called Vivaldi (Stable), not the one you mentioned though. I've fixed that now by removing that one and replacing with the other.



  • @Alkaris : Had the same issue with Vivaldi 3.1.1929.45-1. The issue was fixed after updating to 3.3.2022.45-1.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.