Android版:特定のサイトでリンクを踏む度にタブ内ページバーが上がって行く



  • 環境
    Android版 Vivaldi 3.2.1996.30 安定版現時点最新かと思われます

    再現手順(ステップ・バイ・ステップ)
    1.任意のタブに複数のタブ内ページを作ってある状態にする
    2. 同一タブ内でhttps://twilog.org/roprossを開く
    3.2のページの任意のリンクをタップして開く

    本来あるべき挙動
    リンクが別ページ等で開く

    実際の挙動
    リンクは別ページで開くが、同時にタブ内ページバー?(正式な名称が調べても出てきませんでした、申し訳ございません)が上がっている。
    再度繰り返すとどんどん上がっていき、最終的にページの上部に到達する。

    補足情報
    広告トラッカーブロッカーは無効にしました。
    最近使い始めたのでいつからかはわかりません。このサイトの他のページでも起こるようです。他のサイトでは詳しくは確認していませんが、こうならないサイトもあったのですべてのサイトで起こるわけではないようです。

    又、上がったタブ内ページバーは
    1.タブ一覧ページをタップ
    2.Android付属の戻るボタンで戻る、又はタブ内ページを選び直す
    事でもとの位置に戻ります。

    不具合報告が不慣れで、できる限り画像を添付しますが、もし不備や失礼、先例がありましたら申し訳ございません。よろしくお願いします。
    ![3_1599715621456_Screenshot_20200910-141605_Vivaldi.jpg](Uploading 100%) ![2_1599715621442_Screenshot_20200910-141619_Vivaldi.jpg](Uploading 100%) ![1_1599715621431_Screenshot_20200910-140326_Vivaldi.jpg](Uploading 100%) ![0_1599715621375_Screenshot_20200910-141555_Vivaldi.jpg](Uploading 100%)



  • すみません、画像が送れてないのか表示されてないようで……
    もう一度試してみます。駄目でしたらすみません……
    ![3_1599715992503_Screenshot_20200910-141605_Vivaldi.jpg](Uploading 100%)
    ![2_1599715992486_Screenshot_20200910-141619_Vivaldi.jpg](Uploading 100%)
    ![1_1599715992469_Screenshot_20200910-140326_Vivaldi.jpg](Uploading 100%)
    ![0_1599715992430_Screenshot_20200910-141555_Vivaldi.jpg](Uploading 100%)



  • Screenshot_20200910-141605_Vivaldi.jpg

    Screenshot_20200910-141619_Vivaldi.jpg

    Screenshot_20200910-140326_Vivaldi.jpg

    今更ですが恐らく画像をあげられる気がしたので……よろしくお願いします……。あげられてなかったら申し訳ございません……
    直近のアップデートでも修正はされてない模様でした。
    又、このページバーはページバーを隠す設定でも隠れず、ページの最下部が隠れてページの一部が見ることができない模様でした。せめて表示させないような設定が欲しいです……


  • Vivaldi Team

    @axyu

    報告並びに詳細画像の提供、ありがとうございます🙂

    画像から判断するに、私たちが提供していない機能のようです。
    flag を用いて UI を変更されていますでしょうか?

    flag は Vivaldi では正式に対応していない他、Chromium 側のものであるため、意図しない挙動があっても不思議ではありません。
    あくまで開発途中の機能となっているため、私共では対応できかねます。ご了承ください。

    また、flag によって予期せぬ不具合を引き起こす可能性もあるので、正式には使用はお勧めはしておりません。
    ご使用の際はご自身の責任と判断にてご使用いただければと思います。

    もし flag をお使いでない場合、アプリを再インストールしていただき、
    全ての flag をデフォルトに戻した状態で本挙動が確認できるか、再度ご確認いただければと思います。



  • ありがとうございます。flagというものを初めて知り、もちろん使った覚えもありませんでした。インストールして直後使えていたので標準機能と思い込んでいたようです。Vivaldiをインストールする前はChromeを使っていたのですが、関係あるのでしょうか……(勿論flagらしき設定をいじった記憶はありません……)

    お恥ずかしながら、いつの時期なのかは確定できませんが、(少なくとも私はなんの設定も触ってないと思っているのですが)いつのまにかタブグループが解散し使えなくなり、問題も解消されていました。最初から最後まで何もしていないつもりという返答で申し訳がないのですが、個人的な解決はしましたのでご報告致します。



  • 思い出したので追記します。
    本当にその昨日はインストール直後から使えてたので、本当に見に覚えがないのですが、インストールしてかなり早期に(最長数日内)PCと同期をした覚えがあります。しかし、PCでもflagを変更している記憶はありません。しかし、拡張機能は入れてありました。それが直接flagに関係するかどうかはわからず、すみません……
    どちらにせよ個人的にはflagというものを触ってなくても変更されてしまったという認識でいますが、このような質問をしてしまい申し訳ございませんでした。


  • Vivaldi Team

    @axyu

    とんでもないです、投稿いただきありがとうございます🙂

    意図せず Flag の機能が有効になっていた、という報告が以前何点か挙がっておりました。
    しかしながらどのケースも環境や設定が異なっていたため、原因はわかっていません。
    設定によるものかもしれませんし、端末や他のアプリとの関連によるものである可能性も十分にありえます。

    今後同じような件に遭遇した場合は、vivaldi://flags にアクセスしていただき、
    設定をデフォルトに戻した状態でも継続して発生するか確認いただければと思います。

    *Vivaldi の不具合ではないためトピックを移動させていただきますね。


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.