Insane Lag when opening pages



  • Whenever I open a new tab, input an URL and push enter I have to wait many seconds (usually at least 10-30) before there are even visual cues of the page loading. This is insane and disturbing (alongside the search box losing focus after some seconds i am writing in it). Please fix it! It happens also when inputting an URL in the F2 menu. I believe it is related to DNS lookup and chaching, as subsequent urls of the tab are loaded with human times.


  • Moderator

    @B9K___:

    Whenever I open a new tab, input an URL and push enter I have to wait many seconds (usually at least 10-30) before there are even visual cues of the page loading. This is insane and disturbing (alongside the search box losing focus after some seconds i am writing in it). Please fix it! It happens also when inputting an URL in the F2 menu. I believe it is related to DNS lookup and chaching, as subsequent urls of the tab are loaded with human times.

    This is hard to understand without knowing your version, your platform, your hardware, and whatever extensions you may be running. On my main machine, the delay in opening a new tab is imperceptible. Getting an entire new page to load, including graphics, usually takes less than a second.

    On my oldest, crummiest machine, the performance is similar. On that one, opening Vivaldi from a cold start takes 27 seconds the first time and 12 seconds each subsequent time, it's that weak (it takes 7.5 seconds first cold start with 26 tabs on my main machine) but once it's open, a new page takes 2-7 seconds to load completely, graphics and all. That machine is 13 years old. Tell us a little more about What you're running Vivaldi on, and how you're running it?



  • I was using v1.0.321.3 on windows server 2012 R2, 64 bit. The page loading problems manifests "randomly" (but mostly when I start the browser).


  • Moderator

    @B9K___:

    I was using v1.0.321.3 on windows server 2012 R2, 64 bit. The page loading problems manifests "randomly" (but mostly when I start the browser).

    Thanks! And the resources on which that OS is running?



  • Also, how many tabs are you asking Vivaldi to open initially (or are already open when you open a new tab so slowly)?



  • I doubt the problem are system resources, however:
    Amd Phenom II X4 3.2 Ghz
    4GB Ram (Corsair XMS3 + Kingston cheap ones)

    Also, how many tabs are you asking Vivaldi to open initially (or are already open when you open a new tab so slowly)?

    Usually no more than 8, but the symptom manifests also with higher numbers.

    Below is an example of the absence of any apparent loading:



  • Could this be caused by an extension? Have you tried turning them off one by one, reloading after each?


  • Moderator

    @B9K___:

    I doubt the problem are system resources, however:
    Amd Phenom II X4 3.2 Ghz
    4GB Ram (Corsair XMS3 + Kingston cheap ones)

    OK - my backup machine, which does not suffer the symptoms you cite, is a 3.4 GHz dual-core AMD Athlon with 4GB of 667 MHz RAM, running Win10 X86.

    So my resources on that machine are less than yours (tho Win10 allocates them better), but it runs faster and more smoothly, and I have not had the "blank page" symptom for several versions now. There has been some optimization since the Beta you are running, so you may want to try the 1.0.330.3 snapshot, here: https://vivaldi.net/



  • I have to agree with the original poster, there is shocking lag every time i click a page. I have only just installed the latest version no plugins, no nothing basically, browser terribly slow, chrome however is perfect.

    nice effort and youre better than firefox but a long way short of chrome.



  • I confirm this one. Sometimes tab takes like 5-10 seconds to begin rendered,
    I sit on Win10 i73520M/8GB



  • Try to use a new profile guys,
    I had mine since some months and tabs took 2 seconds to load.
    I was like " when is optimization coming? " then I saw people having no problems at all.
    I deleted my profile and it started opening tabs in half a second or even less.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.