Vivaldi freezing for several minutes upon searching in history



  • Hi,
    I'm a Vivaldi snapshot user, since the latest update (3.3.2022.35), I'm facing a very annoying issue: when I press <F2> for "Quick Commands" and key in 1 or 2 characters, Vivaldi freezes for something like 2 or 3 minutes. This is not systematic but happens enough to be really a PIA.
    Does anyone else is facing this issue too? I'd like to know before submitting a bug report.
    BTW, this occurred several times since I updated, I had at least 2 Vivaldi windows, with a total of about 40 open tabs.

    It puzzles me as I also noticed a freeze issue with Android version, but usually happens when scrolling. I created a specific topic in Vivaldi Android forum.


  • - Ambassador -

    @TerDale Try disabling some of the options in Settings, Quick Commands. I guess showing all bookmarks and history entries might slow things down.



  • @Pesala thanks. Currently, I'm testing with only 1 extension: SimpleExtManager, disabled any other. I should have done this before submitting this topic 😛
    If it ever happens again I'll follow your advice. though I have all included for a while and didn't face that issue with previous versions. But, anyway, I'll do it if needed.



  • Hi,
    it’s a normal issue for me coz I save all history & have it enabled in the QC. There’s a work-around though: until you open a history page (or panel) in the window, the QC will only list the items you’ve visited in that session (I don’t know exactly if since opening the window or launching Vivaldi, or only in that window or all windows) so it’s much better then. If you need to do a history search, either open a new window and search through the history there, or do so from the address bar.



  • Actually I faced the issue again with (almost) no extension. So, I disabled bookmarks & history from the Quick Commands settings, as suggested by @Pesala. Didn't get the issue again so far, but I'll wait a bit more to claim "victory"...



  • Update on this: I actually confirm that after having disabled bookmarks & history from the Quick Commands settings, the issue is gone. So, thanks to @Pesala for the heads up!
    So, I decided to re-enabled bookmarks first to determine which one (with history) is the culprit. Just done it, will update this thread after a while using this configuration.
    However, I'm betting on History, indeed I just figured out that keying in a search term in History page or panel leads to the same freezed situation. So, the actual bug is likely this one, while facing the freeze with QC would be just a side-effect.



  • BTW, I had "Save browsing history" setting to "1 year", changed it to "6 months" to check if that could be a workaround, but nope. I don't want to lose my whole history, so did try to lower again the value.
    I'll file a bug now that it's pretty clear.



  • "bug report has been given the issue reference VB-71652"



  • Couldn't find if it is possible to change this topic title (is it?), but should be changed to "Vivaldi freezing for several minutes upon searching in history".


  • - Ambassador -

    @TerDale You should be able to edit your first post to change the title.



  • "bug report has been given the issue reference VB-71652"

    Vivaldi support response: "Thank you for reporting this issue. We are aware of the issue and are now looking into it. Please bear in mind that (depending on the complexity) it may take a while for the fix to get into our Stable version. Thank you for being patient with us and for using Vivaldi!"



  • Having the same issue. Is thre a fix on the horizon?


  • Moderator

    @scrutinizer No progress for a fix.

    Workaround is https://forum.vivaldi.net/post/396180



  • also happened for me.

    2nd search in history -- 2nd time browser completely hangs up.

    I am giving up with Vivaldi.. Too many childish bugs.



  • <offtopic>

    Wouldn't adult bugs be a bigger problem? If it's childish, it's not old, and hasn't be around a long time.

    Sorry, it was just hanging there.

    </offtopic>



  • When viewing my history (CTRL+H), Vivaldi quickly becomes unresponsive. Especially when trying to search in my history it completely freezes. Also drains memory and CPU. Is there anything I can do to prevent this from happening? Version 3.3.2022.47 on Windows 10.


  • - Ambassador -

    @MoosMas Reduce the time period for saving history in Settings, Privacy.



  • @Pesala said in Vivaldi freezes when viewing history:

    @MoosMas Reduce the time period for saving history in Settings, Privacy.

    That shouldn't be necessary, I imagine something else is the root cause the OP's issue. I have my history going back to 2016, it never deletes, and I don't experience any freezing of Vivaldi when using it.



  • @MoosMas normally we'd suggest testing in a clean/new profile, but then you won't have your history. One option would be to create the new profile, exit Vivaldi, then copy the History file from your profile into the new profile. If the issue persists in the new profile then it's possible you have some external app interfering or the History file itself is corrupted. That might be the best approach, but at a minimum, disable all extensions and test that way. If it resolves the issue, start enabling the extensions one by one, testing each time until the issue returns to discover the offending extension.


  • Banned

    I clear my History every 2-3 Days. Why keep the paper from laste week? If I want to find something i´m missing - i use a search engine.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.