Vivaldi is not using my DNS?



  • Hello,

    I'm running Pi-Hole as my DNS servers to block ads.
    However, when i'm on my WiFi, i still see some ads in Vivaldi, which i don't see in Firefox.

    I think it has something to do with the Chromium engine.
    There is an topic about this on the Pi-Hole forum: https://discourse.pi-hole.net/t/not-blocking-ad-in-chrome/34890/3

    There they say, you have to disable the option "Use a web service to help resolve navigation errors" or similar"
    However, i don't have this option in Vivaldi.

    I've switched back to Firefox for the time beining, since i can't trust the DNS lookups for Vivaldi.
    Why does it look up sites without using my DNS? It looks like we can't trust Vivaldi when looking up DNS. We don't know where it send the requests to. is it using Google? I choose Vivaldi because i don't want Google.


  • Moderator

    @maartenbrand said in Vivaldi is not using my DNS?:

    when i'm on my WiFi

    Vivaldi uses the DNS of the network which is used to connect.
    Check network route and which DNS your WiFi use.



  • I'm using my own DNS server, that's Pi-Hole.

    Some sites still shows ads.
    When opening the same site in Firefox, i don't have ads.

    So, where does Vivaldi get this ads from?

    I also read something about the QUIC protocol which is used by Google to deliver ads:
    https://brave.com/quic-in-the-wild/

    Is Quic protocol enabled by default in Vivaldi?
    When going go chrome://flags i see the option for Quic protocol is "default". However, is that "On" of "Off"?


  • Ambassador

    @maartenbrand , in vivaldi://flags QUIC is by default, (enabled I think), open the pull down and select "Disabled" and restart Vivaldi.



  • Have you checked where the ads you're seeing are coming from? Sites don't necessarily serve the same ads every page load, nor necessarily from the same ad network even. There are a multitude of reasons that could be the reason why you're seeing ads in Vivaldi but not in Firefox, we don't have enough information to determine the cause.



  • Thanks for all the responses.
    I will test it again the next days. When i have this problem again, i will check where it loads from and will make some screenshots in Firefox and Vivaldi to check the differences.

    If you google for this kind of issues, it looks like it has something to do with the Chromium engine. Maybe it's the QUIC protocol.
    I will set it to default, and disable it when i have an ad on an website to check if it made any difference and will post results here.



  • If you are running piehole you should also disable:

    Support for HTTPSSVC records in DNS.

    While you're in flags


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.