Take a break – Vivaldi Browser snapshot 2020.3



  • @JoshStrobl said in Take a break – Vivaldi Browser snapshot 2020.3:

    they also live south of the equator in Australia

    Conclusive proof: V Devs are blatant hemisphericists! It's scandalous.

    🤪


  • Moderator

    @JoshStrobl Seems some GPU drivers have trouble with Vivaldi or vice-versa.
    I guess (as a test) starting as vivaldi --disable-gpu does not help?



  • @Steffie said in Take a break – Vivaldi Browser snapshot 2020.3:

    surmising that you might be quite enjoying my abject misery

    😧 Never!!

    they also live south of the equator in Australia

    It couldn't be as simple as a language/dictionary setting, could it????



  • So with the next snapshot we’re getting into the future? 😲 I’m really interested how it’s gonna look like… Was there a 2020.8 internal build?

    Just a reminder, VB-70804 is still present. Ctrl-clicking the address while the field is focused behaves as if the cursor was one level deeper.



  • @Priest72 said in Take a break – Vivaldi Browser snapshot 2020.3:

    Not certain if this is related somehow.Whenever i return to my homepage the URL is highlighted blue.Not a world ending issue but thought i would inform the forum.
    i have attached a screenshot.

    capture30080.png

    This is an old bug/feature. Possible workarounds:

    • focus page content on new tab
    • define the homepage with http instead of https (or a similar change that causes redirection)


  • @Steffie I really do 😁 The view from here 🏔 is really great, me feeling like Xerxes 🤴🏼

    (couldn't find the :Zeus: emoticon 😉 )



  • @TbGbe said in Take a break – Vivaldi Browser snapshot 2020.3:

    It couldn't be as simple as a language/dictionary setting, could it????

    Now, i know you were totally taking the piss here, but...

    1. I was already doing some stuff at the time in my ArcoLinux Plasma VM anyway
    2. Absolutely nothing else has worked so far
    3. I enjoy the piss-taking too

    ...so i thought "why not?". This VM had never had V-SS installed before. I added herecura to /etc/pacman.conf in the usual way, Before installing it, i made these changes:
    8c8c20b6-a698-4747-8c4e-f9eae276a31a-image.png

    d5fd7325-4179-4a0e-b145-67293a5331d5-image.png

    ... then logged out & in. Then i installed V-SS with pacman, & still in Yakuake i ran:

    [steffie@ArcoLinuxVM ~]$ vivaldi-snapshot
    Gtk-Message: 21:28:44.806: Failed to load module "appmenu-gtk-module"
    [9971:9971:0826/212844.824970:ERROR:chrome_content_client.cc(347)] Failed to locate and load the component updated flash plugin.
    [9971:9971:0826/212847.505425:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: The message port closed before a response was received.", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [9971:9971:0826/212954.368576:ERROR:CONSOLE(14)] "Uncaught (in promise) TypeError: Cannot set property 'hidden' of null", source: chrome://version/version.js (14)
    
    
    

    Well blow me down, butter me sideways, & call me toast.

    It launched.


    What the very wtf?

    Clearly this was an uncontrolled experiment, so atm i suspect this was a fluke rather than causal. In a few ticks i shall launch one of my other VMs already with V-SS [failed], change the region & language, & then see what happens.


    Update:
    Still in ArcoLinux VM, i returned the Region to Straya, the language to Pommie, logged out/in, relaunched V-SS again from Yakuake... & the damn thing still launched ok. Ergo, whilst i'm damned if i know why it works in this one VM & no where else here, indicatively the Region setting seems non-causal.


    More to come...



  • So - this is new I guess?

    Test1.gif

    The setting in Experiments seems to be gone?



  • @gwen-dragon: That has no effect. I'll relay the backtrace reporting so the affected user can file a bug.



  • @vort: Yeah, that's my point, it's there for what?

    Why i can't post in Snapshot, on Windows i just have Snapshot, on Ubuntu i have both.


  • Moderator

    @Pathduck Yes, I think it was migrated and highlighted find in page results is now the default behaviour



  • @LonM Maybe, just strange there's no mention in the changelog is all. But it's fine. I guess the reason might be for some sites with "hidden" results this might help.

    Another new thing that's already been mentioned:
    1b9c4c0c-ad30-4379-80f7-01b081b72b0f-image.png

    I had a look at this and the class is UrlBar-UrlObfuscationWarning so it can be hidden in custom CSS. But again I assume this is a new Chromium thing they've not removed yet. Because in Vivaldi it shows whether URL obfuscation is enabled or not.

    It really doesn't make sense - why would Chromium first hide parts of the domain name, and then warn users about it. Talk about confusing the poor user... 🤦♂



  • @Steffie said in Take a break – Vivaldi Browser snapshot 2020.3:

    Now, i know you were totally taking the piss here, but...

    Nope - honestly!!
    Once more Aussies reported similar problems, I just thought "there's a (new) straw to grab"!!

    Still in ArcoLinux VM, i returned the Region to Straya, the language to Pommie, logged out/in, relaunched V-SS again from Yakuake... & the damn thing still launched ok. Ergo, whilst i'm damned if i know why it works in this one VM & no where else here, indicatively the Region setting seems non-causal.

    UNLESS.... once installed successfully, all is good?



  • @TbGbe Sit down, breathe steadily, apply mild force to the sides of your head to prevent hyper-inflation, coz...

    You, good sir, are looking like a genius!!

    Now on my Arch KDE VM, which has had V-SS for mega-yonks, but which has failed to launch it for the current & previous versions. I changed the Region & lingo to Full Pommie, logged out/in, attempted the launch from Yakuake [convinced it would fail], &...

    steffie@archlinuxVM[~] $> vivaldi-snapshot
    Gtk-Message: 22:17:17.224: Failed to load module "appmenu-gtk-module"
    [9140:9140:0826/221717.796865:ERROR:chrome_content_client.cc(347)] Failed to locate and load the component updated flashgin.
    [9140:9340:0826/221721.674187:ERROR:database.cc(1692)] Calendar sqlite error 1, errno 0: no such column: etag, sql: updavents set etag = ''
    [9140:9340:0826/221721.674242:ERROR:calendar_database.cc(48)] Calendar DB failed to migrate from version 1. Calendar APIl be disabled.
    [9140:9340:0826/221722.728603:ERROR:calendar_backend.cc(164)] INIT_TOO_NEW
    [9140:9140:0826/221739.550810:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: The message port closed before a response received.", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
    [9287:9289:0826/221804.918997:ERROR:object_proxy.cc(621)] Failed to call method: org.kde.KWallet.isEnabled: object_path=dules/kwalletd5: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
    [9287:9289:0826/221804.919084:ERROR:kwallet_dbus.cc(100)] Error contacting kwalletd5 (isEnabled)
    [9287:9289:0826/221804.919788:ERROR:object_proxy.cc(621)] Failed to call method: org.kde.KLauncher.start_service_by_deskname: object_path= /KLauncher: org.freedesktop.DBus.Error.ServiceUnknown: The name org.kde.klauncher was not provided by .service files
    [9287:9289:0826/221804.919817:ERROR:kwallet_dbus.cc(72)] Error contacting klauncher to start kwalletd5
    [9287:9289:0826/221805.083284:ERROR:object_proxy.cc(621)] Failed to call method: org.kde.KWallet.close: object_path= /mos/kwalletd5: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
    [9287:9289:0826/221805.083337:ERROR:kwallet_dbus.cc(418)] Error contacting kwalletd5 (close)
    
    

    It also launched!!


    I see the calendar reference in the cli, so... i wonder...?


    Just reverted the VM's Region to Straya, logged out/in... & V-SS still launches!

    I cannot pretend i even begin to understand, but your other deduction;

    @TbGbe said in Take a break – Vivaldi Browser snapshot 2020.3:

    UNLESS.... once installed successfully, all is good?

    also looks like it's on the money! OMZ.

    Soooo, that means the time is nigh to try this majik out in my real pooters next...



  • @Steffie
    Posting this from Tower's 2nd-boot; SolydK. Applied Ye Olde Majik Trick, & voila -- Vivaldi 3.3.2020.3 / Chrome 85.0.4183.80. Next stop: another reboot, back into primary system Arch KDE, to do the deed there...



  • @Steffie 🤸🏽 🤹🏻

    Sometimes it pays to ask stoopid questions 🤷♂



  • @TbGbe Back in primary boot Arch now, all Majicked, &... Vivaldi 3.3.2020.3 / Chrome 85.0.4183.80.

    I can't thank you enough! 🤩

    I wonder what the Devs will make of this amazeballs discovery... & which poor widdle ol' fascist country they'll pick on next? 🤪



  • @Steffie Just wish everyone had stuck to "good ole" en-GB 🤣


  • Vivaldi Team



  • @Steffie LOL! You had the solution in front of you from the very beginning, gratz for trying that out, though I'm a bit sad that I can't enjoy more of it anymore 😁


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.