Wie gehen die seitenspezifischen Einstellungen wie beim O12



  • Tag zusammen da mir der O12 langsam doch bei immer mehr Seiten rumzickt, wollte ich mal langsam dauerhaft den Vivaldi auch zu Hause benutzen; im Büro werkelt er schon 1a seit einem halben Jahr als Standardbrowser vor sich hin. Mein O12 ist allerdings recht restriktiv eingestellt: Referer aus, Cookies aus und Plugins aus. Per seitenspezifischen Einstellungen wird es dann wieder eingeschaltet. Nun geht das ja (noch?) nicht so komfortabel beim Vivaldi. Das größte Problem, was ich bisher allerdings habe, dass die Cookies immer gelöscht werden! Und das nervt dermaßen, Logins bei Foren sind da noch das kleinste Problem (auf einer Seite mit 2Faktorauth bekomme ich jedes Mal eine Mail, was nicht schlimm wäre, wenn nicht noch ein angeschlossener Markt mich jeden Tag aufs neue für 7 Tage sperrt). [strike]In den Einstellungen von V habe ich [b]Cookies nur für die Sitzung annehmen[/b] und Drittanbietercookies gesperrt. Bei [b]Ausnahmen für Cookies und Webseitendaten[/b] steht: [i]Host Verhalten[/i]. Ich kann dort aber nichts anklicken oder eintragen. Darunter kommt dann die Cookieübersicht, aber das sind ja nur die aktuellen, oder? Ein Klick auf das x im Kreis löscht diese ja nur, aber "speichert" sie ja nicht. Auf Cookies immer annehmen könnte ich umstellen, aber das behebt ja nicht das Problem, oder?! Und selbst wenn ist das ja nicht die Lösung.[/strike] Ich sehe grade, dass wenn ich auf vivaldi://settings/content wechsel, ich die entsprechenden Ausnahmen eintragen kann! Muss ich das [b][*.] [/b]vor jede URL machen (ich will Cookies für example.com mit allen Subdomains zulassen also trage ich nur [b]example.com [/b]ein, richtig? oder ist dann auch [b]nexample.com [/b]für Cookies zugelassen?). Von meiner jetzigen O12 Installation werde ich dann alle (positiven) Ausnahmen händisch eintragen müssen? Ach, und wo stelle ich ein, dass das Downloadpaneel sich bei einem neuen Download direkt öffnet? In den Einstellungen - Downloads ist der Haken gesetzt, dass das Paneel sich öffnen soll. Oder gibts dazu eine Bugmeldung? Installiert ist bei mir V als Standalone x64 unter C:\Tools. Demnächst würde ich ihn dann normal unter C:\Programme installieren und das Profil entsprechend verschieben (sollte ja kein Problem sein, oder? Ist doch nur der Default Ordner) Ansonsten fehlt mir eigentlich nicht mehr viel unter V. Die Buttons sind ja schon eine schicke Sache unter O12, aber irgendwann sollen sie ja auch im V wiederkommen. Grade Plugins an/aus oder Tab duplizieren geht echt viel schneller mit sowas (per Shortcut geht das ja im Moment auch noch nicht). Und natürlich warte ich auch sehnlichst auf den Mailclient. Danke schonmal für eure Hilfe, das Hauptproblem ist ja erledigt. derDay



  • Zum Downloaden:
    Wenn du das Häkchen bei Download-Paneel automatisch öffnen gesetzt hast, sollte sich das auch öffnen, selbst wenn das Paneele nicht geöffnet/angedockt ist.

    Zum Pfadwechsel:
    Vivaldi deinstallieren, und erneut im gewünschten Pfad wieder installieren.
    Profilordner bleibt unberührt. Ein komplettes Backup kann natürlich nicht schaden.



  • @Admirale!

    Wie kann mein geposteter Text unter dem Mitglied regonn erscheinen?
    Sehr mysteriös! Und nein, ich habe noch nichts getrunken. :woohoo:
    In OneNote ist der Text noch als Sicherung gespeichert. Ich kann mich hier unmöglich irren.



  • den Beitrag von Uwe ignoriere ich mal einfach :lol:

    sowohl bei der Installation im Büro als auch bei mir zu Hause öffnet sich nicht das Downloadpaneel bei einem neuen Download. Daher passiert es mir auch häufiger, dass ich nochmal eine Datei runterladen, weil ich zuerst denke, dass der Download nicht angefangen hat.
    Ich werde am WE meine Installation von Standalone auf normale Installation umstellen, mal sehen, ob der Fehler dann immernoch auftritt.

    Die Sortierreihenfolge der zugelassenen Domains bei den Cookies ist ja auch …sehr eigen! Erst nach Topleveldomain (com vor de), dann nach Anfangsbuchstaben wobei es egal ist, ob vor der Hauptdomain noch eine Subdomain kommt :cheer: Klar, wenn man das verstanden hat, kann man ungefähr schonmal richtig suchen, aber (meiner Meinung nach) ist logisch was anderes…



  • @regonn:

    Zum Pfadwechsel:
    Vivaldi deinstallieren, und erneut im gewünschten Pfad wieder installieren.
    Profilordner bleibt unberührt. Ein komplettes Backup kann natürlich nicht schaden.

    welche Datei beinhaltet die Einstellungen von Vivaldi (Tabsplatzierung, Reihenfolge beim Tabwechsel, Panelposition etc)? Die Preferences Datei ist es anscheinend nicht. Ich würde gerne alles übernehmen (besonders Cookies und Extensions) bis auf die allgemeinen Einstellungen, da ich da ja einen Fehler vermute.
    Ich hatte vorhin Teile des Profils kopiert, anscheinend wurde aber garnix übernommen (z.B. keine Extensions, obwohl ich alle Ordner/Dateien kopiert habe, die mit Extension anfangen).
    Wenn ich das komplette alte Profil an die neue Stelle kopiere, funktioniert Vivaldi wie die alte Standaloneversion.
    Beim O12 brauchte man ja nur die operaprefs.ini löschen, um obigen Fall zu erhalten.

    Kann mir noch jemand erklären, warum das Vivaldiprofil bei Win7 unter AppData\Local liegt und nicht wie bei vielen anderen Programmen unter AppData\Roaming ?



  • @derDay:

    Tag zusammen

    In den Einstellungen von V habe ich Cookies nur für die Sitzung annehmen und Drittanbietercookies gesperrt. Bei Ausnahmen für Cookies und Webseitendaten steht: Host Verhalten. Ich kann dort aber nichts anklicken oder eintragen.
    Darunter kommt dann die Cookieübersicht, aber das sind ja nur die aktuellen, oder? Ein Klick auf das x im Kreis löscht diese ja nur, aber "speichert" sie ja nicht.
    Auf Cookies immer annehmen könnte ich umstellen, aber das behebt ja nicht das Problem, oder?! Und selbst wenn ist das ja nicht die Lösung.
    Ich sehe grade, dass wenn ich auf vivaldi://settings/content wechsel, ich die entsprechenden Ausnahmen eintragen kann! Muss ich das [.]* vor jede URL machen (ich will Cookies für example.com mit allen Subdomains zulassen also trage ich nur example.com ein, richtig? oder ist dann auch nexample.com für Cookies zugelassen?).

    Selbiges Problem hab ich auch mit V1.0.334.3 auf Linux(Manjaro). Allerdings kann ich nicht, auf dem von derDay beschrieben Weg, die Ausnahmen eintragen. Ist das gewollt oder ein Bug?

    Gruß
    DAS Feuerchen



  • @Feuerchen:

    … Allerdings kann ich nicht, auf dem von derDay beschrieben Weg, die Ausnahmen eintragen. Ist das gewollt oder ein Bug?

    Die Seite, auf der diese Einstellungen möglich sind, erreicht man über die URL chrome://settings/content. Vivaldi ändert das automatisch zu vivaldi://… Gibt man aber selbst vivaldi://... ein, kommt man nur auf die Standardseite der Einstellungen. Auf meinem Manjaro System konnte ich die Seite bisher problemlos aufrufen. Ich werde es mit dem neuesten Snapshot später noch einmal testen.



  • @RJules3:

    Die Seite, auf der diese Einstellungen möglich sind, erreicht man über die URL chrome://settings/content. Vivaldi ändert das automatisch zu vivaldi://… Gibt man aber selbst vivaldi://... ein, kommt man nur auf die Standardseite der Einstellungen. Auf meinem Manjaro System konnte ich die Seite bisher problemlos aufrufen. Ich werde es mit dem neuesten Snapshot später noch einmal testen.

    DANKE! Jetzt funktioniert es. Die Info, dass es vorne chrome:// und nicht vivaldi:// heissen muss, fehlte mir. ;)



  • @RJules3:

    Die Seite, auf der diese Einstellungen möglich sind, erreicht man über die URL chrome://settings/content.

    auch ich bedanke mich für die Info, ist mir garnicht aufgefallen.
    Ein weiterer Weg in das Dialogfeld zu kommen: ein Linksklick in der Adresszeile vorne auf die Weltkugel (oder Schloss bei gesicherten Verbindungen) und dann Website-Einstellungen anklicken



  • @derDay:

    @RJules3:

    Ein weiterer Weg in das Dialogfeld zu kommen: ein Linksklick in der Adresszeile vorne auf die Weltkugel (oder Schloss bei gesicherten Verbindungen) und dann Website-Einstellungen anklicken

    Und genau dieser "Weg" funktioniert bei mir leider nicht mehr seit ein paar updates unter Windows 10 64x - Vivaldi 32x, also wenn ich da linksklick drauf mache kommt gar nichts…. :unsure: dachte das es eventuell ein bereits gemeldeter Bug währe... weis dazu jemand genaueres oder bin ich mit diesem Problem alleine?



  • Hier auf meinem Windows 8.1 System mit Vivaldi 1.0.340.7 (Beta) (32-bit) funktioniert der Linksklick auf die Weltkugel oder das Schloss noch immer. Ich habe das nicht konsequent bei jedem Snapshot nachgeprüft, aber mir ist nicht aufgefallen, dass es irgendwann einmal nicht funktioniert hätte. Gleichzeitig glaube ich jedoch nicht, dass es hier ein Phänomen gibt, das wirklich nur ein Nutzer erlebt. :)



  • Ok, nach wenig herumprobieren bin ich darauf gekommen das es mit der "Skalierung der Benutzeroberfläche" (in den Einstellungen zu finden) zusammenhängt.. lässt man die auf 100% funktioniert es wie gehabt, doch wenn man die verstellt tritt oben genanntes Problem auf. (hatte die auf 115%)

    Ich weis das gehört nicht unbedingt hier rein aber:
    Ein ähnliches verhalten hat die Lesezeichenleiste wenn man die Seite zoomt und einen Ordner darin öffnet ist die liste was normal direkt darunter angezeigt werden sollte leicht daneben :silly:

    Getestet auf Windows 10 64x mit aktuellen Vivaldi 32x und 64x…..

    Edit: Die von mir beschriebenen Bugs wurden alle bereits mit Snapshot 1.0.375.3 gefixt. :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.