Can you change blocker level for local files?


  • Vivaldi Translator

    I'm currently writing an API server and for testing purposes I have created a simple .html file for making some basic POST and GET requests. When I tried using this file* in Vivaldi all the requests it tried to make to the API server (localhost:8888) were blocked by Vivaldi's content blocker**. If I clicked on the shield by the address bar there was no option to change the protection level like there usually is. I tried adding exceptions manually through Settings > Privacy > Tracker and ad blocking but couldn't get it to work.

    Entering localhost:8888 directly into the address bar and accessing the server that way worked perfectly fine without anything being blocked.

    So does anyone know if it is possible to change the protection level of local files?


    * The .html file was opened directly in Vivaldi, i.e. using the file:/// protocol, and not through a local server.
    ** It was apparently the Arabic (Liste AR) rule list which caused this issue. I must have enabled that list by accident at some previous time, so I just disabled it and the issue went away. However, it might still be good to be able to change protection level for local files.



  • Uninstall and Reinstall Vivaldi, Try this if does not work, then give me the next problem and i'll be willing to help you out.



  • @e01awunyo said in Can you change blocker level for local files?:

    Uninstall and Reinstall Vivaldi, Try this if does not work, then give me the next problem and i'll be willing to help you out.

    Sorry if you don't understand English here's the Arabic translation for what i wrote before,
    قم بإلغاء تثبيت وإعادة تثبيت Vivaldi ، جرب هذا إذا لم يعمل ، ثم أعطني المشكلة التالية وسأكون على استعداد لمساعدتك.
    qum bi'iilgha' tathbit wa'iieadat tathbit Vivaldi , jarb hdha 'iidha lm yaemal , thuma 'aetani almushkilat alttaliat wasa'akun ealaa aistiedad limusaeadatik.


  • Moderator

    @Komposten said in Can you change blocker level for local files?:

    However, it might still be good to be able to change protection level for local files.


    Thank you for reaching and sorry for the trouble.

    May be this issue is a bug.

    Please read

    carefully and report the bug to Vivaldi bugtracker.

    Again thank you for using Vivaldi.


    [1] Do not forget to attach a testcase (the local HTML file) in a reply.



  • @Komposten So you were able to figure it out?

    Good - did you find the rule in the AR list which blocked your requests? Did you find how the blocked requests looked like?

    It's strange that a blocker list should block requests to localhost and/or a specific port like that.

    Did you try to add just localhost to the exceptions?

    I just tried with the qBitTorrent WebUI running on port 8888 with the AR list enabled, looked like it worked.


  • Vivaldi Translator

    @Pathduck said in Can you change blocker level for local files?:

    Good - did you find the rule in the AR list which blocked your requests? Did you find how the blocked requests looked like?

    Good suggestion.
    The rule that causes this is |http://$image,script,third-party,xmlhttprequest,domain=. Not sure exactly how these rules work, but it looks to me like it blocks all XMLHttpRequests to either all domains or no domain?

    Maybe I should send a bug report to EasyList about that one, unless it's Vivaldi that's misinterpreting that rule.

    Did you try to add just localhost to the exceptions?

    The exceptions are domains which the content blocker should not block requests from, not to. So adding localhost as an exception doesn't do anything since the .html file is not run from localhost.


  • Vivaldi Translator

    @Gwen-Dragon Yep, I'll send a bug report about local file protection level. 👍


  • Vivaldi Translator

    Reported two bugs:

    • VB-70257: Blocker list "Arabic (Liste AR)" blocks requests to localhost
      • The list works in AdBlock Plus without blocking my local requests, so I'm thinking it might be an issue with how Vivaldi interprets this rule.
    • VB-70258: Cannot change blocker protection level for local files (file:/// protocol)

  • Moderator

    @Komposten I confirmed both reports now.

    I am curious what the developers will investigate and say.



  • @Komposten said in Can you change blocker level for local files?:

    The rule that causes this is |http://$image,script,third-party,xmlhttprequest,domain=. Not sure exactly how these rules work, but it looks to me like it blocks all XMLHttpRequests to either all domains or no domain?

    Yeah, that one's way too generic. If I read it correctly, it will block all insecure requests (of the types) on all domains. It's got to be a mistake.

    I think I found the change in the list after some digging:
    https://hg.adblockplus.org/listear/rev/1d16ef0fe0d6
    See lines 46,47...


  • Vivaldi Translator

    @Pathduck said in Can you change blocker level for local files?:

    I think I found the change in the list after some digging:
    https://hg.adblockplus.org/listear/rev/1d16ef0fe0d6
    See lines 46,47...

    Hmm, maybe they accidentally deleted cimaclub.org and didn't realise it? 🤔



  • @Komposten I think these lists are getting so big and so unmaintainable that whoever does the commits has no way of actually verifying that the rules don't break stuff. They're totally dependent on users reporting issues.

    However, they really should have some automatic checking of too generic rules like this.


  • Moderator

    If you find issues with a blocklist, please contact the author of the list first, most list have a issue tracker on Github.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.