Peacock tv not working in V

  • does not work in V. But does in Chrome.
    It Does say it supports Chrome and/or Ff. What would be used besides the user agent string? If V now identifies as Chrome.

    It works until you try to play any movie or tv show in their library.
    You get a a page with a picture of a cat & "something went wrong. Please try again". Also the option to dismiss. (I disabled uBO & native blocker just in case)

    3.1.1929.48 (Stable channel) (64-bit)
    macOS 10.11.6


  • Moderator

    @tonyd1 The service is geo-blocked. I can not test that from EUrope.

  • @tonyd1 said in Peacock tv not working in V:

    The cat is Puss In Boots from Shrek.

    First try I get "Something went wrong.
    Sorry, there was a playback error. Please try again. (2003)"

    Not finding any info about it on (tho they have a lot of peacock facts).

    Just looking at the page source is a browser sniffer

    function goToBrowserWarningPage() {
            window.location.href = '/international/static/31f5a5c/browser/browser.html';
          if (!Array.prototype.indexOf) {
          var minBrowserVersions = {
            Firefox: 65,
            Chrome: 70,
            Safari: 12,
            Edg: 80, // Blink/Chromium
            Edge: 15, // EdgeHTML
          var userAgent = navigator.userAgent;
          var browserName = navigator.appName;
          var fullVersion = '' + parseFloat(navigator.appVersion);
          var majorVersion = parseInt(navigator.appVersion, 10);
          var nameOffset;
          var verOffset;
          var ix;
          // In Edge EdgeHTML, the true version is after "Edge"
          if ((verOffset = userAgent.indexOf('Edge')) != -1) {
            browserName = 'Edge';
            fullVersion = userAgent.substring(verOffset + 5);
          // In Edge Chromium, the true version is after "Edg"
          else if ((verOffset = userAgent.indexOf('Edg')) != -1) {
            browserName = 'Edg';
            fullVersion = userAgent.substring(verOffset + 4);
          // In Chrome, the true version is after "Chrome"
          else if ((verOffset = userAgent.indexOf('Chrome')) != -1) {
            browserName = 'Chrome';
            fullVersion = userAgent.substring(verOffset + 7);
          // In Safari, the true version is after "Safari" or after "Version"
          else if ((verOffset = userAgent.indexOf('Safari')) != -1) {
            browserName = 'Safari';
            fullVersion = userAgent.substring(verOffset + 7);
            if ((verOffset = userAgent.indexOf('Version')) != -1) {
              fullVersion = userAgent.substring(verOffset + 8);
            const errorImage = new Image();
            errorImage.src = "/international/static/e03d0772a85818bd3afd8f2abf7cd8c3.jpg";
          // In Firefox, the true version is after "Firefox"
          else if ((verOffset = userAgent.indexOf('Firefox')) != -1) {
            browserName = 'Firefox';
            fullVersion = userAgent.substring(verOffset + 8);
          // In most other browsers, "name/version" is at the end of userAgent
          else if ((nameOffset = userAgent.lastIndexOf(' ') + 1) < (verOffset = userAgent.lastIndexOf('/'))) {
            browserName = userAgent.substring(nameOffset, verOffset);
            fullVersion = userAgent.substring(verOffset + 1);
            if (browserName.toLowerCase() == browserName.toUpperCase()) {
              browserName = navigator.appName;
          // trim the fullVersion string at semicolon/space if present
          if ((ix = fullVersion.indexOf(';')) != -1) {
            fullVersion = fullVersion.substring(0, ix);
          if ((ix = fullVersion.indexOf(' ')) != -1) {
            fullVersion = fullVersion.substring(0, ix);
          majorVersion = parseInt('' + fullVersion, 10);
          if (isNaN(majorVersion)) {
            majorVersion = parseInt(navigator.appVersion, 10);
          if (!minBrowserVersions[browserName] || majorVersion < minBrowserVersions[browserName]) {

    I wonder if the site is expecting auto play to be enabled (not sure if that is it)

    The tracker blocker looks to be blocking what might be part of the video player or part of the backend:
    by default 2020-07-30 at 7.52.50 AM.png

    Site has some DRM issues:

    vendors~raven-loader.js:1 license request rejected {request: {…}, url: "…ixFIONMIbY-cuV6PsR8r-BOE7h-OJr7CMUcFTLoPjskSJlpGU", headers: {…}, status: 422, statusText: "", …}

    Other things I see in the console:
    by default 2020-07-30 at 8.08.53 AM.png

    The DRM version I have in Vivaldi (via vivaldi://components):
    Widevine Content Decryption Module - Version: 4.10.1610.0

  • @Chas4 What happens if you disable the blocker?

    Very likely that it's the error for the POST to aquire a Widewine license. You need to dig deeper into why the license request is rejected.

    If you can reproduce in a clean profile, open a bug report noting the Widewine failure specifically. Would help if one of the Sopranos located in the US could confirm the issue.

    Does the site require a login/payment to use?

  • @Pathduck I have tried with both V native blocker also uBO turned off.

    "Does the site require a login/payment to use?"

    • Login yes. I have account login
    • payment, for premium version
    • To begin I'm in free offering.

    Able to reproduce in new profile.

    Thanks for spending time & effort

  • Moderator

    @tonyd1 Could you please create a bug report for this issue? There are some US-based Vivaldi team members that should be able to access this site and who can investigate further.


  • @tonyd1 said - Bug report # VB-70228

  • I don't believe this is a geo-location issue as the thread was initiated by someone whom i assume tried both chrome and vivaldi in the same location.

    It seems it cannot be a user-agent issue as vivaldi identifies as chrome.

    So my "opinion" for what it is worth is that there must be a video codec which is google chrome specific,perhaps licensed only to chrome which is missing from vivaldi.

  • Moderator

    @tonyd1 May be a issue in DRM decoding.
    Please check at and if the DRM tagged videos work for you.

    I fear Vivaldi is missing a paid decoder for this Peacock TV stream.

  • @Priest72 Yes this was tried from same US location & both browsers.

    @Gwen-Dragon DRM vids. worked (partial screen shot

    2020-08-01 12.28.21 523f0c5e86bf.jpg

    hope that helps.

    Thank you

  • From castlabs.

    2020-08-01 12.38.53 d228d800becf.jpg

  • @Priest72 It is geo-location as the site is not accessible worldwide and the site is owned by Comcast (one of the biggest ISPs in the US)

    @Gwen-Dragon said in Peacock tv not working in V:

    Both work for me here

    Looking again at the console errors for Peacock I see a Content Security Policy violation

    Refused to load the image '' because it violates the following Content Security Policy directive: "img-src 'self' data: * * * * * * * * * * * * * * * * * * *".

    Error PlayerError(2003/DRM_FAILED_LICENSE_REQUEST) from the code in this javascript file:

    I tested a video in Safari it worked (tho the DRM used is completely different)

  • Moderator

    @tonyd1 Thanks very much for the bug report. I pointed out this issue internally, it has been confirmed and is currently being investigated.

    Bug report # VB-70228

  • Just tested in Opera 70 (Opera also uses Chromium and both Opera and Vivaldi are on Chromium 84) and tried a video and it worked.

    Opera has this version of the DRM:
    Widevine Content Decryption Module - Version: 4.10.1610.0

    With Vivaldi masking as Chrome is the site code expecting something else?

  • @Chas4 My Opera just updated I also can now get Peacock on that browser.

    Thanks for trying that out.

    @Chas4 said in Peacock tv not working in V:

    Opera has this version of the DRM:
    Widevine Content Decryption Module - Version: 4.10.1610.0
    With Vivaldi masking as Chrome is the site code expecting something else?

    Yes what is different?

  • opera=chinese surprised anyone uses it.

  • @Priest72 Most used Browser in China is Chrome (~ 45%). Opera has ~0,3%

    China has a problem for sure - but not because a browser. 🤨

  • Moderator

    MOD says: PLEASE! Stay on Topic, this trhead is not about a Opera issue!

  • Tested in today Vivaldi snapshot 3.3.2009.3

    Looks like it is a DRM issue

    vendors~raven-loader.js:1 license request rejected 
    {request: {…}, url: "…ouaZEpeQgpPj_d0LveyPUAv1w16yiMs9wyfK4-MxKTruaGeSV", headers: {…}, status: 422, statusText: "", …}
    body: ArrayBuffer(0)
    [[Int8Array]]: Int8Array []
    [[Int16Array]]: Int16Array []
    [[Int32Array]]: Int32Array []
    [[Uint8Array]]: Uint8Array []
    byteLength: (...)
    __proto__: ArrayBuffer
    elapsedTime: 0.1747250000044005
    headers: {content-length: "0", x-sky-signature: "SkyOTT client="NBCU-WEB-v4",signature="jEOxZY8RMA3…fElJlyH3mE=",timestamp="1597411483",version="1.0""}
    length: 0
    request: {method: "POST", url: "…ouaZEpeQgpPj_d0LveyPUAv1w16yiMs9wyfK4-MxKTruaGeSV", headers: {…}, responseType: "arraybuffer", credentials: "omit", …}
    status: 422
    statusText: ""
    timeToFirstByte: 0.17470000000321306
    url: ""
    __proto__: Object

    The DRM call looks to be from

  • Comcast has to fix their broken DRM code

    Vivaldi 3.3 still does not work


    Poked Comcast support on Twitter about the site bug

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.