Open Application Warning



  • I had something weird happen that required deleting everything to do with Vivaldi and reinstalling. Ever since then I've had the open application warning dialogue pop up whenever I click on a magnet link for a torrent. I know there is a way to get rid of this on MacOS because I had done it and it was working fine even after updates. But I can't remember how I did it. If anyone can point me in the right direction or show me how this is done, it will be much appreciated.



  • @DDK Hi, this has been changed in newer versions, I assume you still had an old version. The hack of editing the preferences JSON is no longer valid, and the new dialog will ask you if you want to remember the choice:

    1a03f67b-d08a-4b05-8515-a3ec45a28eee-image.png

    You'll have to do this on a per-site/protocol basis though...
    And as is usual with brain-dead Chromium dialogs, there is no way to undo this choice.



  • @Pathduck said in Open Application Warning:

    brain-dead Chromium dialogs, there is no way to undo this choic

    Might be able to in the site settings for that domain



  • @Chas4 I've not been able to find any reference to the sites where I choose the "Always allow..." setting in any of the Chromium settings. Only in the Preferences JSON file.

    This is how it looks in the Preferences file:

    "protocol_handler" : {
    		"allowed_origin_protocol_pairs" : {
    			"https://1337x.to" : {
    				"magnet" : true
    			},
    			"https://btdig.com" : {
    				"magnet" : true
    			},
    			"https://store.steampowered.com" : {
    				"steam" : true
    			}
    		}
    	},
    


  • @Pathduck said in Open Application Warning:

    I assume you still had an old version.

    No, it was definitely a current version. I literally remember checking it just a few days prior to the issues I had that required the complete deletion. And when I reinstalled, I never got a "Always allow..." option like what you're showing.

    Regardless, these constant popups are getting irritating.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.