Resolving Host Issue



  • I am having a major problem on a Windows 10 computer using Vivaldi version 3.1.1929.45, 64 bit. I keep getting a message in lower left corner that says "Resolving host", and it then takes me a long time to get connected to any website.

    I don't have this problem on my primary Windows 10 computer running the same version, 32 bit.

    I would appreciate any help and guidance on how to eliminate this "Resolving host" issue. I'm hoping that it's merely a setting that needs to be tweaked. Thanks in advance.....



  • @Durango38 Welcome to the Vivaldi Community 🙂 👍

    The resolving of host names (like forum.vivaldi.net) to IP addresses (like 104.22.79.179) is done in the Operating System itself. So this is usually a problem in the OS or on the local network, not the browser itself.

    Does this issue only happen in Vivaldi or does it also happen in other browsers?
    How long does it take to connect?
    Do you have any extensions installed, if so try disabling them all and restarting Vivaldi.
    Or try in a Guest Profile if you get the same issue: https://help.vivaldi.com/article/guest-view/

    Sometimes locally installed security software like anti-virus/firewall/parental control/VPN etc can cause these issues.

    You can use a tool like GRC DNS Benchmark to test the speed of your DNS lookups.



  • Thanks for the response Pathduck. Vivaldi is the only browser I use on both my Windows 10 computers. I've never had this Revolving host problem on my primary computer. But I recently acquired a second computer on which I downloaded/installed Vivaldi. That's where my problem is.

    Although I've used Vivaldi for a year or so, I'm not too well versed on it's settings. And I don't know if I have any extensions installed....how would I find out? And I'm not well-versed on DNS stuff. So you might say I'm pretty-much a computer novice and need all the help I can get. What settings should I look for in my OS or my local network to perhaps resolve the problem?

    On the troublesome computer, it sometimes takes 15-20 seconds to connect. I will go there later and try a guest profile and report back. Thanks again.



  • Pathduck, I have no extensions installed. I tried a Guest Profile and did not encounter the issue of Resolving Host. I also ran the GRC DNS Benchmark but I did not understand the results. Any suggestions would be appreciated.



  • @Durango38 If you ran in a guest profile and the problem was gone, chances are something in your main profile is "broken". But there really is no setting that could affect this, as DNS lookups are done on the OS layer. And we want to avoid having to reset your Vivaldi profile to default if we can.

    All Windows systems have at least Edge installed as an alternative browser. Testing in Edge as well will give an indication if the problem lies in Vivaldi or other places.

    You say you have no extensions installed, but to make sure go to the URL vivaldi://system (paste it into the address bar), find "extensions" and click the button named expand. Copy the list that appears and paste it here in a code block like this:

    ahfgeienlihckogmohjhadlkjgocpleb : Web Store : version 0_2
    cjpalhdlnbpafiamejdnhcphjbkeiagm : uBlock Origin : version 1_27_10
    dhdgffkkebhmkfjojejmpbldmpobfkfo : Tampermonkey : version 4_10
    

    When running DNS Bench, the important thing to note is the two bolded IPs, and their response times, as these are your current servers. After running the benchmark, click on them and note the response times. The same data can be found in the Tabular data, just find the IP. Also look at the Conclusions tab and note any warnings you get there.

    These are the numbers I get from my local network router which is how most local networks get their DNS:

      192.168.  0.  1 |  Min  |  Avg  |  Max  |Std.Dev|Reliab%|
      ----------------+-------+-------+-------+-------+-------+
      + Cached Name   | 0,001 | 0,002 | 0,003 | 0,000 | 100,0 |
      + Uncached Name | 0,007 | 0,054 | 0,202 | 0,059 | 100,0 |
      + DotCom Lookup | 0,004 | 0,042 | 0,119 | 0,046 | 100,0 |
      ---<-------->---+-------+-------+-------+-------+-------+
               Non-routable local internet address
                    Local Network Nameserver
    

    It could also be an idea to run the Windows "Network troubleshooter" found in Windows Settings > Network & Internet.

    There could be lots of different reasons why DNS resolving of hosts is slow, so there is no quick fix unfortunately.


  • Moderator

    I sometimes saw such delay while having problems with IPv6 protocol with DNS and my ISP.



  • @Gwen-Dragon said in Revolving Host Issue:

    I sometimes saw such delay while having problems with IPv6 protocol with DNS and my ISP.

    Could be that disabling IPv6 for the network adapter or even on the router (if supported) might help. Problem is, I think maybe IPv6 is required for Windows Update to work correctly. Then again, my old router doesn't support IPv6 at all 😕


  • Moderator

    You should check if Windows automatically searches for Proxy settings. That causes delays, too.
    This might help: Windows Settings > Network and internet > Proxy > Automatically detect settings - Off



  • Thanks for all the above suggestions. I will crank up the troublesome computer later this morning and try them all.



  • It appears that my problem solved itself. The first thing I did was to exit/quit Vivaldi and then restart the browser. The Resolving Host issue and delay no longer occurred. Sometime it's the simplest actions that solve the problem.

    I was prepared to download the current Beta version of Malwarebytes Premium, as I read that it was causing performance problems with Windows 10, version 2004 (which is what I am running). But now there is no need.

    Thanks to all for your many suggestions. I am proud to be a new member of the community.



  • @Durango38 That's great 👍

    A tip; restart your browser once in a while. I know it's tempting to just run it forever and hibernate/sleep the machine, but applications are not made to run "forever". Sometimes they need a restart 😉



  • @Gwen-Dragon Wow! That was it! I turned the damned Proxy varmint off and am sailing into smooth waters! Bless you!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.