Unusual Popup Appearing Several Times



  • I sometimes get a popup asking to allow or disallow notifications from a website. Lately I've been getting them more frequently, sometimes 3 times on the same browsing session /site. The strange thing is the word "notification" isn't always shown. A few moments ago I set Vivaldi to block notifications it was previously set to "ask". Hope everything is ok now.
    message.jpg


  • Moderator

    @techguy88 That is not a web page Notification you can block in Vivaldi Settings > Webpages > Default Permissions.

    It is a permission popup where your banking site asks to access something (we do not know what).



  • When these messages appeared there was no indication of asking me to input anything. The popup would appear on different sites that i have used consistently before without having this popup appearing. I don't think its anything nasty because I am very careful on how I use the computer. Incidentally blocking all "Default Permissions" except sound has stopped (perhaps by coincidence) the popup appearing.



  • @Gwen-Dragon How can you not know what they're requesting permission for? The browser is creating the dialog.


  • Moderator

    @mpen The browser displays the dialog, but does not create it. It's being generated by the site, by an extension, or by malware.


  • Ambassador

    I get this with fb but the pop-up tells me that it wants to send Notifications...
    Other sites (Home Depot, Lowes) give me the blank pop-up. I surmise they are asking for Location Data but since it doesn't show I Deny and select my store manually.


  • Vivaldi Translator

    @greybeard said in Unusual Popup Appearing Several Times:

    Other sites (Home Depot, Lowes) give me the blank pop-up. I surmise they are asking for Location Data but since it doesn't show I Deny and select my store manually.

    Nope, Location works as it should (and has a different icon):
    0afffedb-7b3c-499a-8bdd-9ce1e8d875ff-image.png

    @techguy88 @mpen Based on the icon (puzzle piece) I would guess that these blank popups are asking for access to some kind of browser plugin. Chromium uses a similar icon for the Flash permission (plugin), "Unsandboxed plugin access" permission (whatever that is) and for the Extensions Page (vivaldi://extensions).


  • Ambassador

    @Komposten Not for me...

    Capture.PNG



  • I'm getting the same thing on a multitude of sites, including just now on vivaldi.com:

    89f80587-fbb2-40a4-9ce5-f4afae690cef-image.png

    The two permissions mentioned in the site info popup are motion sensors and flash -- even though I assume neither are being used or requested by vivaldi.com

    531d7614-d9fe-4e90-bef4-3e5c076e2f96-image.png

    These two are actually mentioned on all sites I visit, even ones that don't have a proper index.html.

    It appears that the motion sensors are the ones causing the trouble here. I can't right now reproduce the popup on vivaldi.com (it doesn't show up anymore), but I can on the following site.

    c833b503-878a-4022-96ad-14d584960ed1-image.png

    547556f1-b5df-4aa4-9296-e14663c5e18d-image.png

    When I (manually) deny access it looks like this:

    e763ecd2-57b5-438e-bbed-84cb3b1bd939-image.png

    When I change it back to Ask and reload, the popup reappears.

    I would be surprised if this this website actually requests access to motion sensors. Could anyone confirm?


  • Vivaldi Translator

    I didn't even know "Motion Sensors" was a thing websites could have permission for. Interestingly enough, I can only choose Allow or Block as default for it, not ask. And it does not show up in the site info popup. 🤔



  • https://vivaldi.com/blog/snapshots/desktop/whole-page-blocking-support-vivaldi-browser-snapshot-2001-3/

    [Permissions] “Motion or Light Sensors” permission dialog is empty (VB-68900)

    [Permissions] Dialog is empty on some pages (VB-69271)

    try the new snapshot if it fixes this issue for you



  • just block all notifications..i have never seen such pop ups ever.
    Block geolocation as well.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.