New V Crashes on settings



  • @Chas4 With new 3.1.1929.40 (Stable channel) (64-bit)
    Initially yes the problem was still apparent. In other words my 1st 3 launches the crash was still happening. But it did take longer for that same behavior.

    I kept trying to see if it would occur regularly. So far I have yet to have it happen again. After 1 1/2 hrs of browsing with prefs window open & making changes then closing it opening scrolling open etc. I have yet to repeat the crash.
    So fingers crossed it has been corrected. (I believe so)

    YAY Team Vivaldi! Thank you



  • OK. Checking smooth scrolling & use hardware acceleration to on then restarting brought the crash back. I did that out of curiosity. I will leave those two off.

    All is ok again😌


  • Moderator

    @tonyd1 Does enabling (or disabling) "smooth scrolling" alone have any effect on your ability to trigger a crash? chrome://flags/#smooth-scrolling is not even supported on macOS and the Vivaldi setting just changes the value of this flag through a command line argument when the browser gets launched, so it should be ignored.

    I filed a bug to have this preference removed on Mac years ago but the devs said that things could be left as is. On Mac, #smooth-scrolling is always enabled in the Chromium code, with no controls to turn it off, so this setting should not have any effect on stability or performance. If this is not the case, please let me know and I will have this investigated further.



  • @xyzzy said in New V Crashes on settings:

    #smooth-scrolling

    I enabled then disabled both in Vivaldi General settings > Webages settings > Checkbox Smooth Scrolling on (crash) Off ( no crash.)
    Same actions for Hardware Acceleration. Even worse if both were checked on at the same time.

    You are correct In Flags / Experiments both smooth scrolling & hardware acceleration are - "Not available on your platform."
    I didn't know they were not available on my platform. But it made a difference.
    I have no idea why they are in V settings. Except for uniformity among platforms. (?)

    On a side in the forum sometimes the suggestion is given for users to try with hardware acceleration off to see if that helps to solve a problem. Or something to that effect. Am I misunderstanding when I read that. (I've seen that suggestion in both Mac & windows forums.)

    Thank you.



  • Smooth Scrolling
    Animate smoothly when scrolling page content. Windows, Linux, Chrome OS, Android

    #smooth-scrolling
    Not available on your platform.


  • Moderator

    @tonyd1 Hardware Acceleration does different things depending on the platform and the underlying system hardware. Chromium uses GPU resources to accelerate rendering and composting. If the hardware acceleration code causes instability, the Chromium team will typically blacklist the GPU. If you override the blacklist, that too will cause instability to varying degrees. If you ever run into stability problems with Vivaldi, the first thing that you should do is ensure that chrome://flags have been reset to their defaults.

    On Mac, Vivaldi also still does some media decoding in the GPU process renderer, so Vivaldi force-enables some underlying acceleration so that the GPU process gets activated, and that too can sometimes cause problems... which is why I'm hoping that the remaining bits of old legacy media code will eventually get removed.

    I haven't had a chance to look at the crash logs for the crashes that you have all reported. Hopefully, the Vivaldi team has symbolicated the stack backtraces and I can get a better idea of what might be triggering the crashes.



  • I also have crashes, as soon as I do anything in the preferences window.
    Latests vivaldi version on OSX

    That is a huge problem, since this means I can not access my saved passwords and make them visible. a disaster



  • @a4z
    Hi, I cant help about the bug but may you can get access to your passwords and other settings with
    chrome://settings
    It open the underlying Chromium settings page.

    Cheers, mib



  • @mib2berlin said in New V Crashes on settings:

    chrome://settings

    Thanks a lot!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.