Window pops to top on focus



  • The last several snapshots I've noticed that the Vivaldi window pops to the top when the mouse passes over it. This is annoying and contrary to the behavior of any other app. pls fix. :)



  • I cannot reproduce this with the latest snapshot (64-bit) on Linux Mint 17.2, Cinnamon Edition. Which desktop environment are you running?



  • Welcome to the forum spoon0042!

    Like Tiamarth I tried to reproduce this on Fedora 21 (Gnome3 desktop) with Vivaldi 1.0.303.37 (Developer Build) dev (64-bit) but can't confirm it. The Vivaldi window stays behind the focused one, irrespective of a hovering pointer on it.



  • Updated to 1.0.303.48 (Beta) dev (32-bit) and have tried both openbox and xfce. The behavior seems to differ slightly between the two but usually the vivaldi window pops up. I just have vivaldi and a few xterms open. With openbox it seems to almost always happen; in xfce it doesn't always trigger but clicking one xterm and then moving the mouse around it eventually happens.

    I tried a bunch of things including upgrading openbox and backing up and deleting both its config and vivaldi's. The original openbox package was a year old and this only started happening recently so I have to assume it's due to some change in vivaldi. (Doesn't mean it can't still be a bug in openbox and xfce though.)



  • Hello again. I was able to reproduce this with xfce installed on Linux Mint 17.2 with Vivaldi (1.0.303.52 (Beta)). I was able to change the settings of xfce's window manager to prevent it from happening. To see if your window manager's settings are the culprit for you as well, do this:

    1. Open xfce's Settings Manager, find Window Manager, open the "Focus" tab.
    2. Make sure "Focus Model > Click to Focus" is checked.
    3. Make sure "Raise on Focus > Automatically raise windows when they receive focus" is not checked.


  • That's not really a solution since I actually want "focus follows mouse". I've had "raise on focus" off of course.



  • Then I imagine you'll just have to live with this behavior. It's neither a bug in Vivaldi nor in xfce, as Vivaldi's window is just obeying the window manager's settings.



  • It really isn't, though.



  • Does this on KDE3 too.. Policy is click to raise. Vivaldi randomly disobeys.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.