Bad performance even without extensions



  • Hi,
    this issue has been bugging me for quite some time. Vivaldi is really slow with rendering pages/scrolling. I tried disabling extensions, enabling Override software rendering list in vivaldi://flags, nothing seems to help.
    Usually while scrolling it just displays a blank background then renders the rest of the site, like it was doing some lazy-rendering for content outside of the viewport.
    With just one tab active and a few hibernated, I'm seeing about 300MB usage of GPU Process and 150-200MB of Browser in Vivaldi's task manager while idle, not sure if that's much.
    This is on a fresh install while logged into Sync, if it matters.
    Any help would be appreciated, I love using Vivaldi despite those issues.

    edit: I'm running Vivaldi on a late 2015 Macbook Pro.


  • Moderator

    @kjhank Hi. Welcome to the Vivaldi Community!

    Are you running standard/stock macOS or do you have any desktop management software (such as Magnet or Moom) installed? Scrolling with Vivaldi should feel as natural as it does with Safari or Chrome. All Chromium flags should be at their defaults and you should not have any experimental code enabled.

    What extensions do you have installed? Do any of them customize the UI in any way or interact with Chrome at a low level? Some Chrome-specific extensions can cause very strange side-effects in Vivaldi. Sometimes, disabling an extension is not enough.

    Vivaldi also has its own code for supporting mouse gestures and this can also have interoperability issues with 3rd-party mouse / trackpad / digitizer drivers and some browser extensions as well.

    The GPU Process is a special renderer that has priviliges to interact with the GPU hardware. Vivaldi also does some media decoding in that renderer. Site specific issues could trigger a CPU or memory usage spike but what you are seeing is not too excessive or out of the ordinary.

    One other thing: If you go to vivaldi://gpu is hardware acceleration enabled or are you only using software-based rendering?

    Thanks for using Vivaldi and best of luck with your troubleshooting!



  • I'm not running any additional desktop management software nor any 3rd party drivers, and currently don't have any additional experimental flags enabled. I have quite a lot extensions installed, but none of them are currently enabled. Here's the list:

    • Allow-CORS
    • Facebook Pixel Helper
    • Password Checkup Extension
    • PerfectPixel
    • React Dev Tools
    • Redux Dev Tools
    • Google Tag Assistant
    • Twitter 'Likes' Hider
    • Vue.js devtools
    • Wappalyzer
    • WAVE Evaluation Tool
    • Web developer
    • Web developer checklist

    Everything except Metal and Hardware Protected Video Decode in vivaldi://gpu is green/enabled.


  • Moderator

    @kjhank Do you see the same issues if you browse as a Guest user? (Click on the Profile icon, then click Open Guest Window)

    Do you have Tracker and Ad Blocking enabled and if so, do the problems still reproduce if you change the Blocking Level to "No Blocking"?

    You also could try creating a test user account on your Mac and test with a clean/default Vivaldi installation. If you still experience slow/laggy scrolling, you can file a bug report. A member of Vivaldi's testing team will likely follow up if you have clear steps-to-reproduce but they cannot reproduce the issue. If the scrolling problem does not reproduce in a test account, you can then try installing extensions, one by one, to replicate your other (problematic) installation and then report a bug with clear steps on how to reproduce the issue.

    FYI, I checked the bug tracker and don't see any bugs for any scrolling issues on macOS.



  • For what it's worth, I am experiencing this too using the latest v3 stable on OS X. I also disabled my extensions, restarted the laptop, restarted the browser, and so on. Immediately after a reboot, same behavior. Same pages render fine in Firefox.

    I have a 2015 MBP 15", 16G RAM, plenty of free disk space. SSD.



  • @xyzzy Everything is fine while in guest mode.
    I disabled tracker & ad blocking and completely removed all extensions & it's still here on my main profile. For reference, this is what it looks like: https://streamable.com/h7k6x5
    So I'm guessing this must be something to do with some of my settings? Is there any way to maybe reset all preferences without resetting the whole profile?
    @jvivaldi885 Interesting, I'm also on the 2015 MBP (13" & 8GB though), maybe there's something device-specific going on here?



  • @kjhank
    Hi, at the end you save time if you refresh your profile, I had to do this several times over the last years. If you use sync it is a matter of 15 minutes.
    Without sync it is a bit more but you get a working system in a hour or so.
    Move your profile directory to a save place and wipe Vivaldi, start to copy major files back like bookmarks, passwords and so forth.
    https://forum.vivaldi.net/topic/10388/refreshing-or-cleaning-your-profile
    Realy hard for me are my custom speed dial thumbnails, I have to bring them back bit by bit.
    You loose some settings, panels and search engines (there is a mod to export them), nothing else I am aware of.

    Cheers, mib



  • I had a similar issue:
    https://forum.vivaldi.net/topic/45059/laggy-scrolling

    Disabling hardware acceleration helped a lot but as the number of tabs increased, eventually scrolling became unbearably slow.

    Last week, I finally erased all my personal settings (removed ~/Library/Application Support/Vivaldi) and started afresh.

    Since then, I've tried not to increase the number of tabs and so can't tell whether the laggy scrolling problem has gone away or not.



  • I too wiped my profile (after syncing and bookmarking all open tabs) and created a new one; Then restored my tabs by copying the bookmark folder to my speed dial and opening all tabs in the speed dial.

    Vivaldi quickly downloaded saved settings and extensions automatically.

    So far, it seems to be working as expected. It's a very noticeable difference in performance. And this is after I reinstalled the latest 2.x; Maybe 3 is even better.

    Good luck!


  • Ambassador

    @jvivaldi885 Do install the latest version. It is important to keep up to date for security fixes rather than for new features.



  • So getting back to this. I disabled settings synchronization in case it was something in my settings. Then did a complete wipe of my ~/Library/Application Support/Vivaldi/Default, directory and it's still here. Just getting constant delayed repaints while scrolling.



  • What version of macOS?



  • @Chas4 10.15.5



  • @kjhank Apple did release another update for 10.15.5 yesterday (it is over 1GB macOS Catalina 10.15.5 Supplemental Update, also might take around 30 minutes to install).

    I have the same OS but a 2 year older machine.
    Is there any different with "Use hardware acceleration when available" enabled and disabled (it does require a restart of Vivaldi for the change to happen).

    For me on vivaldi://gpu the top
    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Metal: Enabled (this is a flag right now and not stable on all systems)
    Multiple Raster Threads: Enabled
    Out-of-process Rasterization: Hardware accelerated
    OpenGL: Enabled
    Hardware Protected Video Decode: Unavailable
    Rasterization: Hardware accelerated
    Skia Renderer: Disabled
    Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated



  • @Chas4 Installed that update a few moments ago. Actually it seems to perform much better with the hardware acceleration checkbox unchecked. Not sure if that's how it should be, but it's something 🤷🏿♀



  • Hoped 3.1 would help, but still nothing - scrolling is fine without hardware acceleration, but awful with it enabled.



  • Does it work any better if you clear the cache (since the beginning of time), and then restart Vivaldi?

    Metal support in Chromium is experimental chrome://flags/#metal out of curiosity does that make any difference? (Vivaldi might crash with it enabled)



  • @Chas4 Clearing the cache did nothing. With Metal enabled it's maybe slightly better, but the difference is really minimal.


  • Moderator

    @kjhank I honestly don't know what could be causing this. My initial thought was the developer extensions that you have installed. (... and especially if you also had Vivaldi set up so that you can inspect its UI, but I don't recall you ever saying that you did.) However, given that this issue persists even when you disable or remove your extensions, it would appear to be something else.

    The Vivaldi team also fixed an issue that was causing performance problems on Windows, related to the Razer Chroma integration with themes, but this should not be an issue on Mac.

    Given that this problem does not occur in the Guest window still leads me to believe that it is related to your configuration or settings.

    I'll ask about this internally to see if any other testers or developers have any other suggestions to offer.



  • I have the same problem with Vivaldi 3.1.1929.45 on macOS Version 10.15.5. I think it started around the v3 release. Scrolling is choppy. Rendering seems to be laggy. This is on a 2020 MBP with 32GB memory. I only have uBlock Origin installed. I removed everything *vivaldi* in ~/Library to test this. Save for uBlock this is completely stock & fresh vivaldi.

    If I open the same page in Vivaldi and Firefox and scroll both of them the difference is really obvious, despite the fact that my FF has 50 tabs open and 10 extensions installed, it's still much snappier while scrolling (I think fluid might describe it best).

    Now this is not a horrible bug, but it just makes all usage of Vivaldi slightly less enjoyable. And it also did not use to be that way, so I am quite certain that this is a bug that was introduced along the way.

    If you need any debugging, I am happy to oblige.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.