Vivaldi noticeably sluggish since upgrading to 3.0


  • Moderator

    @emanx995 Fascinating.



  • @emanx995 said in Vivaldi noticeably sluggish since upgrading to 3.0:

    @rseiler @Ayespy Some Ease of Access settings in Windows can turn it on. For example I found that if I enable the text cursor indicator (Windows Settings->Ease of Access->Text->Turn on text cursor indicator) and then restart Vivaldi, the accessibility modes are automatically enabled in vivaldi://accessibility When I disabled text cursor indicator and restarted Vivaldi, the accessibility modes were disabled again.

    When I was having the freezing issues it did affect the onscreen keyboard which I have running most of the time.



  • @emanx995 I tried that setting, and you're right, whichever Chromium browser you run next (even Chrome) magically enables accessibility. Fortunately, --disable-renderer-accessibility does seem to short-circuit that from happening.



  • @Darthagnon said in [Vivaldi noticeably sluggish since upgrading to 3.0]

    Reported as VB-67553.

    If you haven't already, you should update the report with mention of the smoking gun that @aldaviva found: Accessibility.

    Maybe someone already has in a separate report, but we don't really know and I see no mention of others.



  • @rseiler

    He hasn't been online for the better part of a week. Regardless, you can always just file a bug yourself if you don't see a report that something which should have been filed was, and just make sure to explicitly call out the original bug number and that you're providing important information that has been discovered by the community since the original was filed.

    I'm not privy to Vivaldi's internal processes and which tools they are using, but they almost certainly have a standard method in place for handling something to that effect. Depending on how they are tracking issues, they could either link your bug to the original, close yours out as a duplicate of the original and copy & paste the needed information into the original. That seems to me to be the best way to provide new information to the Vivaldi dev teams that is critical to an existing bug.



  • @mtaki14 Sorry for the delay in replying; I have the problem as soon as I open Vivaldi, not after any idle time. I heard on Reddit:

    The problem happens when vivaldi://accessibility becomes enabled, which it can unpredictably and automatically unless you start Vivaldi with this switch:

    --disable-renderer-accessibility

    I'm trying that, and so far, it feels better. I'll keep testing. Any chance we could have a settings switch to disable these "accessibility" features, so that Vivaldi doesn't have to be started by a shortcut all the time?

    @BoneTone, I'm back 😉

    Is there somewhere I should update the bug?



  • @Darthagnon Yes, the very end of the bug report email says that you can respond to that email to do that.



  • @Darthagnon said in Vivaldi noticeably sluggish since upgrading to 3.0:

    @BoneTone, I'm back
    Is there somewhere I should update the bug?

    @rseiler has it right. When you filed the bug you should have received an email with the bug number among other info. Replying to that email is the best way to provide updated information.



  • @Darthagnon said in Vivaldi noticeably sluggish since upgrading to 3.0:

    --disable-renderer-accessibility

    Love using that switch, as it completely solves the problem. I don't see not using it in the future just as a safeguard, but I'm curious, is anyone testing the problem in the 3.1 builds so far?

    Just to update this post with some further info:

    If you want to cover the case where Vivaldi launches another way, like from a mail app, that can be done in the Registry:
    https://i.imgur.com/1LPzBL3.png

    So, you insert the switch into the place shown. And note that your exact location in the Registry will differ, since Vivaldi uses a random sequence of characters after the VivaldiHTM.

    BTW, it's possible that one or both of these flags would eliminate the need of the switch entirely, but the descriptions for them aren't overly clear, so they may or may not serve our purpose:

    chrome://flags/#webui-a11y-enhancements
    chrome://flags/#enable-accessibility-expose-display-none



  • I was rereading my older posts in this thread which I've now deleted. A mod asked me something and I replied thinking I was responding by saying using --disable-renderer-accessibility at startup worked. I mistakenly said something else. Just to clarify for my own sanity so this will quit bothering me adding "--disable-renderer-accessibility" at startup is what solved my issues with Vivaldi freezing along with the onscreen keyboard doing the same.



  • Took me a while, but I sent an email into the void, as a reply/update to the Vivaldi bug report.


  • Moderator

    @Darthagnon said in Vivaldi noticeably sluggish since upgrading to 3.0:

    Took me a while, but I sent an email into the void, as a reply/update to the Vivaldi bug report.

    I can confirm that the void has received your message 😃



  • There's a registry entry you can make, as explained by rseiler here:
    https://forum.vivaldi.net/topic/47583/stabilization-for-3-1-vivaldi-browser-snapshot-1929-13/32

    Registry Entry:
    Computer\HKEY_CLASSES_ROOT\VivaldiHTM\shell\open\command

    Before:
    "C:\pf_Speed\Vivaldi_stable\Application\vivaldi.exe" -- "%1"

    After:
    "C:\pf_Speed\Vivaldi_stable\Application\vivaldi.exe" --disable-renderer-accessibility -- "%1"

    This will ensure Vivaldi opens (even from shortcuts/urls/links) with maximum performance and no lag every time (until this awful bug is fixed).



  • Speaking of which, is anyone on 3.1 still seeing the problem? It's in quasi-final state at the moment with the special builds (not to be confused with snapshots) made available to seekers.



  • @rseiler I haven't seen any freezes so far with 3.1, but in comparison to other browsers, Vivaldi still doesn't feel as fluid and fast. I have a powerful machine, but opening a new private Window takes about 2 seconds in Vivaldi. In all other browsers I've tested (Edge, Opera, Firefox), a new private window opens in under one second.


  • Moderator

    @HellbillyDeluxe I don't know what you call a "powerful" machine, but here, a new private window opens in less than a second. In my former "powerful" machine, the one in my signature (which I will be changing today), a new private window takes nearly 8 seconds to build. This is partially down to the fact that Vivaldi builds an entire extra layer, the one housing all of its customization and modification ability, which Edge, Chrome and Firefox do not build, because they make their UI out of elements native to the system, and therefore, they are not able to develop full customization like Vivaldi.

    (signature concerning my old tower - Windows 10 X64, AMD A10 8750 @ 3.6 GHz; ASUS EAH5450 graphics; 1TB Crucial MX500 SSD; 16 GB DDR3 PC3 12800 RAM)



  • @Ayespy

    Some of my PC specs:
    AMD Ryzen 5 2600 Six-Core CPU ~ 3.4 GHz
    32 GB DDR4 RAM 3200

    That should me more than enough for Vivaldi to run smoothly, but I understand that Vivaldi's UI is the bottle neck and slows things down. I hope they can improve on that in the future.


  • Moderator

    @HellbillyDeluxe said in Vivaldi noticeably sluggish since upgrading to 3.0:

    @Ayespy

    Some of my PC specs:
    AMD Ryzen 5 2600 Six-Core CPU ~ 3.4 GHz
    32 GB DDR4 RAM 3200

    That should me more than enough for Vivaldi to run smoothly, but I understand that Vivaldi's UI is the bottle neck and slows things down. I hope they can improve on that in the future.

    I have lesser specs than you but launching a private window takes less than half a second for me. Do you have an SSD?



  • @mtaki14

    Yes, I have a 512 GB Samsung 860 Evo SSD.



  • Sure, those in the know use the switch, but just for future reference, is this fundamental problem that's been around for several months and which blindsides people fixed in 3.2?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.