Vivaldi broken on upgrade to latest version

  • Just upgraded to v.3 from the most recent 2.x and now Vivaldi does not work at all. Just get a white window and nothing in the Vivaldi menu (top left) except About Vivaldi (which does not work), and Quit (which does work). HELP!!!!
    Mac OS High Sierra 10.13.6 on iMac 27-inch Mid 2011.
    3.4 GHz Intel Core i7, 16 GB 1333 MHz DDR3, AMD Radeon HD 6970M 2048 MB

  • Reverting to 2.11.1811.47 sorts the issue.

  • @eggwin Is there a way I can revert - I just ran the updater which I guess replaces the previous version? Thanks!

  • @eggwin Thanks so much.

  • UPDATE - After reading that someone else waited some minutes to see what would happen - I did the same. Launched Vivaldi and looked at the blank window for a while; it has now started up (after 2 to 3 minutes) and looks normal, though it had switched out my background from the StartPage. So far so good.
    I have just quit Vivaldi and relaunched to see if subsequent launches take just as long. They do.

  • Same here. Just a gray window. Had to revert to the previous version (2.11.1811.52)
    Mac OS Sierra on Macbook Pro late 2011.

  • Same here. MacBook Pro late 2011, OS X 10.13.6 (High Sierra), updated to 3.0.1874.23 and nothing but a grey screen. After a while menu bar but nothing more. Binned it, downloaded most recent version from Vivaldi, reinstalled, same effect. Haven't tried the iMac yet…

  • Same here after the latest update. I also just loaded a new copy from your website and it's the same problem. So not a problem with the update but the new version itself.
    Here is the error output indicating that we have to wait for a timeout as the db can't be opened:

    [31075:775:0422/] XXX Init()
    [31080:775:0422/] PROPMEDIA(GPU) : Initialize Asset is not playable
    2020-04-22 10:46:02.098 Vivaldi Helper (GPU)[31080:1525724] NetworkStorageDB:_openDBReadConnections: failed to open read connection to DB @ /Users/x/Library/Caches/com.vivaldi.Vivaldi.helper/Cache.db. Error=14. Cause=unable to open database file
    2020-04-22 10:46:02.098 Vivaldi Helper (GPU)[31080:1525724] CacheRead: unable to open cache files in /Users/x/Library/Caches/com.vivaldi.Vivaldi.helper
    2020-04-22 10:46:02.098 Vivaldi Helper (GPU)[31080:1525724] Failed to obtain sandbox extension for path=/Users/x/Library/Caches/com.vivaldi.Vivaldi.helper. Errno:1
    2020-04-22 10:46:04.573 Vivaldi Helper[31081:1525804] XPC error for connection Connection invalid

    I than tried to delete the cache and noticed that there is no folder named com.vivaldi.Vivaldi.helper in the Cache. Only a folder named com.vivaldi.Vivaldi without the .helper

  • So this affects macOS 10.13.x, anyone know if it also affects macOS 10.14.x? From my experience macOS 10.15.4 is not affected.

  • @Chas4 Seems to be working fine here; using macOS 10.14.6

  • @timi Same here; the last snapshot build that did not show this pause-on-start behavior on all of my Mac 10.13 systems was 2.12.1862.3. Each snapshot since then (and the recent official v3) have all exhibited this behavior.

  • @ron-stewart I have not seen this pause behaviour at all before; been using Vivaldi (official releases only) for quite a while. Always worked well on my previous OS versions 10.10.x, 10.11.x and on this 10.13.6 (from December 2019) until today; always install the new official releases when they're available, never had a problem before.
    I can't go any higher than 10.13.x on this version of iMac, nor will newer OS's run Adobe Creative Suite CS6 (so I've read), so am stuck here for now.

  • Same problem here. MacOS 10.13.6. Have to wait a minute or two. After quitting Vivaldi 3 and reopening does the same - have to wait.
    Downgrading back to v2.

  • Vivaldi Team

    From what we know, this issue is affecting users on macOS 10.13 and older. Our devs are looking into it and we're hoping to fix the bug ASAP.

    In many cases, like @timi mentioned, waiting a few minutes helps and the browser returns to normal (at least until you restart the browser).

    Thank you for your patience and keep an eye on browser updates.

    As a side-note, as this issue is only present on older macOS versions, if upgrading to the latest version is an option, that could be something to consider as well. Not just for the sake of getting Vivaldi to work, but for macOS' own improvements and security updates as well.

  • @jane-n Thanks for this. Will keep a look-out for the fix...

  • Thanks for the update @jane-n - Unfortunately I don't have the option to upgrade to anything higher than macOS 10.13.6 on my 2011 MBP. I use this machine mainly when relaxing on the couch, where my regular laptop would fry my legs off.

  • Same here, thanks for keeping us posted, and updating the operating system would mean upgrading to a new system, which is not an option…

    @HansGeering said in Vivaldi broken on upgrade to latest version:

    Thanks for the update @jane-n - Unfortunately I don't have the option to upgrade to anything higher than macOS 10.13.6 on my 2011 MBP. I use this machine mainly when relaxing on the couch, where my regular laptop would fry my legs off.

  • Wanted to confirm - I am running 10.11.6 - the prior version worked fine but this version is a gray screen and nothing else. Left it sit for 20 minutes and came back and still a gray screen.

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.