Vivaldi and Overheating



  • I know this sounds crazy, but I've run some tests and I think that vivaldi is causing my 4 SSDs in RAID0 to overheat when running. I have the "Disks" utility running and I refresh the temp of one of the SSDs and it's about 40C. I start vivaldi and suddenly the temperature starts rising. If I keep it open long enough, it reaches 70C where my SSDs start throttling. If I exit vivaldi, the temp continues to rise. I've check System Monitor and it seems that after exiting vivaldi, there is still one vivaldi-bin process running. If I force close that process, the temperature drops REALLY fast. This does not happen when on Chrome. Is it possible that one of the changes done for the Speed Dial causes many read/writes on the SSDs?





  • I've done some more tests and I think the problem is not specifically speed dial but I am 100% sure that the overheating is caused by vivaldi. I think it's the same problem as the one mentioned in this thread: https://vivaldi.net/forum/vivaldi-browser-for-linux/6624-snap-1-0-291-18-high-i-o-usage
    I've attached screenshots from htop and System monitor but as far as I can see it doesn't show Disk read/write usage. Bear in mind that the vivaldi processes you see in the pictures are running in spite of the fact vivaldi is actually closed

    [attachment=1848]Screenshotfrom2015-10-1614:43:46.png[/attachment]

    [attachment=1849]Screenshotfrom2015-10-1614:44:55.png[/attachment]
    Attachments:
    ,



  • I have the same problems. i am using Linux Mint 17.2 Cinnamon 64 bit, and after updating Vivaldi to the newest snapshot Version it is overheating my cores extremely to 100% . And if i open a few Tabs, then nothing works anymore, all is hanging up. I had uninstalled it and installed it again, but still the same problem. So what can i do? :(



  • Yes if anyone from Vivaldi is watching this it would be great if this gets investigated further. I have a gaming laptop and vivaldi is causing the SSDs to overheat. And this was not the case with the previous snapshots. This overheating caused one my SSD's read error rate to go up permanently.



  • Hello,

    I've answered you in the topic I've created about this problem :
    Kill vivaldi and rename your ~/.config/vivaldi-snapshot folder to reset your profile.
    Since I did this, the I/O usage was back to normal.

    For diagnotics, I used the command iotop -P to monitor which process was using my HDD.



  • I tried that just now. It seems that it fixes the issue for like 1 hour or so. Then suddenly the disk writes go up to 67% and caused by jbd2/dm-7-8 according to iotop -P. After closing vivaldi and killing the ghost process that stays in the background, everything is back to normal



  • jbd2/dm-7-8 is the journalize process for EXT filesystems.

    If it uses a lot of I/O, it's because there is another process which does it.

    When you start iotop -P, use the left arrow for order by DISK WRITE, you will see who is the big consumer.

    For me, reset my profile fixed the issue, but I don't know how SSDs are managed.

    Try a remove / install of Vivaldi snapshot package ? I remember that I tried a rollback to previous version with APT but it changed nothing.



  • It's caused by libpepflashplayer.so –ppapi-flash-version=19.0.0.207.
    How do I reinstall that?



  • @andreasyeah:

    It's caused by libpepflashplayer.so –ppapi-flash-version=19.0.0.207.
    How do I reinstall that?

    What distro are you using?



  • Zorin OS. It's based on Ubuntu 15.04. However, I assume that file is also used by google chrome but that doesn't cause any problems there



  • @andreasyeah:

    It's caused by libpepflashplayer.so –ppapi-flash-version=19.0.0.207.
    How do I reinstall that?

    It was the same process for me.



  • SOLVED
    The solution is indeed to clean your profile, but on my attempt to save my settings, bookmarks and stuff I was copying the file TopSites to the new profile. It turns out that's the one causing the problem. If it gets too large, it take a lot of time to write to it, even after closing vivaldi. This is what causes the ghost process. If other have similar problems and want to preserve your settings just delete the TopSites file and it should be fine



  • @andreasyeah:

    If other have similar problems and want to preserve your settings just delete the TopSites file and it should be fine

    Thanks !



  • I had a similar issue, but unfortunately saw your post only now. I have reset my entire profile and the processing went down. For me, it was not only heating the SSD, but also BTRFS was starting to occupy at least 2 of the 4 cores I have.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.