Snap high I/O usage

  • Hello, After upgrading to I've noticed a big I/O usage for Vivaldi. [url=][img][/img][/url] When I look inside the profile dir in ~/.config/vivaldi-snapshot/Default I see the files reloading a lot. When I close Vivaldi, I see there is a last process which cannot stops itself and continusly write inside the profile dir. I've tried a kill SIGTERM => nothing happen, I must kill it brutally because it locks the profile dir. Vivaldi complains for "can't access to profile directory" if I don't kill the remaining process. After closing Vivaldi : [code]seb:~/.config/vivaldi-snapshot/Default$ ps -afe|grep viv seb 17151 7559 5 19:04 ? 00:01:18 /opt/vivaldi-snapshot/vivaldi-bin --user-data-dir=/home/seb/.config/vivaldi-snapshot --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/ --ppapi-flash-version= seb:~/.config/vivaldi-snapshot/Default$ kill -SIGTERM 17151 seb:~/.config/vivaldi-snapshot/Default$ ps -afe|grep viv seb 17151 7559 5 19:04 ? 00:01:18 /opt/vivaldi-snapshot/vivaldi-bin --user-data-dir=/home/seb/.config/vivaldi-snapshot --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/ --ppapi-flash-version= [/code]

  • Ok after analyzing with iotop, it seems to be the bundled flahsplayer with around 500K/s a disk write.

    25506 be/4 seb 0.00 B/s 565.04 K/s 0.00 % 0.03 % –ppapi-flash-version=

    Disabled in plugin page, the process still write a lot in disk.

  • I've cleaned my profile, it seems to be fixed for now.

  • My SSDs are overheating with the latest snapshot. It probably cause of the high I/O. Can you give more info on what you did to solve the problem? Did you delete your whole profile?

  • Yes I did.

    I closed Vivaldi, kill the last process which stayed alive, renamed the folder ~/.config/vivaldi-snapshot for backup (for bookmarks etc) and restarted the browser.

  • Confirmed with 1.0.303.52-5 (beta1) on Linux Debian

    I see a constant 1MB/s write from in iotop :( :(

    edit: same with snapshot 1.0.330.3-1

  • Moderator

    For me no constant write of at Debian 8 and last Snapshot.
    I'm using Flashplayer PPAPI

  • On another topic we have seen that you just need to delete the "Top Sites" db file from the profile directory.

    This case should have been resolved since previous releases.

  • Thanks, this seems to have resolved the issue!

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.