laggy scrolling



  • Since some snapshots ago, vertical scrolling is very laggy. My tabbar is placed on the left-hand side and scrolling within it is also laggy. When I scroll fast, the background color is first seen before the objects are drawn, both on a webpage and on the tabbar.

    This happens even when all background tabs are hibernated and all extensions are disabled (and after Vivaldi is re-launched). It doesn't seem to happen on a Guest Window or on Google Chrome (but my tests have been cursory on Guest Windows and on Google Chrome).

    The lag doesn't seem to be web-page specific. It happens on a search-result page of Google Search and on other text-dominated webpages. The initial loading of any page feels slower than on Google Chrome.

    As far as I can remember, this lag never happened on Vivaldi on me (been using Vivaldi ever since its first general-public version came out) until this.

    Does anybody have a similar problem?

    Vivaldi 2.12.1854.5 (Official Build) (64-bit)
    Revision e624adc3a52d56f586e8194fabbe10bc3310155a
    OS macOS Version 10.15.3 (Build 19D76)



  • @ryofurue said in laggy scrolling:

    The initial loading of any page feels slower than on Google Chrome.

    I've found that the loading of webpages is definitely slow, much slower on the existing profiles than on a fresh profile of Vivaldi.



  • @ryofurue
    Hi, there are some things/settings can slowdown Vivaldi:
    Long list in downloads
    Huge history
    Many notes with screen shots
    Animations (Appearence settings)
    Smooth Scrolling (Webpages settings)
    Hardware acceleration (UI slow when enabled)
    Some pages act strange with Vivaldi on scrolling, https://www.wissenschaft.de/ for example.
    I am on Linux so cant really test but OSX is a Unix so some settings may help.

    Cheers, mib



  • Any extensions or flags enabled?



  • @mib2berlin said in laggy scrolling:

    @ryofurue
    Hi, there are some things/settings can slowdown Vivaldi:

    Thanks.

    Long list in downloads

    Possible. I haven't done anything about it.

    Huge history

    Possible. I haven't done anything about it.

    Many notes with screen shots

    I have only one note, I think.

    Animations (Appearence settings)

    I haven't touched that setting.

    Smooth Scrolling (Webpages settings)

    I haven't touched the setting.

    Hardware acceleration (UI slow when enabled)

    I haven't touched the setting.

    Some pages act strange with Vivaldi on scrolling, https://www.wissenschaft.de/ for example.

    I don't see anything strange on the page, but scrolling on it is as laggy as on other webpages. It scrolls fast on Chrome and on a fresh profile of Vivaldi. (By the way, I guess it's a science page, isn't it? Looks fun.)

    In short, everything on your list has been left default. I'll try to go over your list one by one (like deleting history) to see any of them improve the speed.

    Cheers,
    Ryo



  • @Chas4 said in laggy scrolling:

    Any extensions or flags enabled?

    The sluggishness doesn't go away even when all the extensions are disabled. As in my response to mib2berlin, I don't remember customizing anything that would affect the performance. I just move my tabbar to the left-hand side, change the theme to one of those dark themes, switch on the flag that make a new tab automatically form a stack, enable Sync, and I think that's about it.

    For a particularly sluggish site, I created a new profile for it and it's not sluggish at all on it.

    Cheers,
    Ryo



  • It's interesting that on a website which loads rather slowly, I can't start to scroll until the loading nearly ends on my main Vivaldi profile. On a fresh profile, I can start to scroll right away even while the page is being loaded rather slowly.

    I've cleared "Browsing History", "Downloads", "Storage", and "Cache" and restarted Vivaldi. The sluggishness stays (all extensions have been disabled).



  • @ryofurue
    Hi, it was meant as "Touch it", delete DL list, switch off animation and so forth.

    Cheers, mib



  • Okay,

    • switching off hardware acceleration has made the scrolling within the tabbar a lot smoother.
    • it has mixed results for webpages, though:
      • Some pages takes some time to load, and while it's loading, you can't scroll within it. (On a fresh profile, you can.)
      • But, once the page is fully loaded, the scrolling is fast. (It was laggy before the switching-off of hardware acceleration.)

    Has some lagginess due to hardware acceleration reported? Is it new?

    On the other hand, I haven't noticed any change when animation is switched off. It remains off for now.



  • I closed all but two tabs and this problem is gone.

    There seem to have been two elements in this issue:

    1. Scroll itself is extremely laggy → This problem was gone when hardware acceleration is switched off.
    2. Loading of pages is slow and during the loading you can't scroll. ← I couldn't fixed this.

    Both problem happened even when the background tabs were hibernated. Neither problem happened in a fresh Profile.

    I've switched hardware acceleration back on but still scrolling is fine.

    So, somehow hibernated tabs interfere with the performance of the active tab. Perhaps they keep some resources, such as network connection and GPU memory, to themselves even when hibernating?



  • Now it's getting weirder.

    The above problem was actually on my main Profile. It had 60–80 tabs and I thought that somehow was causing the problem.

    I use two more Profiles and one of them has started to develop the laggy-scrolling problem. It has only about 25 tabs.

    As I write this, I close them one by one and test the smoothness of scrolling on a particular webpage. It gradually gets better and better (subjectively). When the total number of tabs is down to 5, I stop noticing lagginess.

    I'll use Vivaldi with minimum tabs for a while.



  • Hi,

    I'm on the latest of MacOS Catalina and Vivaldi (at the moment there are about 30 opened tabs) and confirm, that switching off HW Acceleration eliminates the effect of laggy scrolling. Also, I don't see notable impact neither on energy nor CPU usage after switching HW acceleration off.

    Thanks.



  • @doka380 What model Mac do you have? (might be others who can also test it with the same hardware)



  • I have the same issue. Scrolling has been really laggy on any web page, and even typing is kinda laggy as well.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.