100% Disk Usage



  • This is why we need to always remember the ABCDEs - Always Be Closing Defective Extensions 😜



  • @Pathduck True, though I still think sync was the most likely culprit. That, and Cortana and the registry are active, that's pretty much all we can see that is touching the disc. An underlying root cause could possibly be a failing disc. There is essentially no data throughput, yet also no idle time on the drive. That can be indicative of lots of tiny files, or also a drive that is starting to fail as one write after another has to be retried.

    But you can see the sync db is being written, by System, as well as lots of locations that could be synced. If the OP wishes top try to dig into what happened, there's always the log filled to check.



  • @Pathduck The problem is not anything you are running but I do suggest changing Chrome's options to not run any background programs after closing. My Firefox Developer's Edition uses way more RAM than you show with Chrome with no problems (I have 6GB).

    Make sure you have latest version (1909) of Win 10.. One of Micro$oft's updates made Task Manager always show 100% even though other specs were well within system's capabilities. Believe the problem was with one of Window's programs running which didn't show amount of usage.

    1. Might try turning off Windows Search. Type and run the command net.exe stop “Windows search” in Command Prompt. Doing this will prevent Windows Search from running until Windows is restarted.
    2. Might try using CheckDisk utility program.
    3. Disble the Startup programs at boot temprarily.
    4. Disable certain Windows programs (first click Start, then type services and click Enter):

    A) In the Services window, look for the service called Superfetch. Right-click on that item and click Stop. Don’t exit out of this window.
    😎 Open Task Manager to see if your usage dropped. If not, right-click on Superfetch again and click Start to re-enable it.
    C) Next, see if another service is causing the problem. Repeat the steps above with two more services, including Background Intelligent Transfer Service and Windows Search, checking to see if disk usage drops after each attempt.
    D) If any of these steps stopped your disk usage problem, then you’ll want to right-click the service that caused disk usage to drop, then click Properties > Startup type > Disabled. This prevents the service from starting up and should cure your disk usage problem permanently.

    1. If nothing helps, try "100% Disk Usage in Windows 10 Fixed With 14 Tricks" at https://www.makeuseof.com/tag/4-tips-fix-100-disk-usage-improve-windows-performance/

  • Ambassador

    Windows 10 is a good OS, but certainly before it really is, it is convenient to disable a lot of unnecessary services.
    It can be done by hand, but not in all services is the function that they have very clear and if one is not very expert in the subject, one runs the risk of turning the PC into a paperweight.
    It is therefore recommended for newbies to use for this purpose some utility that allows to disable the necessary services with security, for example https://www.sordum.org/8637/easy-service-optimizer-v1-2/



  • @darkstar9386

    When something like this happens to me, I shut down the PC and open it after sometime.



  • @TheShadow4Vivaldi said in 100% Disk Usage:

    Repeat the steps above with two more services, including Background Intelligent Transfer Service

    I would not disable BITS. Set it to manual instead of disabled if you feel the need to make any changes. Then it should start when you manually invoke Windows Updates, which depends on BITS to download the packages. If it is not running, the WU will not be able to download updates in the background using idle bandwidth



  • @BoneTone Most of the changes are not to be done permanently. Just to see if a service is causing the problem. Troubleshooting suggestions are just that, suggestions until problem is solved. I mentioned that Micr$oft issued an update at one time which they said was causing the problem. They did take care of it eventually but other updates could cause problems as you well know.



  • @TheShadow4Vivaldi said in 100% Disk Usage:

    Most of the changes are not to be done permanently. Troubleshooting suggestions are just that, suggestions until problem is solved.

    Except for the change I mentioned, it comes after the troubleshooting and is the proposed fix. You specifically called out that change as a permanent solution.

    @TheShadow4Vivaldi said in 100% Disk Usage:

    If any of these steps stopped your disk usage problem, then you’ll want to right-click the service that caused disk usage to drop, then click Properties > Startup type > Disabled. This prevents the service from starting up and should cure your disk usage problem permanently.

    That's precisely why I posted what I posted. If you intended for the OP to then do something else to find the root cause and enable the service again, that was not included in your post.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.