Shortcuts don't work under Chinese Input Method + Zoom in doesn't work, NOT fixed in Beta



  • Shortcuts don't work under Chinese Input Method under Chinese Input Method Wubi Xing. Safari works fine. Also, the Linux version seems to have the same problem if I use Wubi under fcitx. But I can't test it for the moment. I've already tested it under Korean input method, shortcuts don't work. it means that for the input method, if the keyboard map shown in the Keyboard input source is not alphabet. Shortcuts don't work. Please fix it. Thanks for the zoom issue, it's tested in US keyboard Zoom out by Command - works But Zoom in by Command + doesn't work also Zoom control by two fingers doesn't work.



  • Sorry point out the system environment
    Yosemite 10.10.5
    vivaldi 1.0.288.3



  • Zoom in Works
    Shortcuts still don't work under Wubi input



  • Zoom In doesn't work again. What happened ??????

    Why has shortcut problem still not been fixed in beta version? Are our feedback taken into account? if not, I am sorry, I will leave Vivaldi. :angry:


  • Moderator

    @pd1986:

    What happened ??????

    A bug.

    @pd1986:

    Why has shortcut problem still not been fixed in beta version? Are our feedback taken into account? if not, I am sorry, I will leave Vivaldi. :angry:

    I thought this has been addressed when it was raised from Japanese IME. Or I'm confusing the bugs.

    Anyway, if you haven't done so, report in the Bug Report page



  • It seems like the shorts cuts are not functioning under Asian language system.

    On my mac, I have Korean, Colemak, Hiragana with Romaji and US keyboard layouts.
    I tested all of those and only Korean did not corresponded to the short cuts such as command+w for closing tabs.

    Hiragana with Romaji (roman letter) was fine and I guess because its primary input source is roman letter.
    So, there might be same issue for the all other languages that does not use roman letter as their primary input source.

    I hope this gets sorted out quickly.

    p.s. I have same zooming issues as well. It does not zoom in but only zoom outs. It only functions under roman letter as well though.



  • All right. Thanks for giving me another way to report the bug.



  • If the key returns alphabet, it's OK to use the shortcuts like the Pinyin-another Chinese input. If the key returns stokes or something non-alphabet, shortcut doesn't work


  • Moderator

    Your bug is VB-10624. So you can check if it has been resolved when a new version shows up.


  • Moderator

    Can you please check if it works in a clean profile? No one could reproduce it, except for the pinch bug.

    You can also try resetting your shortcuts before trying a clean profile.



  • Have you tried to type "Command + T" under Chinese Wubi Xing input or Korea Input? I am not the only one who has the same problem. Please check the reply of "like4009"in this thread.

    How can I make it work in clean profile? I have tested it in new installation. it doesn't work. Where is the profile file saved?

    I also tried to restore the shortcuts keyboard to default. problem still there



  • I have the same problem when using Cyrillic input method. Shortcuts only seem to work when you use latin-based input.


  • Moderator

    Open the About page. vivaldi://about

    There you can see where the user profile is saved, rename this directory and re-run Vivaldi, it should re-create a new, clean profile.



  • Still don't work. Even the updated release


  • Moderator

    Have you tried with a clean profile?

    Anyway, the team has acknowledge of the problem and is looking at it.



  • Yes, I tried. Still don't work.
    Thank you for your clarification. I am very glad with what you did. That's kind. If this problem is resolved, I will put safari aside.



  • This doesn't work with the Greek input source as well (and I can imagine with others too). Tried with 1.0.340.7 beta and a clean profile.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.