Vivaldi using 90% CPU



  • Yup, I tried playing with Process Monitor too. It shows lots and lots of accesses to Databases.db file but deleting it or any other less frequently accessed files didn't solve anything.
    I also disconnected from the internet so Vivaldi couldn't connect to any potentially malicious page but I still got ~50% CPU usage.

    After some trial and error in profile directory, I found that my problem disappear if I delete both "clngd..." directory from Extensions subdir (it's Stylus extension) and all *.ldb files from Local App Settings subdir (Vivaldi settings).
    Deleting only one of them doesn't solve it for some reason.

    I didn't really help myself because by deleting those *.ldb files I lose my search engines anyway. I guess I'll have to copy & paste them all to Notepad and back manually.



  • @nSheep It shouldn't be necessary to delete the extension folder, just disabling the extension should be enough. Removing the extension in the UI will also do the same as deleting that folder.

    I assume you deleted the files from Local App Settings\mpognobbkildjkofajifpdfhcoklimli\ which is the Vivaldi "extension" settings, so you will lose settings doing that. It shouldn't really be necessary 😕

    I kind of suspect that since the databases.db files are related to the Vivaldi settings, that Sync is somehow involved. Sync has been down for me since yesterday, and it keeps retrying. But it doesn't translate into high CPU, at least on my system.

    Did you filter on Network events in ProcMon? It might give an idea what servers Vivaldi is connecting to, if it's sync-servers or something else. Make sure you've restarted V with no tabs or panels opened.


  • Moderator

    @Pathduck said in Vivaldi using 90% CPU:

    ...... that Sync is somehow involved. Sync has been down for me since yesterday,

    The mail service was affected as well.

    @Pathduck said in Vivaldi using 90% CPU:

    ........and it keeps retrying.

    did you logout followed by logon? If so, please file a bug see here

    Note: 23 replies and no fix that's too long, polluted with shots, and no solution, fix, workaround. We do everything to support/help.
    As my fellow @Gwen-Dragon didn't lock, I will follow her.



  • @Pathduck You're right. If I delete *.ldb from Vivaldi "extension" directory, run Vivaldi, disable Stylus extension in UI and restart Vivaldi, 50% usage is also solved. And settings deleted. 🙂

    The network usage was probably from the initial sync since I took screenshot quite quickly after launching Vivaldi. Looking at it now, it shows just zeroes.
    Sync status is incoming: 💤idle / outgoing: ✔ok (or whatever the English translation is), vivaldi://sync show everything ok, green, no problems or errors.

    @lamarca Is it a problem that I'm brainstorming and not having any solution? I decided I'll just delete my profile folder and that will be my solution. I use the same profile since maybe even before v1.0 so it needs clean start anyway. 🙂 Sorry!



  • @nSheep Ok so that's good. Probably it's the Stylus extension then. Too bad though, as it's a very useful and common extension. Maybe you can try to reinstall it after you've started with a clean profile.

    As I said I don't think deleting the LDB files should be a solution, but if it works for you that's fine .... 🙂

    @lamarca I don't really see the problem of threads becoming long. Trying different possible solutions is all part of the troubleshooting process and this takes time. The main problem here is that nPro "jumped" an old thread, when a new thread should've been opened for the new unrelated issue. We've not heard from the thread starter for two weeks which either means they've solved it or given up...


  • Moderator

    @nSheep said in Vivaldi using 90% CPU:

    Is it a problem that I'm brainstorming and not having any solution

    First of all, you are far from brainstorm me.
    Secondly, {{every}} problem has to be a solution.
    Last but not least, we do everything to keep the user happy. Specifically in your case, the issue is not related to Vivaldi.


  • Moderator

    @Pathduck Neither do I. High Cpu Usage differs from machine to machine.



  • @Pathduck said in Vivaldi using 90% CPU:

    The main problem here is that nPro "jumped" an old thread, when a new thread should've been opened for the new unrelated issue.

    Yeah, you're right, I'm just too used to from other forums not to "spam" new thread for similar looking issues. However I'm sure mods can split this topic and then lock "my thread" since my issue was solved by deleting profile.

    @lamarca said in Vivaldi using 90% CPU:

    Specifically in your case, the issue is not related to Vivaldi.

    Vivaldi using 50% of CPU when idle is not an issue related to Vivaldi? Brilliant! 🤣


  • Moderator

    @nSheep said in Vivaldi using 90% CPU:

    Vivaldi using 50% of CPU when idle is not an issue related to Vivaldi?

    Yeah, actually, probably not. Idle Vivaldi here uses 2% of CPU, suggesting the problem is probably not Vivaldi, but Vivaldi+something.


  • Moderator

    @Ayespy I don't agree. It's the same to say Vivaldi is not directly responsible for using swap. The user did not provide the steps to repro, neither the Sys Specs. Vivaldi is not the cause, it's the effect placed in the user machine, who did not provide the steps to {{reproduce}} the resource hog.

    Edited: grammar


  • Moderator

    @lamarca My comment was in agreement with yours.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.