2.10.1745 has stuttering and blackouts



  • The latest upgrade has been causing problems such as stuttering video playback, stuttering scrolling, and occasional blackouts (i.e. empty screen). I noticed the same problem occurring with Chromium 79 so this may be a Chrome problem which is then reproduced by Vivaldi. Oddly enough, this behavior seems to come and go; last night, I had a lengthy period of trouble free browsing, but today, the problems are back.

    I'm wondering whether I'm the only one noticing this, and if not, whether there are any ideas as to what might be causing this.


    modedit change to a useful title


  • Moderator

    @sobermadman
    Welcome to our Forum. 🙂

    Here are a few links for your bookmarks that you may find useful:

    Do not hesitate to ask, we are a community to help users.

    Enjoy browsing.


    Sorry to hear you hvae now some trouble after update.

    stuttering video playback, stuttering scrolling, and occasional blackouts (i.e. empty screen). I noticed the same problem occurring with Chromium 79 so this may be a Chrome problem which is then reproduced by Vivaldi. Oddly enough, this behavior seems to come and go; last night, I had a lengthy period of trouble free browsing, but today, the problems are back.

    Your issue looks like broken graphics driver/missing hardware acceleration by GPU, much memory usage or browser extensions.

    Please tell us more about

    • Vivaldi version
    • browser extensions
    • memory usage (in Vivaldi Shift+Esc for taskmanager)
    • Linux version and architecture
    • Desktop
    • graphic hardware (GPU/CPU)
    • graphics driver
    • vivaldi://gpu (section Graphics Feature Status)


  • @sobermadman said in 2.10.1745 has stuttering and blackouts:

    change

    @Gwen-Dragon - Thanks for your reply. I've tried this latest version of Vivaldi (2.10.1745.21) on Linux Lite 3.8 and MXLinux 19, using a built in graphics chip AMD A8-6500T APU. On both platforms, similar behavior; Linux Lite uses an old 4.4x kernel, MX runs on 4.19, so not a kernel issue.

    Nor has it anything to do with extensions as far as I can tell, I tried new profiles, getting the same issues. All previous versions of the browser worked flawlessly, and I hate having to revert to Firefox for now, but it is working, whereas the constant hiccups, freezes and whatnot make Vivaldi 2.10 too much of a challenge. (Incidentally, chromium 78 works fine on MXLinux. So I suspect it might be something to do with Chromium 79).



  • Here's an indication that this may indeed by a Chromium problem:

    https://support.google.com/chrome/thread/23283471

    This would indicate that the problem affects quite a number of people; the symptoms they describe echo more or less the ones I've been experiencing. So maybe all that can be done is to wait for an upgrade.



  • More evidence that Chrome/Chromium may be the base of this problem:

    https://forums.linuxmint.com/viewtopic.php?t=307061

    Is there any indication that Vivaldi recognize the problem? I'm currently using Firefox which is running fine, and in my Virtualbox Manjaro install I'm retaining Vivaldi 2.9 which runs flawlessly. Hoping very much this will get fixed so I can use Vivaldi's latest version everywhere 🙂



  • So there's been a minor update of the Vivaldi 2.10 series, alas the problem persists. I've now uninstalled the 2.10 version and installed 2.9.1705.41 from a deb file. Working flawlessly. I've also put Vivaldi on hold so I won't be getting any upgrades for the time being.

    It would be very helpful to have some kind of official response, or at least some info once the problem has been solved, so the latest version of the browser may be installed again. It's a very fine browser and I'd like to be able to use its up-to-date version.



  • @sobermadman I'm also experiencing these problems - Just added a new thread.



  • I've now discovered a kind of work around: When a freeze occurs, right click (sometimes, double right click) your mouse - that resolves it. It's a pain because it always brings up the menu, but at least it helps get the thing moving again.


  • Moderator

    @sobermadman If you created a bug report please post the VB-xxxxx number you got by report mail. I could ping some internal Linux testers to check.



  • @Gwen-Dragon - Yes I did post a bug report, and got this number: VB-61855. Thanks for your assistance!



  • Now in terms of getting rid of the freezing etc, this solution is a little weird but it seems to work. I tried it on a fresh install of Vivaldi (Snapshot) 2.11.1792.3 which I'd put on one of my Virtualbox installs just to see if the 2.11 version was doing any better then the 2.10 one.

    It wasn't - just like 2.10, it proved to be all but unusable, especially on sites like youtube, or when writing text. Then I came across this solution in a Google Chrome forum bursting with reports of the problem (affecting all manner of Linux distros both in Virtualbox guests and on "real" hardware).

    What you do is, you let the Task Manager run (you'll find that in Settings/Tools/Task Manager, or just hit Shift+Esc). Leave the Task Manager running, DO NOT MINIMIZE IT.

    And that's it. Vivaldi 2.11 has been running for an hour, I'm writing this using it, which previously would have been impossible - all good so far, and while I haven't the faintest idea which the Task Manager being open should fix it, fix it it does, or so it seems. It also - as far as I can tell - repairs Google Chrome 79. As for Vivaldi 2.10 & Chromium 79 I have yet to see, but right now I'm hopeful this is a weird but effective way around the problem, allowing me to use the latest stable version of what still is my favorite browser.



  • Just to confirm that for me, this workaround also resolves the problem for the current stable version 2.10x. There are occasional minimal freezes when watching videos but compared to previously it's negligible. Everything else is running smoothly.

    Not even beginning to speculate about why this workaround is effective - but perhaps people who understand these things will come up with an explanation and a permanent fix.


  • Moderator



  • @Gwen-Dragon - Actually, I now agree it's got something to do with how Virtualbox deals with the latest browser versions - up to now, that had seemed to be highly implausible, given all prior versions ran smoothly. However, on my host machine Vivaldi 2.10xxx is now running smoothly while in VB it continues with problems (unless, as I described earlier, the Task Manager is kept running).

    I assume there must have been a coding change in the Chrome base or something which has led to Virtualbox suddenly having difficulties coping. But, being a technical idiot, I won't speculate any further 🙂



  • At the risk of boring everyone to death with this issue - if there's positive feedback to be shared, it ought to be shared, right?

    So I've been running Vivaldi snapshot 2.11.1800.5, and the problems seem to have disappeared. Everything is running smoothly, including videos and writing in text forms (as I'm currently doing): no stuttering or freezing any more. I should add this is in Virtualbox, but the same version of it as before when things went badly wrong. Plus I am not keeping the Task Manager open (previously a good work-around).

    So either this is pure coincidence - or something has changed in the coding. Anyway, browser's been going entirely hassle-free for two hours, and things are looking good 🙂


  • Moderator

    @sobermadman Thanks for report.
    Yes, works again with 2.11 Snapshot + 3D accel on Linux guest with VirtualBox 2.10.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.