Vivaldi changes windows power plan



  • In Windows 10 I have a Custom Power Plan that I have long kept as the active plan. Recently I noticed that whenever I have Vivaldi running, and the Vivaldi window is made the active window, the active power plan switches from My Custom Plan to "High Performance." I can't find a setting in Vivaldi, in Windows, or in NVidia Control Panel, that accounts for this behavior. If I move my mouse pointer to a non-Vivaldi window and click on that window, the power plan returns to My Custom Plan. I know this is happening because, with a "power options" window open (Control Panel > power options), I can see the highlighted radio button switch between My Custom Plan and High Performance depending upon whether a Vivaldi window is the active window or not. Also, I have verified that the setting change to the settings that are in the (automatically) selected plan. The way I learned this was happening, is when I noticed that my computer wasn't going into sleep mode, even though my Custom Plan called for this to happen. I just recently noticed this behavior. In the past, my computer usually went into sleep mode, per the instruction in My Custom Power Plan. I recently added a second display screen, plugged a second screen into my NVidia graphics card. I think this behavior started after I did that, and perhaps it may have been a result of that.



  • @nomenclator I don't think this is something Vivaldi does, but check your Windows Settings > System > Display > Graphics Settings.

    See: https://www.ghacks.net/2018/11/30/assign-graphics-performance-preferences-windows-10-programs/


  • Moderator

    I never saw Vivaldi switching the power plan. I have a NVidia card and mine stays always Balanced.



  • @Pathduck I've seen that graphics settings page before and I've never been able to make any sense out of it. The link you gave me isn't helping. On the windows graphics settings page there is a dropdown menu with the choices "classic app" and "universal app" but no explanation of what those choices mean. Also, something new, Vivaldi now only switches the power plan if it is active full screen. If I change the Vivaldi window to "resizable" (by R-clicking on the pictograph of 2-squares pictograph at the upper right, between the "-" pictograph on the left and the "X" pictograph on the right) my power plan changes back to My Custom Power Plan.



  • If I go to windows "settings > system > display and in the dropdown box labeled "multiple displays" I select only one of my 2 displays, I no longer have the problem. So I was right, this problem arose after I added a second display. If I return the dropdown box to "extend these displays" the problem returns. Also, you are given a choice as to which display you want to be your "main display." It is only possible to see the problem if Vivaldi is on the "non" main display, and I am viewing control panel > power options on the main display. Makes no difference which display I make the main display. Also, it may well be that the power plan changes if I am using only a single display, but there is no way to tell, because it had only been changing when Vivaldi is full screen, and if Vivaldi is full-screen, then it will block out the control panel > power plan screen, and I won't be able to see if the plan has changed to "high performance" or not.



  • @nomenclator Classic app is a regular Windows application. Universal app is the name MS uses for the apps on the Windows Store. If you have no settings there, then that's not the issue.

    The full-screen thing might be a clue. Maybe there's something on your system which detects something full-screen as a "game" or something that needs more power for some reason.

    Before someone else is able to reproduce, and not knowing anything more about your system, it's hard to guess. I'd take a long look at what other things you have running which might cause this. Maybe a graphics card setting?

    Try turning off hardware acceleration in Vivaldi (Settings > Webpages) and see if that helps.

    Is this a laptop or desktop computer?



  • @Pathduck I have tried a few other programs, and so far it is only Vivaldi, displayed full-screen, that changes the power plan.



  • @Pathduck In windows I went to settings > system > display > graphics settings and chose classic app, then browsed for vivaldi, and set it as follows: graphics specs.png

    but Vivaldi, when active and in full screen mode, still changes the power plan from My Custom Plan to "High Performance!" – even though according to the this windows setting it should choose "Power Saving." I tried restarting Vivaldi.

    Next I am going to remove Vivaldi from windows "graphics settings" and then, I am going to change multiple displays from "extend these displays" to "show only on 1. Then I am going to use My Custom Power Plan and configure My Custom Power Plan to put the computer to sleep after 1 minutes – and that way I'll be able to tell if my Custom Power Plan is still in effect when I go to Vivaldi full-screen. If my computer goes to sleep I'll know my plan is still in effect. If it stays awake for more than a minute that means windows has switched the power plant to "high performance" (which has the sleep timer set to "never").



  • OK, when using a single screen, and My Custom Power Plan set to put computer to sleep after one minute, my computer did go to sleep after a minute of inactivity, even with vivaldi the active program, and full-screen. so the problem has something to do with having 2 screens. Yet I can't find anything in NVidia Control Panel to account for this power plan change, or in Windows, or vivaldi. I am going to update the Nvidia drivers to the latest and see if that helps (I have the next to the latest).



  • Updated NVidia drivers but it didn't help.



  • @nomenclator Just FYI I run a three-monitor setup and I've never seen this. Also Nvidia (GTX970). Something else must be going on, but no idea at this point what.

    Do you have other Chromium-based browsers installed, like Opera or even Chrome? Does it happen with those as well?

    EDIT: Are you running Avast by the way?
    https://help.avast.com/en/av_free/17/performancegaming.html

    Trigger high performance (for laptop users): switches the power plan to the highest performance setting.



  • @Pathduck said in Vivaldi changes windows power plan:

    @nomenclator Just FYI I run a three-monitor setup and I've never seen this. Also Nvidia (GTX970). Something else must be going on, but no idea at this point what.

    Do you have other Chromium-based browsers installed, like Opera or even Chrome? Does it happen with those as well?

    EDIT: Are you running Avast by the way?
    https://help.avast.com/en/av_free/17/performancegaming.html

    Trigger high performance (for laptop users): switches the power plan to the highest performance setting.

    I have Avast installed and running but it doesn't seem to have a game mode (at Avast > performance >)

    I'll start chrome and see what happens. I haven't updated Opera recently. I probably have a version that is about a year old.



  • @Pathduck said in Vivaldi changes windows power plan:

    @nomenclator Just FYI I run a three-monitor setup and I've never seen this. Also Nvidia (GTX970). Something else must be going on, but no idea at this point what.

    Do you have other Chromium-based browsers installed, like Opera or even Chrome? Does it happen with those as well?

    EDIT: Are you running Avast by the way?
    https://help.avast.com/en/av_free/17/performancegaming.html

    Trigger high performance (for laptop users): switches the power plan to the highest performance setting.

    I started chrome and I didn't have any problem with it causing the power plan to change.



  • @nomenclator In the later versions of Avast it's called "Silent mode" or "Do not disturb" mode. If you have Avast, I'd say it's a big chance this is what's causing it.

    What version do you have of Avast? I have the Premier, it looks like this, there's a maximise performance setting:

    alt text



  • @Pathduck That seemed to do the trick Pathduck. In Avast I turned do not disturb mode for Vivaldi to OFF and now the Windows power plan is not being changed from My Custom Plan to the "high performance" plan when a Vivaldi window is active and in full screen.

    How did you figure this out.? Power plans are not "notifications" from third party apps.

    What I have is Avast Free Antivirus by the way. It is configured with do not disturb set to ON for Chrome but its not causing any power plan changes for chrome. Or for Firefox.



  • @nomenclator Glad it helped! 🙂

    I just googled "change power plan for fullscreen applications" and it lead me to this:
    https://www.tenforums.com/performance-maintenance/81665-power-plan-automatically-changing-game-launch.html

    When I read Avast there I had a "D'oh!" moment as I remembered this setting. In fact it caused issues with Irfanview, so I had to explicitly disable it. Actually this type of intrusive guessing of what the user wants and then silently overriding stuff is one of the reasons I'll probably not renew my license for Avast when the time comes.

    As for Chrome+Firefox: Have you checked whether the "Maximize performance" setting is checked for those, under the "..." menu next to the On/Off button?



  • @Pathduck said in Vivaldi changes windows power plan:

    @nomenclator Glad it helped! 🙂

    I just googled "change power plan for fullscreen applications" and it lead me to this:
    https://www.tenforums.com/performance-maintenance/81665-power-plan-automatically-changing-game-launch.html

    When I read Avast there I had a "D'oh!" moment as I remembered this setting. In fact it caused issues with Irfanview, so I had to explicitly disable it. Actually this type of intrusive guessing of what the user wants and then silently overriding stuff is one of the reasons I'll probably not renew my license for Avast when the time comes.

    As for Chrome+Firefox: Have you checked whether the "Maximize performance" setting is checked for those, under the "..." menu next to the On/Off button?

    No, in the Avast "Do Not Disturb" window "maximize performance" is not checked for Chrome or for Firefox. However even though I have turned "do not disturb" OFF for Vivaldi, "Do Not Disturb" is still checked. Also, although 'change power plans" is specifically mentioned in the tenforums.com page you linked to, in my version of Avast it referred to so vaguely that it isn't clear what is being referred to. If I hover over "maximize performance" I get the balloon message "when full screen, run this app in high priority mode and switch Windows to high performance mode." It doesn't say "high performance power plan;" rather, it says "high performance mode." Like, I asked myself, "what, what is high performance mode?" There was no way for me to know it was high performance power plan that was being referred to by Avast. In my mind a "mode" is a vague term that could refer to anything. Avast didn't say power plan so I didn't think power plan.



  • @nomenclator said in Vivaldi changes windows power plan:

    No, in the Avast "Do Not Disturb window" "maximize performance" is not checked for Chrome or for Firefox.

    Well, that explains why it doesn't trigger with Chrome or Firefox 🙂

    However even though I have turned "do not disturb" OFF for Vivaldi, Do Not Disturb is still checked.

    I assume you mean "maximize performance" there at the last bit? Try turning the knob for Vivaldi to ON but UN-check "maximize..." as I believe that's the setting which causes the issue. If you have the knob turned to OFF that setting isn't valid anyway.

    Or just disable the whole "feature" in Avast if possible and don't worry any more about it. That's what I've done, I have no need for that one anyway.



  • @Pathduck Sorry, that was one of my peculiar typos. I meant "maximize performance is still checked" but for some reason, that I don't understand myself, I substituted "do not disturb" for "maximize performance"– and I wrote "do not disturb is still checked."

    I think that's what I'll do, disable the whole feature – I was a bit "disturbed" by the checkbox in Avast that says "automatically add new apps. Any app running fullscreen will be added to your Do Not Disturb list." Also very annoying was the fact that if you go to Performance > Do not disturb mode – bringing up the page where a number of apps are listed – and then you click the gear icon in the upper right to get to another page – also labeled "Do Not Disturb Mode," but containing checkboxes instead of ON-OFF swithes, including the "automatically add new apps" checkbox, there is no obvious way to get back to the previous window. No back-arrow, and clicking on "performance" on the left does nothing. You have to click the X in the left-hand corner to get back to the list of apps? I didn't expect that. The window with the checkboxes lbeled "do not disturb mode" completely covered, completely obscured, the window with the list of apps, labeled "do not disturb mode." Not the most elegant interface. However many of the free anti-malware programs that are available seem to be horribly inelegant. I tried one a while ago that was removing some executables without first asking permission to do so, even though I had it configured to "always ask."


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.