Vivaldi Repository Timeout


  • Banned

    Just got the following in both Discover and in UCareSystem-Core and Vivaldi / Vivaldi Snapshot were updating fine. I'm running Kubuntu 19.10.

    UCareSystem-Core

    Ign:18 http://repo.vivaldi.com/snapshot/deb stable InRelease        
    Ign:19 http://repo.vivaldi.com/stable/deb stable InRelease
    Hit:20 http://repo.vivaldi.com/snapshot/deb stable Release
    Hit:21 http://repo.vivaldi.com/stable/deb stable Release
    Err:24 https://repo.vivaldi.com/archive/deb stable InRelease
      504  Gateway Time-out [IP: 23.111.9.47 443]
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    All packages are up to date.
    W: Failed to fetch https://repo.vivaldi.com/archive/deb/dists/stable/InRelease  504  Gateway Time-out [IP: 23.111.9.47 443]
    W: Some index files failed to download. They have been ignored, or old ones used instead.
    

  • Moderator

    I get no problems on my Debian 10.2.

    test@debby:~$ sudo apt update
    [sudo] Passwort für test: 
    OK:1 http://security.debian.org/debian-security buster/updates InRelease
    OK:2 http://deb.debian.org/debian buster InRelease                                                                       
    OK:3 http://deb.debian.org/debian buster-updates InRelease                                                               
    Ign:6 http://repo.vivaldi.com/snapshot/deb stable InRelease              
    Ign:7 https://repo.vivaldi.com/archive/deb stable InRelease
    OK:8 https://repo.vivaldi.com/archive/deb stable Release
    Ign:11 http://repo.vivaldi.com/stable/deb stable InRelease
    OK:12 http://repo.vivaldi.com/snapshot/deb stable Release
    OK:13 http://repo.vivaldi.com/stable/deb stable Release
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Alle Pakete sind aktuell.
    test@debby:~$
    

    //EDIT:
    Which repos are shown with:
    apt-cache policy


  • Banned

    Your Debian doesn't use PPA's. Can you please list the current PPA / PPA's for Stable and Snapshot and i'll replace mine to see if that corrects the problem. Shouldn't affect the installs, right?


  • Moderator

    @LordOfTheNet1 There are no PPAs for Vivaldi needed.

    My sources.list.d:

    test@debby:~$ cat /etc/apt/sources.list.d/vivaldi*.list
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    deb http://repo.vivaldi.com/stable/deb/ stable main
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    deb http://repo.vivaldi.com/snapshot/deb/ stable main
    test@debby:~$
    

  • Banned

    I added BOTH the stable and snapshots via ppa and want to keep it that way, so please once again provide the current ppa's, thasnks.

    EDIT:

    If i remove the ppa rep[ositories and edit my list to include your below lines all should be good?

    deb http://repo.vivaldi.com/stable/deb/ stable main
    deb http://repo.vivaldi.com/snapshot/deb/ stable main
    

  • Moderator

    @LordOfTheNet1 Yes, the two lines are ok.


  • Banned

    @Gwen-Dragon said in Vivaldi Repository Timeout:

    @LordOfTheNet1 Yes, the two lines are ok.

    So just to varify:

    Open synaptic and remove the Vivaldi PPA's
    Open sources.list.d and add those two lines
    Then my currently installed Vivaldi and Vivaldi-Snapshot should update without issue?


  • Moderator

    @LordOfTheNet1 said in Vivaldi Repository Timeout:

    Open synaptic and remove the Vivaldi PPA's

    Yes.

    Open sources.list.d and add those two lines

    No. sources.list.d ist not a file.
    Please put the lines into file /etc/apt/sources.d/vivaldi.list

    Then my currently installed Vivaldi and Vivaldi-Snapshot should update without issue?

    Try it, it works:

    sudo su
    apt clean
    apt update
    apt reinstall vivaldi-stable vivaldi-snapshot
    

  • Banned

    Thanks looks like it worked like a charm.


  • Moderator

    @LordOfTheNet1 Fine.
    Have a nice day, i wish you surfing without any issues.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.