[SOLVED] Video had stopped, codecs replaced, video and sound resumed, now sound has stopped



  • Vivaldi-snapshot had been working normally for months, but earlier today I got a popup telling me that the proprietary codecs were missing. On the Vivaldi video test page, neither video nor sound were working.

    In terminal, I entered this:

    sudo /opt/vivaldi-snapshot/update-ffmpeg
    

    and then both sound a video began working, on the test page and elsewhere..

    After running for a while, I noted the sound (only) had stopped. I again opened terminal, and (again) entered the same command as before, with this result:

    sudo /opt/vivaldi-snapshot/update-ffmpeg
    [sudo] password for ron:
    Proprietary media codecs (78.0.3904.70) was already present
    

    Now, going back to the same test page (link was given above) the video continues to work, but the sound does not.

    • Can anyone help me to trouble-shoot this problem?

    Info:
    v.2.9.1732.13 (Official Build) snapshot (32-bit)
    Revision: 64ba84ac0180440a314621f1cc84f150f66cbcad

    P.S.: I exited Vivaldi and loaded, in sequence, both Chromium and Firefox. In these browsers, I have both normal video and normal sound.



  • Hello there,

    You didn't tell us your Distro.
    The second point release of Debian, my audio was mute.
    Does Vivaldi run the test case bellow? Mainly the first one.



  • Hi @lamarca , thanks for offering to help!
    I'm running Linux Mint 17.3.
    I should have mentioned there was no change in the operating system between sound and video working, after the first codec update, to now, with only the video playing silently.

    By the way, I just completely rebooted the OS and reloaded Vivaldi. I also reinstalled Vivaldi, in Synaptic. There's still no sound.

    Also, I have opened the Vivaldi codec test page (see second sentence in original post) in Private Mode and it's the same: the video plays to completion, but without sound. Earlier, the sound was working.

    You wrote,

    • "Does Vivaldi run the test case bellow? Mainly the first one."

    I don't see anything below. Were you intending to include a link in your message, or are you referring to something farther down the page? If so, kindly indicate where. At the moment, I'm at a loss.



  • @PearlOfAtlantic (me) wrote:
    I am now doing an internet search on the terms, vivaldi no sound.

    I have located test page titled, "Tek Eye" and all the videos play without sound. I assume one is supposed to hear a waterfall-sound?

    The Vivaldi tab is not muted.





  • There is also a test case for audio.
    http://hpr.dogphilosophy.net/test/



  • @lamarca said in Video had stopped, codecs replaced, video and sound resumed, now sound has stopped:

    There is also a test case for audio.
    http://hpr.dogphilosophy.net/test/

    I now have Vivaldi and Firefox running simultaneously, in different windows, with 'dogphilosophy' loaded into both.

    Firefox: plays all files, except for the last one: CAF file (".caf"). Normal volume, and clarity on all supported files.

    Vivaldi: plays none of the files. In other words, complete silence when the 'play' icon is clicked.

    It is hard to believe, but Vivaldi was working a day ago. But, if I recall, did I see something in the Mint System Updater, to the effect that a new snapshot may have come down the line?

    If I want to return to the previous snapshot, can that be done through the terminal? There is a thread on the forum for how to do this, but it's for MS Windows.

    Any hints applicable to Linux Mint would be appreciated.



  • @PearlOfAtlantic (me), still looking on the full internet and have located an internal flag that someone 'Enabled' to solve a similar problem:

    • chrome://flags/#try-supported-channel-layouts

    A search does not locate the same, or a similar flag, in the Vivaldi I am running.



  • @PearlOfAtlantic (me again): I have opened Pulse Audio Volume control but see no per-application settings. No mention of Vivaldi.



  • I am came across a post saying Vivaldi was muted in System Settings (probably, applies to MS Windows) but looked into the KDE System Settings folder and could find nothing that mentioned Vivaldi.



  • @PearlOfAtlantic wrote:
    I now have explored all references DDG has to offer, and am now down to getting 'hits' for Vivaldi's Four Seasons. 😵

    So, having expended the resources of the internet, I turn to the Vivaldi experts on this forum to point me in the right direction.

    What is the next troubleshooting step??



  • @PearlOfAtlantic said in Video had stopped, codecs replaced, video and sound resumed, now sound has stopped:

    I am came across a post saying Vivaldi was muted in System Settings

    The last point release (from 10.1 to 10.2), Buster restarted with no audio. Mint is based on xbunbtu. I had the impression it is at your settings.
    A quick and easiest way to find out: starting Vivaldi from the scratch using the command line. It's temporary.

    vivaldi-snapshot --user-data-dir="/tmp/TEST-VIV" &
    

    If the new install runs fine, then the issue lies on your profile.


  • Moderator

    I tested with a fresh install of Mint 17.3 Rosa and installed Vivaldi 2.9 Stable, sound is ok.



  • @lamarca , @Gwen-Dragon , many thanks for the excellent tech support and I'll make notes of your suggestions -- for future use.

    This morning Mint Update showed a new Snapshot was available, so I selected it and allowed it to install.

    On the first run of Vivaldi, after that, everything was back to normal. I have sound and video on all the test sites previously linked in this thread, as well.

    Fortunately, I didn't do anything drastic to my system, so there's nothing that has to be repaired.

    I'm waiting for December 10, to move to the stable version. My installing Snapshot happened almost accidentally after I discovered some video wasn't playing on Stable, thought I'd see if Snapshot worked, and then after I saw the message in terminal I realized I could have also fixed Stable in the same way, but thought it easier to leave it 'as is'.

    The potential for regressions didn't occur to me then, but I now see that working them out can take quite a bit of effort and time. Perhaps it would be best just to ignore further Snapshot updates, until the final Snapshot becomes 'Stable'? I'm guessing that may the way it works.


  • Moderator

    @PearlOfAtlantic Fine, you solved it by some magic 🧙 or by luck ☘🍀



  • @Gwen-Dragon, thanks again, but maybe I should wait to see if this survives a program exit, OS reboot, and program reload, before I celebrate!


  • Moderator

    @PearlOfAtlantic Then try a cold boot. Good luck.



  • @Gwen-Dragon , thanks for the follow-through.

    Yes, followed your directions and the audio/video test sites in this thread are still working after a cold system start.

    My suspicion is that loading today's Vivaldi Snapshot fixed it, just based upon when things resumed working. Maybe I'm the only one that noticed it. Could be something peculiar to my setup that 'disagreed' with some code changes in it.

    I am very pleased with the level of Vivaldi tech support! I'll be coming back with a new thread to see if I can get help with making a synced Kanban Extension run on Vivaldi, instead of my having open to Chromium, for just that one item.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.