Vivaldi 2.9 RC 2 – Vivaldi Browser snapshot 1705.30



  • The problems with Youtube's Picture in Picture persist for a maybe 5-6 builds now. It seems related to the resolution. Turning off hardware acceleration in settings, clean install (even on clean OS), standalone install - nothing helps.
    I've made a short video to capture how this issue looks. Unless I change resolutions, I get get a white or black rectangle, with sound, where the PiP should be. Can't move it, like with PiP video, can't click what's behind it.
    this is happening on a Z370 platform with a 8700K CPU and 1070ti, both on 1903 and 1909 x64, and on at least 5-6 Nvidia drivers, even the old 388.13 drivers that were the first to support this GPU. PiP seems fine in 2.8, at least when I tested it a week or two ago.
    Is there any way to troubleshoot this further? Thanks.

    Video:
    https://youtu.be/kNd5-uxV0A8


  • Vivaldi Translator

    @iAN-CooG Or, keep using proper version numbers until many learn that version numbers are not floating point numbers. Allowing only 9 minor versions between major releases might be too restrictive (unless we want to basically go the route of "every release is a major release", like Opera or Chrome where version numbers are in the double digits).



  • @Komposten Adopt both from 3.0 -> 3.001; 3.002 ... 3.152 -> 4.0 🤣



  • @t0yz
    Hi, tested PiP on Windows 10 Pro 64 1903 updated and Vivaldi 2.9 RC 2 1705.30 and work fine.
    Tested on:
    Intel i5 3570K 16 GB RAM
    GTX 760 4 GB /Display card
    Driver 435.80
    Resolution 480, 720 and 1080p
    Hardware acceleration: On
    https://www.youtube.com/watch?v=mrEczg72V4M

    I have no idea why it does not work for you.
    May you open a new thread in the Windows section to get more testers.

    Cheers, mib



  • After installing the latest update, Vivaldi still doesn't reopen.



  • @mib2berlin Thanks.
    It "works" for me as well, provided I choose 240p first. After that, I can use my usual 1080p setting, but if I try 1080p when I first open the page, I get the black square.
    After I "encourage" Vivaldi to use PiP with 240p, it also works with 1080p and the other resolutions normally. If I close the tab and reopen it, I'm back at the blank/black rectangle and I have to go 240p again to "fix" it.
    I really have no idea what in the world can cause this, or what can interfere with PiP like this.
    Maybe there is some sort of log where we can see why PiP fails?
    This also occurs on other Chromium browsers, I tried Chromium Edge on 1903 with same results, so I assume it's from the engine itself.



  • @t0yz
    In addition to my post:
    I start a session in standard view, not full screen, and default resolution is 480p in the linked video for example. > PiP work > close PiP
    Change resolution to 720p > PiP work > close PiP
    and so forth.
    Do you change resolution during running PiP?

    Cheers, mib



  • @mib2berlin You can see the bug here:
    https://youtu.be/kNd5-uxV0A8



  • @schoerb said in Vivaldi 2.9 RC 2 – Vivaldi Browser snapshot 1705.30:

    After installing the latest update, Vivaldi still doesn't reopen.

    You're not alone. Chromium version 78 and later suffers from interactions with Norton/Symantec (which I have) and several other AV programs. There's a long thread on a Chrome forum https://support.google.com/chrome/thread/17555930?hl=en . One of the workarounds given for a non-starting Chrome is to start with" -disable-features=RendererCodeIntegrity" (without the quotes- note the space before the first hyphen). I did this with Vivaldi, appending the disable to the shortcut and it launches. Unfortunately, for me at least, Vivaldi opens with no passwords, and does not offer to save them, either. I haven't figured out why. For now I'm running a standalone version where everything works properly.



  • [BUG] "open saved session" ignores the "open session in new window" option DE-selection, in incognito mode

    1. start vivaldi in incognito mode
    2. open a saved session AND UNselect the "open session in a new window" option
    3. you'll see that Vivaldi opens a new window, instead

    Vivaldi shouldn't open a new Window, as I unflagged the option.

    can anybody confirm

    W10 x64, here.



  • @newscpq How are you starting Vivaldi in incognito mode?

    If I open a new private window from the task bar, the saved session opens in the current private window as requested.


  • Moderator

    @iAN-CooG said in Vivaldi 2.9 RC 2 – Vivaldi Browser snapshot 1705.30:

    remember that for many 2.10 == 2.1 hence older than 2.9

    Yes, these crazy people who compare versions as floating point numbers by JavaScript. They will never know what a version and sub-version number means.



  • Updated (with a slight delay) 👍
    Nice to see that menu icons are now dark friendly 👻



  • You broke middle click on speed dial tiles 😞
    Just in the latest test build.
    Hope it will not get into release.


  • Moderator

    Closed as 2.9 is Final is out with version 2.9.1705.31.
    https://vivaldi.com/blog/vivaldi-2-9-adding-more-to-the-vivaldi-menu-2/


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.