Regression fixes – Vivaldi Browser snapshot 1705.4


  • Vivaldi Team

    Today’s snapshot resolves a number of recent regressions, as we close in on the 2.9 final.

    Click here to see the full blog post



  • Fürst!
    thumbs nose at @olli



  • @pathduck: I´m getting old and slow 🙂



  • [Regression] Double clicking Vivaldi menu maximizes / minimizes window (VB-58980)

    good

    [Regression] Downloads do not start if opened in new tab (VB-58965)

    now works, it was getting annoying, many sites have the dl links opening in new tab automatically

    [Regression] Hidden extension buttons don’t show popups (VB-58918)

    works



  • @olli: 163th who viewed this post, but I updated before I read the post.



  • On MacOS Catalina I still can not zoom Windows with double-click. New entrys since Catalina "Arrange windows on the left side of the screen" and "Arrange windows on the right side of the screen" under the menu-bar menu "Windows" are appearing
    not just once, but several times. Clicking outside the window once (and then back) makes them two, as it shoud be. A bug or a regression?



  • Special hurrah for the VB-54949 fix! 🎆



  • I am still not able to download files from some sites e.g. contacts as a CSV file from Google.com contacts.



  • This is the third snapshot in a row which refuses to run on my system (Win 10 -64 pro, all up to date, only active extensions now are ABP and Disconnect). Downloads fine, installer seems to run normally, but Vivaldi will not run, either from the shortcut or directly clicking Vivaldi.exe. Disabling Norton antivirus and firewall has no effect. I see from the last two snapshot comments that others are having this problem also. Are we doing something dumb, or did some change two snapshots ago cause this? Help! I filed a bug report previously (VB-59025).



  • @justjohn try to install a standalone installation on your system to see, if your profile/config is broken



  • @justjohn Disabling Norton antivirus means almost nothing, antivirus rarely really disable themselves, except you manually stop ALL services (sometimes better to boot in safe-mode), and can interfere nevertheless in the background. Also Norton is notorious for being a badly coded AV, breaking stuff in the system and being the worst of all, why do you do that to yourself?



  • @justjohn This is the same problem that I have on my companies Laptop. I also tried a clean installation, but this doesn't help neither...



  • @justjohn it's either a profile problem as @npro suggests, or maybe you have set some vivaldi://flag previously which are now not supported and make Vivaldi go spaz.
    Some days ago I tried to set (don't do it) in flags #enable-force-dark and restarting, Vivaldi would crash as soon as the splash screen was shown.
    I had to manually edit "%localappdata%\vivaldi\user data\Local State" with notepad++ and JSON viewer to reset the setting to 0 and let Vivaldi actually start.
    In the past, when there were some weird profile corruption every 2-3 days, I had to rebuild the Default profile at least twice a week else Vivaldi would crash after 1 minute or less of use. Luckily it's a thing of the past, for me, but now and then some people still encounter this problem, and rebuilding and refreshing the Default profile surely helps.



  • VB-58897 is fixed but VB-59158 still not.
    isn't it considered as a duplicate?
    actually it's quite different!
    (any url in the other tab is not shown if loading was canceled)


  • Moderator

    @Vladimyr said in Regression fixes – Vivaldi Browser snapshot 1705.4:

    VB-59158

    Closed as Cannot Reproduce.



  • @justjohn: Same problem here, with all three latest snapshots.



  • Oh, this Snapshot, and the one before, is putting after every OS-restart a folder "Recovered files" into the MacOS trash-bin - with no files in the folder.



  • @iAN-CooG said in Regression fixes – Vivaldi Browser snapshot 1705.4:

    Some days ago I tried to set (don't do it) in flags #enable-force-dark and restarting, Vivaldi would crash as soon as the splash screen was shown.
    I had to manually edit "%localappdata%\vivaldi\user data\Local State" with notepad++ and JSON viewer to reset the setting to 0 and let Vivaldi actually start.

    yeah this is the best way to revert flags to default, it saved me lots of times as the --no-experiments command line switch is not working for a long time if I remember correctly. Speaking of it @Gwen-Dragon , @xyzzy is this issue listed in the bug catalog?
    But why scare the user with external programs like notepad++ and JSON lol, a simple edit with Notepad is enough.



  • My saved passwords are still missing (chrome://settings/passwords shows an empty list), as with other recent snapshots. Downgrading to 1675 brings them back.



  • Regression - favicon in tab is always reloaded when scrolling on this forum. It reloads when the last number in URL changes. I guess it is number of post. This not happens on stable version.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.