Vivaldi fails on Ubuntu 14.04 laptop w/nvidia graphics



  • Vivaldi does not open on my laptop running Ubuntu 14.04.3 32-bit. Using snapshot #252 (and others) Kernel: 3.13.0-62 GPU: Nvidia Quadro FX360M (driver vers: 340.76) Something crashes and/or hangs - I have to kill it manually. (see ps output below) Windows 7 32-bit on same machine (multi-boot) works just fine. Q: Are there any options/settings I can use to get more diagnostic info when I launch vivaldi? All I get from the console when it is launched is: [code][2986:2986:0828/135517:ERROR:nss_util.cc(845)] After loading Root Certs, loaded==false: NSS error code: -8018[/code] I really like Vivaldi and have been using in on a number of different machines/OSes without any (unusual) problems. This is the only configuration that doesn't work at all. Unfortunately, this is the machine I use most often. Any help would be greatly appreciated - ask for more data, etc... [u]ps output:[/u] [code] 21585 pts/1 Sl+ 0:00 /opt/vivaldi-snapshot/vivaldi-bin --user-data-dir=/home/thess/.config/vivaldi-snapshot --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so --ppapi-flash-version=18.0.0.233 21592 pts/1 S+ 0:00 cat 21593 pts/1 S+ 0:00 cat 21602 pts/1 S+ 0:00 /opt/vivaldi-snapshot/vivaldi-bin --type=zygote --user-data-dir=/home/thess/.config/vivaldi-snapshot --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so --ppapi-flash-version=18.0.0.233 21614 pts/1 S+ 0:00 / \opt/vivaldi-snapshot/vivaldi-bin --type=zygote --user-data-dir=/home/thess/.config/vivaldi-snapshot --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so --ppapi-flash-version=18.0.0.233 [/code]



  • FWIW - Chromium browser 44.0.2403.89 doesn't work either (Aw, Snap! is all I get for everything)
    Output:

    getrlimit(RLIMIT_NOFILE) failed

    Really!? On a 4GB machine!

    Is there a system limit that needs to be bumped?

    So I guess I'm stuck with a Chromium problem….



  • Works on my Ubuntu 14.04 with Nvidia GeForce GT 740M/PCIe/SSE2, but there are some minor bugs:

    1. The resolution is blown-up -I need to make pages at 80% to be 'normal'

    2. The Speed Dial bookmarks do not display thumbnail for any page I save

    3. Some Chrome extensions work, but some do not, like the ones that replace the speed dial tab, or mouse gestures, or grammarly one.


  • Moderator

    As to speed dial bookmark thumbs, it's not just you. They are broken for everyone in the last couple of snapshots. This will, of course, be fixed down the line.



  • Follow-up….
    Works with --no-sandbox option even though vivaldi-sandbox is owned by root and setuid (chmod 4755)

    Anybody know why and maybe how to fix system config.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.