Hyperlink Opens Another Vivaldi Instance



  • Hello - I have Vivaldi set as my default app for web browser. But when I click on a link in Outlook, Win10 opens another instance of Vivaldi, not the one that is currently running. This new instance has none of my settings, add-ins, etc, of my normal Vivaldi. If I change the default to another browser then back again, the results are the same. How do I fix this?


  • Vivaldi Ambassador

    I don't use Outlook, but maybe it depends on the network settings of Outlook or Windows and not Vivaldi's.



  • @Catweazle
    Right, but someone from the Vivaldi team must know what I need to change in the Win10 Registry to fix this.



  • This post is deleted!

  • Moderator

    @TonyK132 The correct registry key for Vivaldi Stable is:
    HKEY_CLASSES_ROOT\VivaldiHTM\shell\open\command
    (Standard)
    REG_SZ
    "C:\Program Files\Vivaldi\Application\vivaldi.exe" -- "%1"



  • @Gwen-Dragon That's not working. I have that key set as you show, but even after a reboot, it still opens another instance. I have Win10. Did something change with the latest versions that is causing this problem?


  • Vivaldi Ambassador

    But if it seems possible that the cause is some error in the registry. Do you have the CCleaner, or better the Glary Utilities? these can fix it, if the cause is this. The Windows registry has the bad habit of filling up with erroneous entries and all kinds of garbage over time, which can sometimes cause strange behaviors, as I have also experienced in the past, and therefore requires that it be checked from time to time ..



  • Thanks for the tip about the Glary Utilities. It found a bunch of problems with my registry. But it did not solve this one. I still get another instance of Vivaldi.

    BTW, I have a non-standard start line in the desktop version of the Vivaldi shortcut. Here is what I use:

    "F:\Program Files\Vivaldi\Application\vivaldi.exe" --disk-cache-dir=F:\temp\cache --user-data-dir=F:\Vivaldi

    My F: drive is an SSD. When I update Vivaldi, lately it's been using that string for the desktop shortcut, but it seems the registry keys are still wrong. I would want the hyperlink from Outlook to use that string, and therefore, use the existing running instance of Vivaldi. But with the recent changes to Win10, changing the registry keys does not seem to fix this issue.



  • Well then copy that line and add "%1" at the end and use it in the registry. Pretty simple.



  • Not so easy. I had already made that change before I asked for help.

    Also I just did a properties on the 2nd instance, and the command line is correct per my setting above.

    Update: Looks like I fixed it, although I'm not sure which key was actually the one that did it. I searched the whole registry for any key that contained vivaldi.exe, and changed all the command lines (not icon nor uninstall nor reinstall nor binary values) to the string above. So for now, I'm good.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.